Sign in with
Sign up | Sign in
Your question

Stubborn Dell optical drive problem - cdrom.sys the issue?

Last response: in Laptops & Notebooks
Share
July 12, 2012 2:33:08 AM

I have a Dell Inspiron N7110, Win 7 Home Professional. Possibly complicating this issue is an install of PowerISO. The DVD burning program is Roxio (I am at work now, can’t recall the exact program). As you will read below, I could not get into safe mode to isolate the problem.

The optical drive will not work. By that, I mean that it will not read a disc. I insert the disc, it whirs around, and then ejects it a minute or so later, usually with the pop-up prompt of something like “insert a disc in drive E:” after it gives up trying to read it. I have tried the device manager to uninstall / reinstall the drivers, and disabling the device, then rebooting. It seems to “reinstall” itself, and then not work in the same way again. Windows says the drivers are up to date. I have run the “FixIt” utility from Microsoft, but that did not help at all. I have gone into the registry and deleted the values of “upperfilter” and “lowerfilter” in 4D36E965-E325-11CE-BFC1-08002BE10318, and this did not help. Also, this is not a code 19 or code 32 error like I have read about in other forums. There are no exclamation points next to the device at any time in the device manager after the driver is installed, so Windows always been able to recognize the drive. I tried blowing out the drive too, but I didn’t think dust is really the culprit here. Finally, I tried running the computer in safe mode to test in that way, and the screen was all black. Only the touchpad would work. Maybe I entered safe mode wrong. System restore will not be any help. I rarely use the optical drive, but it is crucial at times. The last time I remember it working was about five months ago, so a “system restore” is not going to work.

This last bit though, I think I may be on the right track. I have gone into the “system32” folder, and saw the file “cdrom.sys”. I tried to cut it out of the system 32 folder, but it would not let me, saying I needed “TrustedInstaller”, whatever that is. I think this could be the problem, but I ran out of time last night and had to get to bed. :sleep:  Could cdrom.sys be corrupt? If it is, how would I get this file? From another computer? I have another Win 7 computer (a netbook with Win Starter) that I could get it from.

I am open to possible doing a reinstall of Windows (especially would be nice to get a clean install without all the Dell bloatware), but don’t I need the CD/ROM drive to do this?

Ok, maybe this is information overload, but I want give all the details. Thanks!
a b D Laptop
July 13, 2012 6:39:05 AM

I'll bet the either roxio or powerISO borked the cdrom somehow. If you boot off of your windows installation media you can do a fresh installation of windows.
m
0
l
July 13, 2012 9:29:14 AM

What do you mean by "Windows Installation Media"? You mean the factory disc? Or are you talking about clicking (F8 is it??) during the boot up, before the login screen appears?

m
0
l
!