Geforce GT 540M / Optimus won't work

Hi this should probably have been posted at the Nvidia forums, but it is out of sercive because it was hacked or somesuch. I also posted in the Laptop subforum - perhaps I should have chosen the Nvidia one? I was just thinking posting here would save me the mandatory "you shouldn't use a laptop for gaming" spam posts. I have tried to be somewhat detailed, so please bear with me.

I have an i5 2.3 GHz laptop with a Geforce GT 540M graphics adapter. This adapter is built with the "Optimus" function, which lets it switch between the Geforce adapter for 3D rendering etc. and the onboard Intel HD 3000 for lighter tasks (like Aero etc.) to optimize power consumption.

I am on Windows 7, and I have the latest set of Nvidia drivers installed (301.42).

Recently I have found out that my laptop solely uses the Intel HD 3000. I am going to use Skyrim as an example because it gives you a lot of easily accessible output, but I mostly play older games so I hadn't noticed this change.

First off, I have tried adding the skyrim, skyrim launcher and the skse (a script extender for mods) executable to the "whitelist" in the Nvidia control panel, and I have also tried setting the Geforce as the prefered graphics adapter under Global Settings. Also tried using the contextual menu (right clicking on the executable and selecting "run with Geforce GT 540M"). None of it changed anything the slightest.

When I load up the Skyrim Launcher it automatically detects my Intel HD, no matter what settings I have chosen in the Nvidia Control Panel - I seem to recall in the past having to use the Geforce as the prefered graphics adapter under Global Settings for Skyrim to recognize it, but that won't work anymore. I also seem to recall that hovering over the Nvidia icon in the task manager would show what programs are actively using the Nvidia GPU, and it would show that the Nvidia GPU kicked in if I ran a video with VLC or watched youtube. Now it constantly shows that 0 processes are running using the GPU no matter what I do.

I searched on the interweb and one guy said to change a line of text in Skyrim.ini and Skyrimprefs, substituting this:

Quote:
sD3DDevice="Intel(R) HD Graphics Family"

for this:

Quote:
sD3DDevice="Nvidia GeForce GT 540M"


I did that, but still get the same choppy framerate when running the skyrim or skse executable, and as soon as I start the Skyrim launcher it reverts it to the Intel HD in the ini files by itself.

Skyrim also makes a text file output with information about the renderer after running the game. When I messed with all the different combinations of settings I deleted this file each time, and each time I ran skyrim it generated this text file with information about the Intel HD. So it's safe to say that contrary to what Nvidia Control Panel settings is saying, Skyrim now uses the Intel HD solely.

Thing is, it wasn't always like this - I have noticed a bit of a performance drop (as I said I mostly play old and not so gpu-intensive games) lately, but I thouht that was just because Windows was getting cluttered up. When I take a look at the skyrimprefs.ini I used previously when the game ran fine, even the one I tweaked for performance, it had medium-ish settings, with DoF, Radial Blur and HDR lighting switched on. Now I run it on the lowest of low settings, and still get bad framerates.

I found other "solutions" on the net, one of which was to deactive the Intel HD and remove the Geforce in the device manager, restart and then reinstall the Geforce drivers (while keeping the Intel HD deactivated). All that resulted in was a messed up desktop (another article said that no matter what, the Intel HD will ALWAYS control the desktop/aero) with low resolutions that don't fit my 16:9 screen.

So I hope someone has experience with this and can help me out. Thanks.

P.S. Dxdiag also shows the Intel HD no matter what I do (except for when I deactivate the Intel HD in device manager - then it shows "Generic VGA adapter" or something along those lines).
20 answers Last reply
More about geforce 540m optimus work
  1. ALSO: I looked in the BIOS but no relevant options were available there.
  2. Update: I tried to:

    1. Remove all Nvidia drivers and install a previous version (296.10). No luck.
    2. Update from that to the newest version. No luck.
    3. Remove all Nvidia drivers again, and install the drivers from my laptop manufacturer's homepage. No luck.
    4. Updating from that set of drivers to the newest set of drivers. No luck.

    The Nvidia control panel keeps saying that the Geforce GPU is set as default, yet everything else (dxdiag + all the games I tried out) still disagrees with that.

    It's annoying that something that seems like some sort of software glitch effectively renders my graphics adapter (which I paid extra for back when I got the laptop) 100% useless.
  3. Bump
  4. same problem here!
    i'm thinking of a hardware failure
  5. Me too, but how do I confirm that it is a hardware failure for sure? Windows 7 makes absolutely no mention of any issues, and everything looks fine and dandy except that the GPU is NEVER active.
  6. Yeah, unfortunately this is a known issue nVidia Optimus. It does not seem to affect a lot of people, but enough that there many complaints.

    I just started to experience this on my Lenovo IdeaPad Y470. The only thing that fixed the issue was reinstalling Windows 7 from scratch. I recommend you do that and test if your nVidia 540 GT will work afterwards. If it does then update Windows 7 and install any programs that you generally use. Once your laptop has been fully setup to your liking you should make an image of your C: drive. This will serve as a baseline configuration for your laptop so if Windows becomes corrupted, the GT 540m stops working or you simply want a clean install, then you have a image of the C: drive already which will save you several hours of various software installation.

    I am guessing your laptop should have some type of backup software that allows you to create an image of the C: drive and save it to a separate partition, or allows you to create a bootable image to be burnt onto DVDs.

    Before creating an image I install Avast! Free, Malwarebtyes and Spybot and do a full system scan.
  7. Have you tried tweaking with the settings on NVIDIA Control Panel? (right click desktop -> NVIDIA Control Panel)

    On the "Manage 3D Settings" section, under the "Program Settings" tab, you can choose a program and set which GPU will it use.
  8. ^^

    Nah, usually when something like this happens Windows 7 fails to completely recognize the Nvidia GPU. Uninstalling / reinstalling the drivers doesn't even work. For me, a complete reinstall of Win 7 seems to be the only way to resolve the problem.

    Hopefully this is just a small hic-up with the nVidia GPUs. Otherwise, I'll need to make use of the extended warranty on my Lenovo Y470.
  9. jaguarskx said:
    Yeah, unfortunately this is a known issue nVidia Optimus. It does not seem to affect a lot of people, but enough that there many complaints.

    I just started to experience this on my Lenovo IdeaPad Y470. The only thing that fixed the issue was reinstalling Windows 7 from scratch. I recommend you do that and test if your nVidia 540 GT will work afterwards. If it does then update Windows 7 and install any programs that you generally use. Once your laptop has been fully setup to your liking you should make an image of your C: drive. This will serve as a baseline configuration for your laptop so if Windows becomes corrupted, the GT 540m stops working or you simply want a clean install, then you have a image of the C: drive already which will save you several hours of various software installation.

    I am guessing your laptop should have some type of backup software that allows you to create an image of the C: drive and save it to a separate partition, or allows you to create a bootable image to be burnt onto DVDs.

    Before creating an image I install Avast! Free, Malwarebtyes and Spybot and do a full system scan.



    @jaguarskx: which version of windows did u re-install?
    I just re-installed windows professional x64 (along with all the drivers) but the problem persists...... :(
    how to change view side of screen
    hiii pink27i know whats your prolem and there is a very simple solution for thaton your desktop right click and click on screen resolutiona window will open with 3 opting the third one is orientationin that there are four options {landscape , portrait... Read More
  10. I have win 7 home premium.

    It happened to me again, lasted September / October. I didn't make a big fuss about it since by that time I stopped playing games on my laptop because I just didn't have time to play and I didn't bother trying to re-install from a backed up image.

    I inadvertently fixed the issue when I decided to install Intel's latest HD 3000 drivers back in Janaury or February. I guess there is just some type of bad mojo between Win 7, Intel graphic drivers and nVidia graphic drivers. Yay!! My GT 550m works again!!! Too bad I don't have time to play games often.
  11. I have same problem, but I got the solution that just run your program with "Run as Administrator" and the program will detects Nvidia's GPU again.
  12. hi.
    i have the exact same problem... anyone has find a solution?
  13. Well, I'm am now thinking about sending in my Y470 for repairs under warranty. I paid the extra $100 or so for a 3 year warranty... so I might as well use it...
  14. Is there a way to confirm GPU usage?

    My Dell XPS l502x (intel hd graphics 3000 and nvidia geforce 540m) stutters with flash games (dirt bike is too addictive!).

    NVIDIA CPL has a whitelist type feature for 3D, but I want to know a) if "run with nvidia" works ! and b) if you set that as default behaviour

    chrome://gpu (even when running chrome with nvidia, via context-menu) always reports

    VENDOR = 0x8086, DEVICE= 0x0116

    thinking about opening process explorer and a chrome lab, try and find spikes.

    I just want a PC that always works!
  15. Peder_dingo said:
    ALSO: I looked in the BIOS but no relevant options were available there.

    Try to use nvidia Inspector! Here are steps if nvidia inspector supports skyrim(or any other game)!
    1. download nvidia inspector http://www.guru3d.com/files-get/nvidia-inspector-downlo...
    2. Open program and then find Driver (256 +) Profile settings( on the right from driver version, icon with screwdriver)
    3. From drop down menu select game you want
    4. Find option " Enable application for optimus"
    5.Then click " Enable application for optimus" and choose "SHIM_RENDERING_MODE_ENABLE" SettingValueHex is "0x00000001"
    6 Click apply settings and exit the program!
    DO this on your own risk!!! I have done this for Counter Strike 1.6 since last updates does not support optimus and game was running on intel hd 3000 so i had huge drops! I have never tested this on any other game so i don't know if it is going to work!!!
    HOPE I HELPED!
  16. my Acer 4755G have the same problem, how can i solve it?
  17. I SOLVED IT! I have tried all of the previous solutions but none of them worked. But then I tried running steam through the Nvidia processor by right-clicking the Steam.exe and selected "run with graphics processor" and chose Nvidia processor. And i also needed to start the game from the steam app and not from the .exe itself. This worked for me awesomely, and I hope it will work for you guys aswell!
  18. dukisha016 said:
    Peder_dingo said:
    ALSO: I looked in the BIOS but no relevant options were available there.

    Try to use nvidia Inspector! Here are steps if nvidia inspector supports skyrim(or any other game)!
    1. download nvidia inspector http://www.guru3d.com/files-get/nvidia-inspector-downlo...
    2. Open program and then find Driver (256 +) Profile settings( on the right from driver version, icon with screwdriver)
    3. From drop down menu select game you want
    4. Find option " Enable application for optimus"
    5.Then click " Enable application for optimus" and choose "SHIM_RENDERING_MODE_ENABLE" SettingValueHex is "0x00000001"
    6 Click apply settings and exit the program!
    DO this on your own risk!!! I have done this for Counter Strike 1.6 since last updates does not support optimus and game was running on intel hd 3000 so i had huge drops! I have never tested this on any other game so i don't know if it is going to work!!!
    HOPE I HELPED!



    This is what I used to do when Optimus randomly decided to stop working for VLC and Windows Media Player. And then it just stopped working a week ago. I did not download or install any software or update anything on my computer. All of a sudden, when I click apply changes and close out, the programs will not use Nvidia. And when I open Nvidia Inspector again, the settings have been mysteriously reverted back to "SHIM_RENDERING_MODE_EDITABLE"
  19. Hello (sorry, maybe my english is not perfect :) ), i had problems with some games since upgrading to win 10, i want to post my solution, maybe it helps some people.

    System is ASUS x73sv, i5-2410m ,Geforce GT 540m 1 Gb and Intel HD 3000, 8 Gb DDR-3 Ram

    I always had the problem, that older and newer games with DX 10 and DX 11 choose the slower Intel HD 3000
    (first on win 7 and then win 10 also, never tried on win 8). Flight Simulator X was the first game i recognized this, Direct X 10 ran on the slow Intel GPU, Direct X 9 ran on the Nvidia.
    Since upgrading to win 10, a lot Direct X 11 games running on win 7 fine ( for example Civilization V, Pinball Arcade) startet on nvidia gpu, but crashed on start. So i had to play these games in the direct x 9 mode.
    A lot of Direct X 11-only Games were not running,too,forcing them to start on nvidia.
    I tried almost all avaiable drivers (old and new) and hints, mostly there was no solution or not for all games.
    Running steam on nvidia gpu and then the game from steam helps in some cases, as already said, but not always.
    I don t like game boosters,they are senseless, but running razer cortex and then the direct x 10/11 games from of this tool helped me.
    In my example Pinball Arcade i also had to change a registry value (display adapter=2 ;;; 1 is Intel 2 is Nvidia) although in Nvidia Driver the Nvidia GPU is selected for all applications, otherwise the game only starts on Intel. Well, sometimes its obviously the game itself, causing the trouble and you have to find out, if there is an ini or registry setting ,because ingame there is no possibility to choose the right GPU
    Additionally also don t forget to try the different compatibilty settings on the game exe or try to turn it off, i recognized, that windows is often wrong with its suggestions.
    At last, i usually restart windows before running a game. I experienced, a game is running fine out of razor cortex or steam. i quit it, want to play another or EVEN THE SAME game a few minutes later, and they crashed,after restart no problems :( :( :( really strange. Also the GPU frequency sometimes freezes in energy saving mode,when the PC started some games in order, i recognized this using msi afterburners on screen information,same solution restart ( and again, i tried different combinations of old and new drivers and settings).

    So i found a solution to run most of my games, but its annoying that we have these problems which should not exist, although my hardware is pretty old.

    greetings
Ask a new question

Read More

Geforce Nvidia Laptops