Sign in with
Sign up | Sign in
Your question

Doom 3 performance tweak

Last response: in Graphics & Displays
Share
August 4, 2004 3:06:25 AM

One of my freind that got D3 yesterday clued me in to this.I dont think its already been posted yet.
<A HREF="http://www.forumplanet.com/planetdoom/topic.asp?fid=573..." target="_new">clicky</A>


<A HREF="http://arc.aquamark3.com/arc/arc_view.php?run=682299587" target="_new">40k in aquamark 3
</A>
P4b2.4@2.8||1024mb DDR@392mhz||9800pro@420/740||Viewsonic UltraBrite 19"||Panisonic DVD-RW

More about : doom performance tweak

August 4, 2004 3:25:17 AM

Is this thing true?

Athlon 2700xp+ (oc: 3200xp+ with 200fsb)
Radeon 9800pro (oc: 410/360)
1024mb pc3200 (5-3-3-2)
Asus A7N8X-X
August 4, 2004 3:44:06 AM

HOLY CRAP! That kicks ass! I changed the cache to 256 and it runs great.

System info:
2500M+ @ 2300Mhz
512 Mb Ram
NF7-S
WD Raptor 36
9700 Pro @ 410 / 345

Smooth frames at 1024 x 768, High quality, V-Sync enabled.

Thanks!
Related resources
Can't find your answer ? Ask !
August 4, 2004 3:51:16 AM

I think thats placebo....

Athlon 2700xp+ (oc: 3200xp+ with 200fsb)
Radeon 9800pro (oc: 410/360)
1024mb pc3200 (5-3-3-2)
Asus A7N8X-X
August 4, 2004 3:54:02 AM

That's very interesting, I'm going to try that in a bit... :cool:
August 4, 2004 4:11:01 AM

Someone with a copy and Fraps want to test it out?Meanwhile im going to check some other hardware sites and see if this is being talked about there.


<A HREF="http://arc.aquamark3.com/arc/arc_view.php?run=682299587" target="_new">40k in aquamark 3
</A>
P4b2.4@2.8||1024mb DDR@392mhz||9800pro@420/740||Viewsonic UltraBrite 19"||Panisonic DVD-RW<P ID="edit"><FONT SIZE=-1><EM>Edited by Pukepile on 08/04/04 00:16 AM.</EM></FONT></P>
August 4, 2004 4:50:55 AM

Here are a few more <A HREF="http://www.techreport.com/onearticle.x/7133" target="_new">tweaks</A>. Was in another thread too.

<i> :eek:  <font color=blue>Futile is resistance,</font color=blue><font color=red> assimilate you we will.</font color=red> :eek:  </i>
August 4, 2004 5:31:06 AM

Seems lower end cards benefit. I hope my Ti200 will do better then!

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 4, 2004 12:57:37 PM

Made these settings:

(OLD)
seta image_useCache "0"
seta image_cacheMegs "20"
seta image_cacheMinK "200"

(NEW)
seta image_useCache "1"
seta image_cacheMegs "256"
seta image_cacheMinK "81920"

My specs:
9800NP 128MB
AthlonXP 1800+
512MB

Very substantial performance gain for me. Jumped two resolutions up, and enabled various eye-candy, shadows still off though. Used to stutter and shoot at walls when those imps sliced me open, now everythings smooth enough for me to aim at it's balls, pow!! Blasting away Cacodemons are a joy.

Loading times have obviously increased, but that's no problem for me.

-----
<font color=purple><b>Update:
AthlonXP 1800+ (1.53GHz) to AthlonXP 300+ (0.55GHz) on air. Underclock successful :) .</b></font color=purple>
Anonymous
a b U Graphics card
August 4, 2004 1:21:48 PM

Nice nice will try it this afternoon.
Enabling Vsync didnt do it for me,huge tearing, unplayble weird...
Playing at medium 1024 everything on in advanced. Will report if I have some performance increase.

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 4, 2004 2:32:09 PM

Wow that forum is full or morons. Some guy in there was trying to convince people these texture cache options were related to L2 processor cache.

If you want to save yourself reading 11 pages of forum stupidity, from what I gather basically this tweak does not speed up framerates, just reduces the lags when loading un-cached textures. Its kind of like the preloading character maps option in UT2004.

"Who is General Failure, and why is he reading my drive?"
P4 3.0 HT, Intel D865GBF, 512MB Crucial PC3200 DDR, WD 36GB Raptor 10,000RPM, BBA Radeon 9800PRO, SB Audigy, Hauppage WinTV
August 4, 2004 2:38:28 PM

That IS another way to say increased frame rates if people are able to bump up quality levels like that.

Since we want having better FPS without image quality reduction, and higher FPS does not only come from visual degradation or better cards only, that setting seems to do what people are experiencing, better FPS.

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 4, 2004 2:39:22 PM

Dude, without shadows, the game is basically nothing.

So why the heck do you enjoy playing at higher resolutions when you can't even have the game's biggest player in immersion?

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 4, 2004 3:21:06 PM

Most people who applied these settings were not able to see any difference in FPS at all (only some people claimed to see jumps, but didnt have any numbers to prove it), but everyone agreed it cleaned up the lag spots.

But if the intermediate framerates between the "lags" are still only, say, 15 fps then its misleading to say these tweaks increase FPS.

If you were to look at a histogram type graph like those used at HardOCP then all these tweaks do is get rid of the low spikes; not increasing max FPS and having a very insignificant effect on avg FPS.

"Who is General Failure, and why is he reading my drive?"
P4 3.0 HT, Intel D865GBF, 512MB Crucial PC3200 DDR, WD 36GB Raptor 10,000RPM, BBA Radeon 9800PRO, SB Audigy, Hauppage WinTV
August 4, 2004 3:23:18 PM

After doing all that stuff, does one need to change any settings within the game...or we just start playing the game ?

Like when you said it jumped two resolutions...did u mean u changed two resos higher manually ?

I am not at my gaming desk right now to try.

<i> :eek:  <font color=blue>Futile is resistance,</font color=blue><font color=red> assimilate you we will.</font color=red> :eek:  </i>
Anonymous
a b U Graphics card
August 4, 2004 4:15:49 PM

Who cares as long as it makes the game play better...
I dont care about FPS I car about playability. Even tough they are related cuz its not playable at 15fps...

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 4, 2004 5:10:51 PM

Well it appears the reason these settings arent enabled by default with large caches is the fact that windows XP does a crappy job of reclaiming the ram for the system when the game is exited. If you set it up properly and the game doesnt crash at the title screen, then most likely when you exit the game when finished windows will slow to a crawl due to lack of resources forcing most users to reboot.

Does this happen to everyone?

Guess it might be worth it for some people.

"Who is General Failure, and why is he reading my drive?"
P4 3.0 HT, Intel D865GBF, 512MB Crucial PC3200 DDR, WD 36GB Raptor 10,000RPM, BBA Radeon 9800PRO, SB Audigy, Hauppage WinTV
August 4, 2004 5:15:21 PM

Yup, start playing the game is fine. Yes to the res change. I normally played on 640x480, lots of stuttering. After changing it, it was much smoother, so much so I decided to bump it to 1024x768.

-----
<font color=purple><b>Update:
AthlonXP 1800+ (1.53GHz) to AthlonXP 300+ (0.55GHz) on air. Underclock successful :) .</b></font color=purple>
August 4, 2004 5:19:18 PM

Heh, I'll play with shadows when I'm not pooping my pants thanks :D .

-----
<font color=purple><b>Update:
AthlonXP 1800+ (1.53GHz) to AthlonXP 300+ (0.55GHz) on air. Underclock successful :) .</b></font color=purple>
August 4, 2004 5:49:28 PM

This alteration increases the cache size for the graphics to the system memory. More, the less the AGP has to decompress and fiddle with the HD. Just watch your system resources.

Mobile Barton 2500+ @ 2420mhz 11x220 1.7v
Asus A7N8X Dlx 440 FSB
1gb Geil GD pc3500 Dual Channel (2-3-3-6)
Segata 80gb SATA 8.5ms seek
ATI Radeon 9800 Pro to XT(463/795)
August 4, 2004 10:02:42 PM

basically what i gather is this:


the game is defaulted to treat your system like it has only a small amount of system ram, and doenst cache much of anything by default to keep your system from dieing


enabling these tweaks are only gonna help people with 512mb+ of system ram. remember the min is 384, perhaps thas what those default settings are for? youd think they would program the game to detect how much ram you have (not a hard thing to do at all, windows keeps very clsoe track of it) and adjust accordingly

i got 768megs of dual channel system ram , i think itll be a great tweak for me once i get the game

of course ill give you guys a well tested "before and after" to verify if this does work well

-------
<A HREF="http://www.albinoblacksheep.com/flash/you.html" target="_new">please dont click here! </A>
<A HREF="http://www.subhi.com/keyboard.jpg" target="_new">This is you, interweb junky</A>
August 5, 2004 2:51:13 AM

*Steps up at podium, silent. Crowd is awaiting something. Silent chirps.*

Ahem....



<b>SON OF A @!#^&#$@^&*@ @* LOUSY !@#@&(#*@^&& COMING FROM YOUR @&#@*&#@!!!</b>

Phew, that was good.

GAME DOESN'T RUN!!!
I just paid and was hyped, and for some freakin' reason, it stutters at like 0.2FPS right from the beginning when launching the game! Logo video stutters BADLY, but the menu screen is the worst. Every 5 seconds or more there is a small update. Mouse movement is barely possible thanks to the lag, while music plays perfectly. GODDAMN IT WHY!
Don't tell me my system is weak, that Ti200 is well within the minimum specs as well as the 1600+! I updated nVidia and VIA drivers as well. Nothing, NOTHING! :mad: 

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 5, 2004 2:52:04 AM

It crashed my game, alas. Only set it to 1 for the enable cache string and the amount to 64! :eek: 

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 5, 2004 8:29:59 AM

Did you also seta image_cacheMinK to something higher? Game crashes if you don't.


-----
I shaved myself.
Anonymous
a b U Graphics card
August 5, 2004 1:43:18 PM

Yup crashed before I changed it!

Also didnt test extensivly and I didnt bench but I must say it felt smoother one resolution higher than what I usually play...

will report more tonight.

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 5, 2004 2:45:57 PM

I'm no computer expert, but I went on the advice given here and increased the cache amount from "20" to "512". Believe it or not...problem solved! The tweak may not be increasing the frame rates, but it certainly smoothed things out. The game had been lagging and studdering when I openned doors and such. Now it runs smooth as glass. In addition, I have not noticed any negative effects on my system. Everything seems to be working just fine.

Thanks again for the tip.
P4 2.66
1G 1066
Audigy 2 ZS
X800 Pro
Anonymous
a b U Graphics card
August 5, 2004 2:51:12 PM

Can you benchmark I wonder how that RDRAM performs in the game.

And yes I dont think it will incresae your max FPS but I dot think youll see your min FPS less often.


Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
Anonymous
a b U Graphics card
August 5, 2004 2:51:15 PM

Can you benchmark I wonder how that RDRAM performs in the game.

And yes I dont think it will incresae your max FPS but I dot think youll see your min FPS less often.


Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 5, 2004 3:45:05 PM

I tried it too and really did not notice jack, and some part are less jerky. This tweak is probably for those with crappy graphics cards.

By doing this it did increase the load time between levels.

Mobile Barton 2500+ @ 2420mhz 11x220 1.7v
Asus A7N8X Dlx 440 FSB
1gb Geil GD pc3500 Dual Channel (2-3-3-6)
Segata 80gb SATA 8.5ms seek
ATI Radeon 9800 Pro to XT(463/795)
August 5, 2004 3:47:18 PM

There is a line just below the cache site where you have to set minamun K used I think 87000 or somewhere in that field will prevent the crash.

Mobile Barton 2500+ @ 2420mhz 11x220 1.7v
Asus A7N8X Dlx 440 FSB
1gb Geil GD pc3500 Dual Channel (2-3-3-6)
Segata 80gb SATA 8.5ms seek
ATI Radeon 9800 Pro to XT(463/795)
Anonymous
a b U Graphics card
August 5, 2004 6:03:46 PM

Ya copyed woodman conf and it worked

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 5, 2004 7:47:50 PM

I'll be damned if I decide to format! :mad: 

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 5, 2004 7:49:37 PM

It worked great for me and I'm using a Visionstek X800 pro, with the new 4.9 drivers. Like I posted earlier, the tweak has smoothed out the game play on my machine. I am going to try and post some benchmarks tonight. However, at this point I'm more intertested in just playing the game. The past two nights have been spent doing everything from upgrading drivers, tweaking my speakers and finally tweaking the game. Now it seems to be right. If it is not broke, then i'm not going to try and fix it.

Thanks again to all those who helped me out.
August 5, 2004 7:54:18 PM

You are all a bunch of lucky bastards whom I should stab over the monitor!

:lol: 

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
Anonymous
a b U Graphics card
August 5, 2004 8:50:36 PM

trade your usertitle for money! and buy a new vid card =)
Look at Kanavit spending money on CPU like if they were throwable! he can probly give you a fair amount of money for that honorary stuff :wink:

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, Leadtek FX5900 w/ FX5950U bios@500/1000, 2X30gig Raid0
August 5, 2004 8:58:22 PM

Eden you must not set the useCache value to 1! That made it not run on my friend JimmyDean's system either.

Make sure you have AA/AF off or set to app. pref in your nvidia ctrl. panel's OPEN GL section. Also ... what do you expect? You're within "minimum" for the game "to work"... but your system sucks. I would expect you to have to play at 640x480 low detail. Maybe one notch higher on the detail OR res setting (not both).

Me: are you saying I can't provide?
Me: cause I know I can provide.
Me: oh and I can provide money too;)
Rachel:) : why do we need money when we can just stay in our room and have sex all day?
August 5, 2004 9:00:40 PM

Holy crap... the worst part is... Labbbby is actually right! It's like selling Everquest accounts!

People could seriously sell their forum accounts... if they had a 1337 user title, or certain privaledges or lots of respect or something... but that leaves Eden out.

Lol.

Me: are you saying I can't provide?
Me: cause I know I can provide.
Me: oh and I can provide money too;)
Rachel:) : why do we need money when we can just stay in our room and have sex all day?
August 6, 2004 2:53:58 AM

It can run if you enable it, just have to increase the image_cacheMinK.

-----
I shaved myself.
August 6, 2004 3:35:32 AM

Yes that fixed launching it with the cache increased. Didn't fix the choppiness though. I know well enough to not complain about low FPS in such a game HAD IT WORKED! I mean, I know the risks I'm taking by buying this game on this system, but I also know such problems are NOT normal.

The proof is also in the fact I increased the cache and minimum cache, and nothing happened. The proof is there with many many more things I tried. Still waiting for Activision to respond.

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 6, 2004 3:36:08 AM

LOL!
NEVER!

I'm an Honorary Gigolo damn it! :lol: 

My services are top of the line!

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 6, 2004 3:39:02 AM

Quote:
Eden you must not set the useCache value to 1! That made it not run on my friend JimmyDean's system either.

Make sure you have AA/AF off or set to app. pref in your nvidia ctrl. panel's OPEN GL section. Also ... what do you expect? You're within "minimum" for the game "to work"... but your system sucks. I would expect you to have to play at 640x480 low detail. Maybe one notch higher on the detail OR res setting (not both).

Trust me, I have done everything above, and like I just said to Woodman, I have set the appropriate settings for the cache thing, however nothing, and I mean NOTHING has changed. The update rate on the main menu changes at the same frequency, I see the same frames as before, kinda like watching the same slideshow if you get what I mean.

And as I said many times, no game would have trouble even rendering the logo animation (is it a video or 3D to you guys?) and the main menu which shows a rather simplistic model of the planet Mars.

I don't even care if I have to play it at Low Quality 640*480, just getting into the Options menu would be a blessing at the moment! :eek: 

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 6, 2004 3:39:58 AM

Quote:
lots of respect or something... but that leaves Eden out.


You're the first I will stab over the monitor! :lol: 


--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 6, 2004 3:46:01 AM

Lol. Well considering what you have done Eden the symptoms you are experiencing are quite odd. I get 60FPS in the menu (does it go higher than this?), and it's not that complex. Mars just spins slowly in the background. I would assume it's video. One good thing about the game is that the menu loads very fast for me, unlike UT2k4 for example.

All I can suggest is uninstalling and re-installing the Cats.

Me: are you saying I can't provide?
Me: cause I know I can provide.
Me: oh and I can provide money too;)
Rachel:) : why do we need money when we can just stay in our room and have sex all day?
August 6, 2004 3:48:31 AM

Woodman, I have the cache size set to 256, and I have 512mb of ram. If I were to set the usecache to 1, what would you suggest for the cachemink setting and why? What exactly does it do?

Me: are you saying I can't provide?
Me: cause I know I can provide.
Me: oh and I can provide money too;)
Rachel:) : why do we need money when we can just stay in our room and have sex all day?
August 6, 2004 3:56:11 AM

I read today to use 1/4rth of your RAM for the cache megs. Woodman suggests about 81702K IIRC for the minK.

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
August 6, 2004 3:57:59 AM

Quote:
Lol. Well considering what you have done Eden the symptoms you are experiencing are quite odd. I get 60FPS in the menu (does it go higher than this?), and it's not that complex. Mars just spins slowly in the background. I would assume it's video. One good thing about the game is that the menu loads very fast for me, unlike UT2k4 for example.

I see. And yeah, that pretty much confirms what I was saying. It's not supposed to lag this badly on the main screen.

Is the iD logo animation a video for you guys? Because if that too lags and it's a video, it's most definitely not the video card, to my knowledge.

Quote:
All I can suggest is uninstalling and re-installing the Cats.

It's a Ti200 Willy. We're not quite in a Catalyst only world yet! :wink:

--

<font color=red>NNNNNNNNNNNNNNN
<font color=white>XXXXXXX<font color=green>S<font color=white>XXXXXXX
XXXXXX<font color=green>SSS<font color=white>XXXXXX
XXXXX<font color=green>SS<font color=orange>g</font color=orange>SS<font color=white>XXXXX
<font color=red>NNNNNNNNNNNNNNN</font color=green></font color=white>
!