Disk drive C is constantly active

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Sometimes my main disk drive gets very busy when I am not using the system.
How can I find what is causing this?
I have scanned the system for viruses and spyware with no problems
discovered.

Thanks, Robert
5 answers Last reply
More about disk drive constantly active
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Windows XP will periodically index your files for optimum
    performance. It will also partially defrag your drive if it is
    excessively fragmented. This occurs when your PC is idle
    and is normal.

    Windows XP's Built-In Optimization
    http://www.extremetech.com/article2/0,3973,1149277,00.asp

    If you wish to disable the Indexing Service, perform the following:
    Go to Start > Run and type: SERVICES.MSC , and hit enter.
    Scroll down to the "Indexing Service", right-click on it and select
    Properties and set the Startup Type to Disabled, then click Apply.

    --
    Carey Frisch
    Microsoft MVP
    Windows XP - Shell/User
    Microsoft Newsgroups

    Get Windows XP Service Pack 2 with Advanced Security Technologies:
    http://www.microsoft.com/athome/security/protect/windowsxp/choose.mspx

    -------------------------------------------------------------------------------------------

    "Robert" wrote:

    | Sometimes my main disk drive gets very busy when I am not using the system.
    | How can I find what is causing this?
    | I have scanned the system for viruses and spyware with no problems
    | discovered.
    |
    | Thanks, Robert


    ---
    avast! Antivirus: Outbound message clean.
    Virus Database (VPS): 0519-0, 05/09/2005
    Tested on: 5/9/2005 10:44:34 AM
    avast! - copyright (c) 1988-2005 ALWIL Software.
    http://www.avast.com
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Robert,

    See also.
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xehowdisablingdiskdefragmentation.asp

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "Robert" <nospam@spamfree.com> wrote in message
    news:%23RviBvKVFHA.3152@TK2MSFTNGP12.phx.gbl...
    > Sometimes my main disk drive gets very busy when I am not using the
    > system. How can I find what is causing this?
    > I have scanned the system for viruses and spyware with no problems
    > discovered.
    >
    > Thanks, Robert
    >
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    BTW, that article was originally written for XP-Embedded. However, the
    "EnableAutoLayout" registry setting very much applies to Windows XP Home and
    Professional. Personally, I would not disable this feature, as it runs
    during the idle time and does not affect my work anyway.

    Description about this feature, as shown in Tweak UI screen:

    "Optimize hard disk when idle" check box allows Windows to rearrange
    files on the hard disk when the computer is not in use to improve
    performance.

    If you don't want this feature, you can disable the auto-optimization
    feature using Tweak UI. Download/Install Tweak UI and run it. Look in the
    General section, and uncheck "Optimize hard disk when idle".

    TweakUI for Windows XP: http://windowsxp.mvps.org/tweakui.htm

    Manual registry edit:

    HKEY_LOCAL_MACHINE
    \SOFTWARE
    \Microsoft
    \Windows
    \CurrentVersion
    \OptimalLayout

    Value name: EnableAutoLayout
    Data Type: REG_DWORD
    Possible values: 1 | 0

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    news:eivt1FLVFHA.3252@TK2MSFTNGP10.phx.gbl...
    > Robert,
    >
    > See also.
    > http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xehowdisablingdiskdefragmentation.asp
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "Robert" <nospam@spamfree.com> wrote in message
    > news:%23RviBvKVFHA.3152@TK2MSFTNGP12.phx.gbl...
    >> Sometimes my main disk drive gets very busy when I am not using the
    >> system. How can I find what is causing this?
    >> I have scanned the system for viruses and spyware with no problems
    >> discovered.
    >>
    >> Thanks, Robert
  4. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Got it! You MVPs are just great. Thanks a million.
    Robert

    "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    news:uvrIwLLVFHA.1404@TK2MSFTNGP09.phx.gbl...
    > BTW, that article was originally written for XP-Embedded. However, the
    > "EnableAutoLayout" registry setting very much applies to Windows XP Home
    > and Professional. Personally, I would not disable this feature, as it runs
    > during the idle time and does not affect my work anyway.
    >
    > Description about this feature, as shown in Tweak UI screen:
    >
    > "Optimize hard disk when idle" check box allows Windows to rearrange
    > files on the hard disk when the computer is not in use to improve
    > performance.
    >
    > If you don't want this feature, you can disable the auto-optimization
    > feature using Tweak UI. Download/Install Tweak UI and run it. Look in the
    > General section, and uncheck "Optimize hard disk when idle".
    >
    > TweakUI for Windows XP: http://windowsxp.mvps.org/tweakui.htm
    >
    > Manual registry edit:
    >
    > HKEY_LOCAL_MACHINE
    > \SOFTWARE
    > \Microsoft
    > \Windows
    > \CurrentVersion
    > \OptimalLayout
    >
    > Value name: EnableAutoLayout
    > Data Type: REG_DWORD
    > Possible values: 1 | 0
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    > news:eivt1FLVFHA.3252@TK2MSFTNGP10.phx.gbl...
    >> Robert,
    >>
    >> See also.
    >> http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xehowdisablingdiskdefragmentation.asp
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "Robert" <nospam@spamfree.com> wrote in message
    >> news:%23RviBvKVFHA.3152@TK2MSFTNGP12.phx.gbl...
    >>> Sometimes my main disk drive gets very busy when I am not using the
    >>> system. How can I find what is causing this?
    >>> I have scanned the system for viruses and spyware with no problems
    >>> discovered.
    >>>
    >>> Thanks, Robert
    >
  5. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Thanks for the feedback! Robert.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "Robert" <nospam@spamfree.com> wrote in message
    news:%23QgMg5LVFHA.2616@TK2MSFTNGP14.phx.gbl...
    > Got it! You MVPs are just great. Thanks a million.
    > Robert
    >
    > "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    > news:uvrIwLLVFHA.1404@TK2MSFTNGP09.phx.gbl...
    >> BTW, that article was originally written for XP-Embedded. However, the
    >> "EnableAutoLayout" registry setting very much applies to Windows XP Home
    >> and Professional. Personally, I would not disable this feature, as it
    >> runs during the idle time and does not affect my work anyway.
    >>
    >> Description about this feature, as shown in Tweak UI screen:
    >>
    >> "Optimize hard disk when idle" check box allows Windows to rearrange
    >> files on the hard disk when the computer is not in use to improve
    >> performance.
    >>
    >> If you don't want this feature, you can disable the auto-optimization
    >> feature using Tweak UI. Download/Install Tweak UI and run it. Look in the
    >> General section, and uncheck "Optimize hard disk when idle".
    >>
    >> TweakUI for Windows XP: http://windowsxp.mvps.org/tweakui.htm
    >>
    >> Manual registry edit:
    >>
    >> HKEY_LOCAL_MACHINE
    >> \SOFTWARE
    >> \Microsoft
    >> \Windows
    >> \CurrentVersion
    >> \OptimalLayout
    >>
    >> Value name: EnableAutoLayout
    >> Data Type: REG_DWORD
    >> Possible values: 1 | 0
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
Ask a new question

Read More

Support Disk Drive Microsoft Windows XP