Closed

Lost Desktop Icons

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I recently lost the ability to display or use any desktop icons.
When I right click the desktop and the Display Properites menu appears, the
"arrange icons by" menu is greyed out. I still have them in the toolbar but
cannot get them back on the desktop. I have XP/SP2 installed. This is
probably my fault as this is the first problem with XP I've had in almost a
year but can anyone think of a reason to loose your desktop icons and more
importantly, how do I get that function back. TIA :)
6 answers Last reply
More about lost desktop icons
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    "Raptor" <raptor3344@comcast.net> wrote in message
    news:kIWdnUpJ5N7pTRrfRVn-tA@comcast.com...
    >
    > I recently lost the ability to display or use any desktop
    > icons. When I right click the desktop and the Display Properites menu
    > appears, the "arrange icons by" menu is greyed out. I still have them
    > in the toolbar but cannot get them back on the desktop. I have
    > XP/SP2 installed. This is probably my fault as this is the first
    > problem with XP I've had in almost a year but can anyone think of a
    > reason to loose your desktop icons and more importantly, how do I get
    > that function back. TIA :)
    >


    This may help you,

    Check the "NoDesktop" value in the registry and set the value to 0.
    [HKCU\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
    and (maybe present)
    [HKLM\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]

    If you have XP Pro, use the Group Policy (gpedit.msc)

    User Configuration > Administrative Templates > Desktop
    Set "Hide and disable all items on the desktop" to Not Configured.

    --
    William
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    That worked. Thanks again

    "WTC" <bcrawfordjr(anyone)@yahoo.com> wrote in message
    news:uIwKmcbWFHA.2796@TK2MSFTNGP09.phx.gbl...
    > "Raptor" <raptor3344@comcast.net> wrote in message
    > news:kIWdnUpJ5N7pTRrfRVn-tA@comcast.com...
    >>
    >> I recently lost the ability to display or use any desktop icons.
    >> >>
    >
    >
    > This may help you,
    >
    > > --
    > William
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    "Raptor" <raptor3344@comcast.net> wrote in message
    news:u5adnfM56qvByRTfRVn-pA@comcast.com...
    > That worked. Thanks again
    >

    You're welcome.

    --
    William
  4. Hey,

    I have a customer that appears to have the exact same problem, however the fixes that you specify don't match up.

    In the registry under [HKCU\Software\Microsoft\Windows\CurrentVersion\policies\Explorer] there is no 'NoDesktop' value to change.

    In 'gpedit.msc' the "Hide and disable all items on the desktop" was already set to 'Not Configured'.

    The problem seems the same otherwise. No icons on the desktop whatsoever. The links and shortcuts are still showing in the desktop folder when using explorer. And all of the options in the 'Arrange Icons By' menu are greyed out.

    I have tried restarting 'explorer' as other fixes have suggested without any success. And the suggestion from Microsoft itself was to click the 'Show Desktop Icons' option in the 'Arrange Icons By' menu. That option does not even show up, let alone greyed out.

    I have run through a couple of malware scans and come up with nothing. Any help would be great.

    Thanks,
    Adam
  5. Hey Adam (A_Wolfie)

    I also had the same problem and the fix above didn't work as is your case. I searched all over using all kinds of methods and sites and wordings of the search terms. I was just about to give up when finally I found a site that gave the following bit of information. I checked those registry keys and finding the hideicons value set to 1 I set it to zero and logged out and back in and it was fixed! Let me know if this works for you as well.

    Quote:
    Bit of info #1
    To hide all Desktop Icons from Explorer but still enable right-clicking on the desktop there is the following registry hack :

    Hive: HKEY_CURRENT_USER
    Key: Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    Name: HideIcons
    Type: REG_DWORD
    Value: 1

    More info can be found at the source site HERE

    Good Luck! :hello:

    David (AK_David)
  6. This topic has been closed by Aford10
Ask a new question

Read More

Desktop Icons Desktops Windows XP Displays