Sign in with
Sign up | Sign in
Your question

Acer factory restore hangs

Last response: in Laptop General Discussion
Share
August 13, 2012 12:46:49 PM

Hello

I've attempted to restore my Acer Aspire 5553 using the Acer eRecovery Management facility. Every went well but when it rebooted, the laptop has been hung for more than 4 hours showing the message "Setup is applying system settings".

Is it safe to switch off and use the backup restore discs which I created.

Thanks, Tom Mackin
a b D Laptop
August 14, 2012 11:43:22 AM

You can try pushing F1, F12, delete or F8 (safe mode) - see if any of those get you past that screen. If not, I think you've been patient enough to do a restart and install from disk and I'm fairly sure waiting longer will not accomplish much more.
August 14, 2012 11:11:36 PM

C12Friedman said:
You can try pushing F1, F12, delete or F8 (safe mode) - see if any of those get you past that screen. If not, I think you've been patient enough to do a restart and install from disk and I'm fairly sure waiting longer will not accomplish much more.


Did what you suggested and used the disks. They worked fine and I'm now up and running again. Poor show on Acer's behalf. If disks had not been available I would probably have had more problems,
Related resources
a b D Laptop
August 14, 2012 11:33:01 PM

I have not had any luck in the past using Acer's eRecovery - I personally don't know why they continue to include it in their systems.
Three cheers for backups
Anonymous
a b D Laptop
November 12, 2012 2:35:53 PM

C12Friedman said:
You can try pushing F1, F12, delete or F8 (safe mode) - see if any of those get you past that screen. If not, I think you've been patient enough to do a restart and install from disk and I'm fairly sure waiting longer will not accomplish much more.


Hi there

This has happened to me and the keys do nothing. Where can I get the disk please?
!