Sign in with
Sign up | Sign in
Your question

WD My Book - can't initialize it

Last response: in Windows 7
Share
June 29, 2010 11:07:58 PM

I have 500GB WD 5000D032 external HDD, it worked fine for 4 years on various computers and OSs until today. Every time I plug it in, Win7 starts installing drivers, but disk doesn't show up in My Computer, while it shows up in Disk Management and opening its properties even displays that it's a WD external USB device.
Disk Management tells me that disk isn't initialized, but when I try to initialize it, I get an error saying "Incorrect function" with error window named "Virtual disk manager".

I searched for drivers on WD's website and they have none for my model, I also tried the trick with turning off computer's power switch for a few minutes to "reboot" motherboard, but it did nothing.

Any ideas/suggestions what might be the cause and solution?

Thanks in advance!!!

More about : book initialize

a b \ Driver
a b $ Windows 7
June 30, 2010 2:04:15 AM

It appears you have an internal failure, more likely in the case rather then the hdd.
You can disasemble the drive from the case and fit directly to the mobo, or get another external enclosure, or a usb to hdd powered adaptor.
For instructions on taking it apart go here.
http://forum.notebookreview.com/hardware-components-aft...
June 30, 2010 9:32:04 AM

Thanks for the quick reply!

I'll take it apart and plug it in directly.
It's making a bit unusual noises from time to time lately though, so I think it could the HDD itself. Is there any way to get the data from it? If the problem is HDD itself, then it probably just can't read anymore, but the data should still be on there.
June 30, 2010 1:34:20 PM

Ok, I plugged the HDD directly to motherboard on a friend's PC and BIOS outputs some warning/error on startup, the friend said that same thing happened when one of his HDDs stopped working. When I get into OS, it's the same thing with disk not being initialized.

What are chances of fixing it? If I take the HDD to the repair service, will they try to do anything that I can't already do myself with a bit of research?
!