Sign in with
Sign up | Sign in
Your question
Solved

Laptop getting slow?

Last response: in Laptops & Notebooks
Share
August 14, 2012 10:52:42 AM

Hi, I'm new here and I have a problem. My laptop, which is used for gaming is slow or getting slower. Sorry if this is the wrong section, I don't really know where to post this.
Here's the specs

Component Details Subscore Base score
Processor Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz 7.2 5.9
Determined by lowest subscore

Memory (RAM) 8.00 GB 7.5
Graphics Intel(R) HD Graphics 3000 6.7
Gaming graphics 1696 MB Total available graphics memory 6.7
Primary hard disk 513GB Free (655GB Total) 5.9
Windows 7 Home Premium

My video card is nvidea 555 Gt I don't know why it dosen't appear there really.
Just copy pasted from the place ( Computer > properties ) don't really know where to find the complete and more detailed list.

So my laptop is getting pretty slow in playing games, They lag alot. My brother bought the same laptop but the only difference was that his laptop's video card was nvidea 540 gt which is worse than mine but when he plays the same games I play he dosen't lag and usually he has a constant FPS.

Can someone help me out? Don't really know the problem here, My laptop's under warranty and bought it April 2012

Lenovo Y570 ideapad

More about : laptop slow

August 14, 2012 11:54:07 AM

Quote:
go to the device manager : right click on "computer" -> "properties" -> device manager
what's listed under "display adapters"?

Mabye there is some drivers problem, maybe not


It says
Display Adapters
Intel(R) HD Graphics 3000
NVIDIA GeForce GT 555M
m
0
l
August 14, 2012 12:13:41 PM

Quote:
So it knows the GT555M.

Maybe there is some problem with the 'Optimus' (switching between the integrated and dedicated GPUs). Do you the Nvidia control center?


Yea I know it. =) been playing with it for sometime now, and everything just dosen't do anything that makes my FPS in games go up . It's always just the same...
m
0
l
Related resources
a b D Laptop
August 14, 2012 12:52:54 PM

As time goes by.. you'll notice a slight decrease in performance.. it's most likely not because the hard ware is getting older. It's because you've got more software, more services etc.. running in the background.. and your hard drive is fragmented.

Things that you can do to help boost performance:

Disable some things when you start up, Click start: Type in "System Configuration" go to startup tab, and disable things you don't need. I don't recommend you disabling any Microsoft services- just things like iTunes etc..

Get Gamebooster- it will help boost performance when you need it to by stopping some services and processes from running.

Defrag your hard drive- Click Computer > Right click on C Drive > Click Properties > Go to Tools tab > Click on Defragment now...
m
0
l
August 14, 2012 4:34:04 PM

Since you're mainly experiencing problems with gaming, it could be due to Optimus switching. Be sure to check your drivers for the integrated and dedicated card are both up to date if you haven't already. Also, depending on power settings or for some other reason, your laptop might start games up with the integrated chip instead of the dedicated. You could try right clicking and launching games with the gt 555.
m
0
l
a b D Laptop
August 14, 2012 8:48:09 PM

Remove CCC
m
0
l
a b D Laptop
August 14, 2012 9:18:38 PM

@Dingo07, the OP won't have CCC... his laptop has an nvidia GPU, not an AMD.
m
0
l
August 15, 2012 10:23:40 AM

dawknezz said:
Since you're mainly experiencing problems with gaming, it could be due to Optimus switching. Be sure to check your drivers for the integrated and dedicated card are both up to date if you haven't already. Also, depending on power settings or for some other reason, your laptop might start games up with the integrated chip instead of the dedicated. You could try right clicking and launching games with the gt 555.


Optimus switching ? What's that. Lol, noob with these stuff. My drivers for both cards are up to date. Power settings = high performance, yea, high performance.

@hpfreak I've tried gamebooster too, din't really make a big difference. Should i send it back to lenovo for checking or something ? I tried disabling some start up stuff too, no big diff too.
m
0
l
August 15, 2012 10:42:46 AM

Try defragging your HDD. When you play your games it needs to access the files on your HDD but since it's fragmented, it takes more time to access the files. Try Defraggler. It replaces the windows defragmenter and it's better imo. get ccleaner as well
m
0
l

Best solution

a b D Laptop
August 15, 2012 12:41:55 PM

xxaamxx135 said:
Try defragging your HDD. When you play your games it needs to access the files on your HDD but since it's fragmented, it takes more time to access the files. Try Defraggler. It replaces the windows defragmenter and it's better imo. get ccleaner as well

This won't have any effect unless your drive is like 90% full... It would be a waste of time IMO.

I suggest you run Resource Monitor while playing the game that you know slows down the laptop. Then you will know exactly what is going on. I suspect your virus software or some process is running on the background that is slowing things down.
Share
August 15, 2012 1:34:46 PM

dingo07 said:
This won't have any effect unless your drive is like 90% full... It would be a waste of time IMO.

I suggest you run Resource Monitor while playing the game that you know slows down the laptop. Then you will know exactly what is going on. I suspect your virus software or some process is running on the background that is slowing things down.


Okay, i'll try that. I probably try it tomorrow, i'll inform you after :D 
m
0
l
a b D Laptop
August 16, 2012 10:24:44 AM

What anti-virus are you using?
m
0
l
August 16, 2012 11:57:36 AM

hpfreak said:
What anti-virus are you using?


using avast free anti virus!
Oh and in the process manager how much memory is considered big? and I just downloaded an application to monitor the temp of my laptop, CPUID hardware monitor. Can someone tell me how hot is considered "overheating" THANKS !!
m
0
l
August 16, 2012 12:25:30 PM

dingo07 said:
This won't have any effect unless your drive is like 90% full... It would be a waste of time IMO.

I suggest you run Resource Monitor while playing the game that you know slows down the laptop. Then you will know exactly what is going on. I suspect your virus software or some process is running on the background that is slowing things down.


Ok, so i tried it now. Played the game "Heroes of Newerth". The process heroes of newerth or "HoN" took up 1,400,000k
that's what it said on the resource manager. Then the next highest process was DWM on 59,000k. Then the other's started going down to 25,000k and below. I just noticed now that when I was playing the game, It said on the resource manager that the CPU usage was only between 15% - 20% You think this is the problem? But the physical memory was on 40%+. One more thing yo, Downloaded CPU-Z to check the speed my Processor was running at , it showed me it says 1400+ MHz
m
0
l
a b D Laptop
August 16, 2012 1:12:58 PM

I don't think theres anything wrong with the laptop - I think you should tame down the graphics settings in the games that's getting slow, I think that's your only issue
m
0
l
August 17, 2012 8:44:31 AM

dingo07 said:
I don't think theres anything wrong with the laptop - I think you should tame down the graphics settings in the games that's getting slow, I think that's your only issue


I don't really think that's the case.... My brother has the same laptop with me except that his laptop's video card is Nvidia 540 gt which is actually worse than mine. But his laptop runs smoothly.
m
0
l
a b D Laptop
August 17, 2012 11:19:43 AM

Could you post your temps instead? Temps when you're not doing anything, and when you are playing games.
m
0
l
August 17, 2012 12:49:31 PM

Best answer selected by imattf.
m
0
l
August 17, 2012 12:50:50 PM

Guys, had it brought to a near computer shop, dunno what they did but they seem to fix most of the problem :)  Anyways, i'll pick best answer to the one who helped me the most. =)) Thanks!
m
0
l
!