No work to do

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

When trying to start Automatic Updates, I get the following error:

The Automatic Updates service on machine BLAH started and then stopped.
Some services stop automatically is they have no work to do, for example, the
Performance Logs and Alerts service.

AU has no dependencies. These machines are all up to date on antivirus,
running SP2 (but nothing after that). I have quite few workstations like
this.

Any ideas?
7 answers Last reply
More about work
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Tina,
    Yes, Automatic Updates does have some services that it needs to be enabled.
    Do a few sanity checks:
    1) You must make sure these Win XP services are enabled :

    Automatic Updates
    Background Intelligent Transfer Service (BITS)
    Cryptographic Services
    Remote Procedure Call (RPC)
    System Restore Service


    Go to Start menu >Run > MSCONFIG <enter>
    Click on the "Services" Tab & review these services. They should have a
    green "tick/check" mark on left; and status "Running" on the far right.


    You need to have either a 3rd-party firewall or XP's firewall ON, and, have
    a good/current antivirus on. Don't go on the net without them!


    2) Following is only a basic first-pass checklist of settings for Internet
    Explorer browser, tailored for smoother entry into Windows Update.
    It is NOT a cureall !


    Make sure this is not running a 3rd-part Popup-Ad remover, or any
    anonimyzer.


    1. In Internet Explorer browser > select Tools, click Internet Options, and
    then click
    Languages....
    If this box is empty, add at least one language -- your usual national
    language.
    If you happen to have 2 or more, move English up on this list.


    2. Disengage your Discussion Bar in Internet Explorer: Click View on
    main IE menu.
    Point to Explorer Bar.
    If "Discuss" has a check mark, click Discuss to *remove the check mark*
    and clear it.
    You may note, if the discussion bar is active, it would appear near the
    bottom of IE window.


    3. I. E. Tools >Internet Options > Advanced Tab > (scroll down thru
    the list)


    These are "some" of the items that I do have CHECKed (selected):
    Under HTTP 1.1 settings --
    Use HTTP 1.1 (ON / Selected)
    + Enable / check to use HTTP 1.1 with proxy servers **** <<----


    and under Security :


    Clear (un-check) the check box next to "Check for server certificate
    revocation" . ( *OFF* )


    Use SSL 2.0 (ON / selected)
    Use SSL 3.0 (ON)


    4. Internet Explorer > Tools > Internet Options > Connections Tab Click
    on LAN Settings > * Uncheck* the Automatically detect settings.
    Make sure _no other_ settings on this screen are enabled.


    5. Internet Explorer > main menu /Tools/Internet Options >


    Security Tab/ click on green icon Trusted Sites/click Sites button.


    Look very closely at line that says:


    "Require server verification (https:) for all sites in this zone" to
    *clear* the selection.
    (e.g. You want that to be un-checked (un-ticked)).


    In the "Add this Web site to the zone:" field, add these entries to
    list of "Trusted Sites" --


    type
    http://*.download.windowsupdat­e.com (click Add)


    http://v5.windowsupdate.micros­oft.com


    https://v5.windowsupdate.micro­soft.com (with HTTPS)


    http://windowsupdate.microsoft­.com


    Click OK. Apply changes to IE browser.


    Then re-try Windows Update.


    HTH Post back with your progress


    --
    Maurice N
    MVP Windows - Shell / User

    ---
    "Tina Shields" wrote
    > When trying to start Automatic Updates, I get the following error:
    >
    > The Automatic Updates service on machine BLAH started and then stopped.
    > Some services stop automatically is they have no work to do, for example,
    > the
    > Performance Logs and Alerts service.
    >
    > AU has no dependencies. These machines are all up to date on antivirus,
    > running SP2 (but nothing after that). I have quite few workstations like
    > this.
    >
    > Any ideas?
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Maurice,

    Thanks so much for the detailed reply; however, I am still unable to start
    the service. I checked to make sure that the services you listed were
    running, and tried to start Automatic Updates. I am still getting the same
    error "..started and then stopped... no work to do..."

    Tina

    "Maurice N ~ MVP" wrote:

    > Tina,
    > Yes, Automatic Updates does have some services that it needs to be enabled.
    > Do a few sanity checks:
    > 1) You must make sure these Win XP services are enabled :
    >
    > Automatic Updates
    > Background Intelligent Transfer Service (BITS)
    > Cryptographic Services
    > Remote Procedure Call (RPC)
    > System Restore Service
    >
    >
    > Go to Start menu >Run > MSCONFIG <enter>
    > Click on the "Services" Tab & review these services. They should have a
    > green "tick/check" mark on left; and status "Running" on the far right.
    >
    >
    > You need to have either a 3rd-party firewall or XP's firewall ON, and, have
    > a good/current antivirus on. Don't go on the net without them!
    >
    >
    > 2) Following is only a basic first-pass checklist of settings for Internet
    > Explorer browser, tailored for smoother entry into Windows Update.
    > It is NOT a cureall !
    >
    >
    > Make sure this is not running a 3rd-part Popup-Ad remover, or any
    > anonimyzer.
    >
    >
    > 1. In Internet Explorer browser > select Tools, click Internet Options, and
    > then click
    > Languages....
    > If this box is empty, add at least one language -- your usual national
    > language.
    > If you happen to have 2 or more, move English up on this list.
    >
    >
    > 2. Disengage your Discussion Bar in Internet Explorer: Click View on
    > main IE menu.
    > Point to Explorer Bar.
    > If "Discuss" has a check mark, click Discuss to *remove the check mark*
    > and clear it.
    > You may note, if the discussion bar is active, it would appear near the
    > bottom of IE window.
    >
    >
    > 3. I. E. Tools >Internet Options > Advanced Tab > (scroll down thru
    > the list)
    >
    >
    > These are "some" of the items that I do have CHECKed (selected):
    > Under HTTP 1.1 settings --
    > Use HTTP 1.1 (ON / Selected)
    > + Enable / check to use HTTP 1.1 with proxy servers **** <<----
    >
    >
    > and under Security :
    >
    >
    > Clear (un-check) the check box next to "Check for server certificate
    > revocation" . ( *OFF* )
    >
    >
    > Use SSL 2.0 (ON / selected)
    > Use SSL 3.0 (ON)
    >
    >
    > 4. Internet Explorer > Tools > Internet Options > Connections Tab Click
    > on LAN Settings > * Uncheck* the Automatically detect settings.
    > Make sure _no other_ settings on this screen are enabled.
    >
    >
    > 5. Internet Explorer > main menu /Tools/Internet Options >
    >
    >
    > Security Tab/ click on green icon Trusted Sites/click Sites button.
    >
    >
    > Look very closely at line that says:
    >
    >
    > "Require server verification (https:) for all sites in this zone" to
    > *clear* the selection.
    > (e.g. You want that to be un-checked (un-ticked)).
    >
    >
    > In the "Add this Web site to the zone:" field, add these entries to
    > list of "Trusted Sites" --
    >
    >
    > type
    > http://*.download.windowsupdat­e.com (click Add)
    >
    >
    > http://v5.windowsupdate.micros­oft.com
    >
    >
    > https://v5.windowsupdate.micro­soft.com (with HTTPS)
    >
    >
    > http://windowsupdate.microsoft­.com
    >
    >
    > Click OK. Apply changes to IE browser.
    >
    >
    > Then re-try Windows Update.
    >
    >
    > HTH Post back with your progress
    >
    >
    > --
    > Maurice N
    > MVP Windows - Shell / User
    >
    > ---
    > "Tina Shields" wrote
    > > When trying to start Automatic Updates, I get the following error:
    > >
    > > The Automatic Updates service on machine BLAH started and then stopped.
    > > Some services stop automatically is they have no work to do, for example,
    > > the
    > > Performance Logs and Alerts service.
    > >
    > > AU has no dependencies. These machines are all up to date on antivirus,
    > > running SP2 (but nothing after that). I have quite few workstations like
    > > this.
    > >
    > > Any ideas?
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Tina,
    Try this. From the Start menus, select the Run option, then type in
    SERVICES.MSC <enter-key>

    Look at the line for Automatic Updates. Click on it. Click on the "Stop" the service. After it finishes that step, click on Restart the service.

    Then wait a while. In the Services screen, Automatic Updates may be shown as Status=Started and Startup Type=Automatic.
    Do you have A U set for a particular time?

    Have you or anyone disabled Windows services (say, using MSCONFIG) ?
    Have you tried selecting Windows Update from main menus (All Programs) or from the Internet Explorer Tools menu?
    Go to Windows Update. Report back with results.
    --
    Maurice N
    MVP Windows - Shell / User
    -----

    "Tina Shields" wrote
    > Maurice,
    >
    > Thanks so much for the detailed reply; however, I am still unable to start
    > the service. I checked to make sure that the services you listed were
    > running, and tried to start Automatic Updates. I am still getting the same
    > error "..started and then stopped... no work to do..."
    >
    > Tina
  4. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Tina,
    Be sure to login to Windows with an administrator-level account.
    --
    Maurice N
    MVP Windows - Shell / User
    -----
  5. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Maurice,

    I can not stop the service, as it is not started, nor can I restart it. I
    am experiencing this same issue with each member of a pilot group of eight
    PCs. My GPO sets the service to a startup type of Automatic, and the
    services mmc reflects same. The machines are scheduled, through the GPO, to
    update at 2200 from my SUS server. This is not occuring, because the
    Automatic Updates service starts then stops because it has "no work to do."
    The service isn't running at 2200 to start the job.

    My GPOs work just fine with my Windows 2000 boxes and my all my servers.
    Just XP seems to be having difficulty. I have about 300 more machines to get
    into the SUS system, after this problem is resolved.

    When I try to update manually from Microsoft's Windows Updates website, I
    get an error code ending in 437. I could find nothing useful on
    Microsoft's support site.

    Thanks,

    Tina

    "Maurice N ~ MVP" wrote:

    > Tina,
    > Try this. From the Start menus, select the Run option, then type in
    > SERVICES.MSC <enter-key>
    >
    > Look at the line for Automatic Updates. Click on it. Click on the "Stop" the service. After it finishes that step, click on Restart the service.
    >
    > Then wait a while. In the Services screen, Automatic Updates may be shown as Status=Started and Startup Type=Automatic.
    > Do you have A U set for a particular time?
    >
    > Have you or anyone disabled Windows services (say, using MSCONFIG) ?
    > Have you tried selecting Windows Update from main menus (All Programs) or from the Internet Explorer Tools menu?
    > Go to Windows Update. Report back with results.
    > --
    > Maurice N
    > MVP Windows - Shell / User
    > -----
  6. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Up to this point, I did not realize you had a SUS setup.
    Repost this situation's details in following newsgroup
    microsoft.public.softwareupdat­esvcs


    Link for Outlook Express / or other newsreader

    news://msnews.microsoft.com/mi­crosoft.public.softwareupdates­vcs

    Following is a link to discussion group for SUS via your browser
    http://tinyurl.com/3rp5h

    HTH

    --
    Maurice N
    MVP Windows - Shell / User
    ---

    "Tina Shields" wrote
    > Maurice,
    >
    > I can not stop the service, as it is not started, nor can I restart it.
    > I
    > am experiencing this same issue with each member of a pilot group of eight
    > PCs. My GPO sets the service to a startup type of Automatic, and the
    > services mmc reflects same. The machines are scheduled, through the GPO,
    > to
    > update at 2200 from my SUS server. This is not occuring, because the
    > Automatic Updates service starts then stops because it has "no work to
    > do."
    > The service isn't running at 2200 to start the job.
    >
    > My GPOs work just fine with my Windows 2000 boxes and my all my servers.
    > Just XP seems to be having difficulty. I have about 300 more machines to
    > get
    > into the SUS system, after this problem is resolved.
    >
    > When I try to update manually from Microsoft's Windows Updates website, I
    > get an error code ending in 437. I could find nothing useful on
    > Microsoft's support site.
    >
    > Thanks,
    >
    > Tina
  7. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    I believe this is a workstation issue, and not a SUS issue, but I'll see if
    anyone over there has some helpful ideas.

    Thanks!

    Tina

    "Maurice N ~ MVP" wrote:

    > Up to this point, I did not realize you had a SUS setup.
    > Repost this situation's details in following newsgroup
    > microsoft.public.softwareupdat­esvcs
    >
    >
    > Link for Outlook Express / or other newsreader
    >
    > news://msnews.microsoft.com/mi­crosoft.public.softwareupdates­vcs
    >
    > Following is a link to discussion group for SUS via your browser
    > http://tinyurl.com/3rp5h
    >
    > HTH
    >
    > --
    > Maurice N
    > MVP Windows - Shell / User
    > ---
    >
    > "Tina Shields" wrote
    > > Maurice,
    > >
    > > I can not stop the service, as it is not started, nor can I restart it.
    > > I
    > > am experiencing this same issue with each member of a pilot group of eight
    > > PCs. My GPO sets the service to a startup type of Automatic, and the
    > > services mmc reflects same. The machines are scheduled, through the GPO,
    > > to
    > > update at 2200 from my SUS server. This is not occuring, because the
    > > Automatic Updates service starts then stops because it has "no work to
    > > do."
    > > The service isn't running at 2200 to start the job.
    > >
    > > My GPOs work just fine with my Windows 2000 boxes and my all my servers.
    > > Just XP seems to be having difficulty. I have about 300 more machines to
    > > get
    > > into the SUS system, after this problem is resolved.
    > >
    > > When I try to update manually from Microsoft's Windows Updates website, I
    > > get an error code ending in 437. I could find nothing useful on
    > > Microsoft's support site.
    > >
    > > Thanks,
    > >
    > > Tina
    >
    >
    >
Ask a new question

Read More

Microsoft Windows XP