Sign in with
Sign up | Sign in
Your question

HD being pelted =(

Last response: in Windows XP
Share
July 29, 2003 1:53:42 AM

i need to find out what is accessing the hard drive at the rate of 3 HD LED blinks in 3~4 secs non stop 24/7.
(swap is on a 2gig partition set at 1534mb max & min(768 ram), changed it from windows managed on that same partition no difference between the user set and windows managed swap in regards to the HD access=(

shutting down every task i can through the task manager does not stop it, is there anyway to get a log showing hard drive access and what requested it?

(winXP kept up dated, 2 Hds & 2 CD running in DMA 2~5)

More about : pelted

July 29, 2003 6:08:07 PM

Question: Have you tried turning off the Indexing Service located under Administrative Tools - Services in the Control Panel?

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
July 30, 2003 12:33:41 PM

when i checked the indexing service after reading your reply it was on manuel and inactive, i disabled it and restarted. there is no change. i am going to try disabling indexing on all drives through the drive's properties menu.
Related resources
July 30, 2003 12:47:55 PM

Let me know if you ever get this problem resolved, because I'm having the exact same problem. It's pretty weird seeing the ide light blink on a regular basis

a7n8x deluxe rev2
Athlon xp 1700+ @ 2600+
512 corsair twinx 2700
Radeon 9500
wd 80 gig hd
ibm 120 gig hd
blah blah blah


It's all good ^_^
July 30, 2003 8:20:14 PM

If that doesn't work, you might need to edit the Registry to remove any applications loading at startup that are constantly accessing the hard drive. A good program for this would be <A HREF="http://www.mlin.net/StartupCPL.shtml" target="_new">Startup Control Panel</A>, as deleted entries can be restored if a problem results from the removal.

You might also consider editing the <A HREF="http://www.blkviper.com/WinXP/servicecfg.htm" target="_new">System Services</A>, turning off <A HREF="http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/doci..." target="_new">System Restore</A>, scanning for spyware and/or viruses (good spyware removal utilities -- <A HREF="http://spybot.safer-networking.de/" target="_new">Spybot</A> and <A HREF="http://www.lavasoftusa.com/" target="_new">Adaware</A>), and testing the system by booting into Safe Mode. If the hard drive isn't accessed regularly in Safe Mode, a driver (such as for the chipset/IDE controller) might be at fault. I've even heard of optical devices sharing a cable with a hard drive causing unusual problems like this.

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
July 31, 2003 1:03:51 AM

i use spybot & i check for viruses often with pc-cillin housecall.
there is nothing starting now with windows(reg cleaner & WINner checked).
i always keep system restore disabled.
ive gone through all the services disabling what i could & stopping everything i could but still needed just to see if it would fix the HD pelting, no luck =(
i tried messing with enabling/disabling SMART & 32bit transfer modes on the HDs & CDs in the BIOS, again no luck.

with my luck & after trying all those things im guessing it is the optical drive+HD issues.
i have it setup like this:
Pri IDE: master 40GB HD, slave CD-RW.
Sec IDE: master 60GB HD, slave 56x CD-ROM.

i have it that way because i write CD-Rs from the 60GB drive & i install OS/APPS/games on the 40GB using the 56x CD.

also i found that if i arrange the drives differently windows has issues running every drive in DMA mode(i have a history with keeping windows using DMA mode on all drives, on 2 diff motherboards no less)...

*reachs for SuSe discs*

thanks for the suggestions & info.

<P ID="edit"><FONT SIZE=-1><EM>Edited by Tungsten on 07/30/03 11:04 PM.</EM></FONT></P>
July 31, 2003 3:32:39 AM

I've seen similar issues with DMA settings, depending on the chipset. CRC errors occur, knocking one of the IDE channels down to PIO mode for at least one of the devices on the channel. Interestingly enough, I've never seen this occur with Intel mainboards (even if the CRC errors <i>still</i> happened when accessing an optical device), but it's a frequent issue with VIA systems, although you may find little viable discussion on the subject around the 'Net.

This is illustrated on this page, which you might have already seen during your investigations:

<A HREF="http://www.microsoft.com/whdc/hwdev/tech/storage/ide-dm..." target="_new">DMA Mode for ATA/ATAPI Devices in Windows XP</A>

It's because of this that I advocate keeping the optical devices on the same cable, and on the secondary channel, as to avoid CRC errors that might cause a hard drive to suddenly be found running in PIO mode. EIDE and ATAPI devices work best if <i>not</i> sharing the same cable, especially if one of the ATAPI devices has issues with running in DMA mode. (Look on this webpage under <A HREF="http://www.pcguide.com/ref/hdd/if/ide/conf.htm" target="_new">Hard Disk and ATAPI Device Channel Sharing</A>.) And DMA devices should never be on the same cable with a device that can't function correctly unless in PIO mode, because this negates chipset support for <A HREF="http://www.pcguide.com/ref/hdd/if/ide/confTiming-c.html" target="_new">Independent Device Timing</A> (which allows devices of different speeds to run independently, without knocking the faster device down to the speed of the slowest device on the cable.)

And so ... I'd move both optical devices to the secondary cable, rearrange the drive letters, and then temporarily disconnect each CD-ROM, one at a time, rebooting after each disconnection, to see if one of these devices is the source of the problem. If this proves to fix the thrashing issue with the hard drive, I'd either try to upgrade the firmware for the optical device, or replace it. (BTW, I'd be looking at the 56X CD-ROM first, because it would be the most likely culprit, in my experience.) Most good CD-RW drives have less problems with DMA.

I'd also suggest giving some thought to replacing the IDE cables, as 80-pin cables can be easily damaged, especially near the connector.

I'd also be certain that the chipset drivers are actually getting installed. I've used the VIA 4-in-1 driver pack on many occasions, and sometimes the chipset drivers just don't get updated, despite the computer requesting a reboot after the installation. Sometimes you have to unpack the drivers into a clean folder, and manually update the VIA Bus Master IDE controller through the Device Manager by pointing towards the folder, or the DMA settings for the IDE channels just won't "hold", if you catch my drift. You have to keep track of the driver versions and dates, so that you can make comparisons after a reboot, to see if the drivers were actually updated.

(You didn't mention your mainboard chipset type, but I used this as an example.)

Finally, be sure that the PSU is powerful enough for the system. A weakened or underpowered PSU can have difficulty supplying enough power to several devices in operation at once, which can also cause CRC errors (and end up causing the Windows to enable PIO mode.) Check the Administrative Tools Event Viewer System log (found in the Control Panel) and see if a particular device is accumulating errors when accessed ... this can indicate which device or cable might be the source of the problem.)

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
August 1, 2003 11:42:11 PM

i moved both the HDs onto pri IDE, left both CDs on the sec IDE > pelting continued > removed 56x > still thrashing, only after removing CD-RW did the pelting stop, which is really bad news cuz i could have gotten by without 56x but not the CD-RW. i will see if the 56x on its own will cause the pelting to see if its any optical drive or just my CD-RW (52x24x52) =(

Oh and my sys:
winxp pro
mobo: MSI KT4V, via KT400 based.
cpu: xp 2100+
ram: 768mb, pc2100 2.5 =(
vid: radeon 9700 pro =)
sound: sound blaster live gamer =/
those 2 HDs and CDs
(s/m 950p, mx700 and no name 10/100 nic)

( EDIT: *cries* & heads for buslinks site for firmware, for the record its the BUSlink 52x CD-RW - Lite-On LTR-52246 - causing HD LED blinks non stop 24/7! - it does write fine =/ )

thanks for the help =)

(EDIT: the HD LED also stops if i just disable the drive in control panel so i will be able to enable to write and leave it off the rest of the time until i can fix it, liteons site is not up right now so i dont know if firmware will fix it)
<P ID="edit"><FONT SIZE=-1><EM>Edited by Tungsten on 08/01/03 11:35 PM.</EM></FONT></P>
!