Sign in with
Sign up | Sign in
Your question

Acer recovery won't work.

Last response: in Laptops & Notebooks
Share
August 18, 2012 4:06:52 AM

Im hoping someone can help me. Yesterday i stupidly decided to reset my Windows 7 on My Acer Aspire 5740 through the Acer recover thing because I was having a few problems. It was all going well until my laptop decided to freeze and i had to turn it off. It didn't finish, so now it isnt working. When i turned it back on i got a Bootmgr is missing message (it dosent come up anymore) I've tried to Bring up recovery through Altf10 but it wont work, even though it's turned on. I didn't have a recovery disc or a windows 7 one. But i since have managed to find a recovery disk and Windows Vista. I tried numerous times to start recovery through them both. But when it scans for a operating system to fix, it cant find one. Since then my screen has turned blue, it won't even load the discs to do anything. I'm at a loss, any ideas on what to do?

More about : acer recovery work

a b $ Windows 7
a b D Laptop
August 18, 2012 1:03:44 PM

I would first attempt to reset your laptop by 1) unplug power adapter, 2) remove battery, 3) press and hold power button for ~30 seconds, 4) replace battery, 5) plug in power adapter, 6) press start. Hopefully you will (at least) get a boot error again.
Acer support site here for your model
http://support.acer.com/product/default.aspx?modelId=18...
has a BIOS update available which you may be able to install
Interestingly (to me), I did a google seach with the following term "acer recovery freeze" and got 1.5M results - that's a little too much reading for me. Also tells me Acer needs to revamp their recovery system.
Have you considered a Linux install?
!