Sign in with
Sign up | Sign in
Your question

ATI Radeon Mobility 9000

Last response: in Graphics & Displays
Share
November 18, 2004 2:23:09 PM

Hi Folks
Any idea how to upgrade the drivers on an ATI Mobility 9000 so that hl2 will run. Stupid thing is that ATI don't support mobile cards (i.e. built into laptops) and my NEC Versa S900 in which the card resides doesn't have any drivers on their support site greater than the 6.14.1.6292 (the driver verwsion that hl2 doesn't like. Its doubly stupid because hl2 was built with ATI cards as a target and there is a dirty great Gordon on their homepage...dohh

ramus
November 18, 2004 3:25:22 PM

As far as I know, you're out of luck. The reason ATI doesn't support Mobile cards is because each manufacturer implements cards in different ways for specific displays. It is up to the Notebook maker to provide drivers for the cards.

Sorry I had to break the bad news. Maybe someone knows more than I do and could help u out with this.
November 18, 2004 3:30:24 PM

You can use <A HREF="http://www.omegadrivers.net/" target="_new">Omega Drivers</A> instead, for your Mobility Radeon. I've been using them for the past few months without any problems. They support all sorts of ATI graphics cards, mobility or no mobility!
a b U Graphics card
November 19, 2004 1:50:50 AM

Have you checked the Windows Update site?

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
!