Sign in with
Sign up | Sign in
Your question

Fix for XP repeatedly dropping wireless link from WPC54G L..

Tags:
  • Wireless
  • Windows XP
  • Wireless Networking
Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
April 12, 2004 1:16:42 PM

Archived from groups: alt.internet.wireless (More info?)

I thank many who contributed to this my most recent fix to my WPA
wireless network. I keep my fingers crossed, but my wireless link has
been going non-stop for over 48 hours between my Linksys WRT54G router
version 2.0 and my WPC54G version 1.2 LapTop card under XP and WPA. I
am not sure what would be the necessary and minimal fix process from
the steps I summarize below. However, the following steps were a
sufficient process. Maybe only step ten below would fix your system
given your system's history and present configuration.

In summary, 1) I installed XP updates in two different ways, 2) I
pulled a WPC54G driver from Microsoft, and 3) I configured the XP
Wireless Zero Configuration to use EAP (PEAP) Authentication.

I am not sure what would be the necessary minimal fix process from the
steps I summarize below. However, the following steps were a
sufficient process.

First, I had to pull the XP Patch for WPA from
http://support.microsoft.com/?kbid=815485 to get XP to cooperate with
WPA in the first place. Then I rebooted and brought up a WPA network
that would work for an hour and then require reconnecting an average
of every few minutes.

Second, I consulted the following medical school site
http://www.bioinformatics.med.umich.edu/bicc/techsuppor...
summarizing in one place the scattered information on XP and WPA
available on the Microsoft site.

Third, I downloaded and installed the cumulative update for the Zero
Configuration for WPA from http://support.microsoft.com/?kbid =826942.
This download got the update file WindowsXP-KB826942-x86-ENU.exe. I
suspect that some of this update duplicated what I did in the First
step above.

Fourth, I did "Windows Update" to see if there was any still
uninstalled update that controlled WPA. The only item I thought might
be relevant was a driver that Microsoft recommended for the Linksys
WPC54G. I elected to install this driver; I don't know if this was
significant. This Microsoft driver update routine from "Windows
Update" installed Linksys driver version 3.50.21.11 dated February 19,
2004.

Fifth, I disabled the internal Ethernet port. In Network Connections,
I right clicked the Ethernet wired LAN connection and clicked
"Disable." Then I rebooted.

Sixth, I uninstalled the Linksys "Wireless-G" card from both PCMCIA
ports. I did this for PCMCIA slot #1 by 1) inserting the WPC54G into
PCMCIA slot #1, 2) going to Control Panel, System, Hardware, Device
Manager, + on Network Adapters, right click on Wireless adapter, 3)
clicking Disable, then 4) clicking Uninstall. Then, I did the same
thing for PCMCIA slot #2 by inserting the WPC54G into slot #2 and
repeating the above uninstallation procedure.

Seventh, I turned off the LapTop.

Eighth, I inserted the WPC54G with the LapTop off. When I turned on
the LapTop, XP did an automatic installation of the WPC54G card. The
resulting driver was version 3.50.21.11 dated February 19, 2004.

Ninth, I configured the WPA connection using WPA-PSK and TKIP as
before.

Tenth, when there still were still occasional drops of the wireless
link, I configured the Wireless Authentication to use EAP (PEAP) by
doing the following: right clicking the "Wireless Network Connection,"
clicking View Available Network Connections, Advanced, Properties,
Authentication, checking "Authenticate as computer," selecting
"Protected EAP (PEAP)" from the dropdown list, Properties, checking
"Validate Server Certificate," checking "Connect to these servers,"
leaving blank the text box after "Connect to these servers," selecting
"Secured Password EAP-MSCHAP v2" from the dropdown list, and checking
the Enable Fast Reconnect. I am not sure that all of those "magic"
selections are necessary. But I UNchecked some of that "magic"
selection that made no sense to me, and the wireless link died
repeatedly after five minutes--until I restored the "magic" selection.

Eleventh, I Enabled the Ethernet wired port.

Then I rebooted. And the WPC54G version 1.2 wireless connection came
up, and as far as I know has not dropped the link to the WRT54G
version 2.0 router day or night, through hibernations, reboots, and a
thunderstorm.

More about : fix repeatedly dropping wireless link wpc54g

Anonymous
a b F Wireless
April 12, 2004 8:33:21 PM

Archived from groups: alt.internet.wireless (More info?)

rednblu@ix.netcom.com (Riley M. Sinder) wrote in
news:50ba1b04.0404120816.2359f89@posting.google.com:

> I thank many who contributed to this my most recent fix to my WPA
> wireless network. I keep my fingers crossed, but my wireless link has
> been going non-stop for over 48 hours between my Linksys WRT54G router
> version 2.0 and my WPC54G version 1.2 LapTop card under XP and WPA. I
> am not sure what would be the necessary and minimal fix process from
> the steps I summarize below. However, the following steps were a
> sufficient process. Maybe only step ten below would fix your system
> given your system's history and present configuration.
>
> In summary, 1) I installed XP updates in two different ways, 2) I
> pulled a WPC54G driver from Microsoft, and 3) I configured the XP
> Wireless Zero Configuration to use EAP (PEAP) Authentication.
>
> I am not sure what would be the necessary minimal fix process from the
> steps I summarize below. However, the following steps were a
> sufficient process.
>
> First, I had to pull the XP Patch for WPA from
> http://support.microsoft.com/?kbid=815485 to get XP to cooperate with
> WPA in the first place. Then I rebooted and brought up a WPA network
> that would work for an hour and then require reconnecting an average
> of every few minutes.
>
> Second, I consulted the following medical school site
> http://www.bioinformatics.med.umich.edu/bicc/techsuppor...
> summarizing in one place the scattered information on XP and WPA
> available on the Microsoft site.
>
> Third, I downloaded and installed the cumulative update for the Zero
> Configuration for WPA from http://support.microsoft.com/?kbid =826942.
> This download got the update file WindowsXP-KB826942-x86-ENU.exe. I
> suspect that some of this update duplicated what I did in the First
> step above.
>
> Fourth, I did "Windows Update" to see if there was any still
> uninstalled update that controlled WPA. The only item I thought might
> be relevant was a driver that Microsoft recommended for the Linksys
> WPC54G. I elected to install this driver; I don't know if this was
> significant. This Microsoft driver update routine from "Windows
> Update" installed Linksys driver version 3.50.21.11 dated February 19,
> 2004.
>
> Fifth, I disabled the internal Ethernet port. In Network Connections,
> I right clicked the Ethernet wired LAN connection and clicked
> "Disable." Then I rebooted.
>
> Sixth, I uninstalled the Linksys "Wireless-G" card from both PCMCIA
> ports. I did this for PCMCIA slot #1 by 1) inserting the WPC54G into
> PCMCIA slot #1, 2) going to Control Panel, System, Hardware, Device
> Manager, + on Network Adapters, right click on Wireless adapter, 3)
> clicking Disable, then 4) clicking Uninstall. Then, I did the same
> thing for PCMCIA slot #2 by inserting the WPC54G into slot #2 and
> repeating the above uninstallation procedure.
>
> Seventh, I turned off the LapTop.
>
> Eighth, I inserted the WPC54G with the LapTop off. When I turned on
> the LapTop, XP did an automatic installation of the WPC54G card. The
> resulting driver was version 3.50.21.11 dated February 19, 2004.
>
> Ninth, I configured the WPA connection using WPA-PSK and TKIP as
> before.
>
> Tenth, when there still were still occasional drops of the wireless
> link, I configured the Wireless Authentication to use EAP (PEAP) by
> doing the following: right clicking the "Wireless Network Connection,"
> clicking View Available Network Connections, Advanced, Properties,
> Authentication, checking "Authenticate as computer," selecting
> "Protected EAP (PEAP)" from the dropdown list, Properties, checking
> "Validate Server Certificate," checking "Connect to these servers,"
> leaving blank the text box after "Connect to these servers," selecting
> "Secured Password EAP-MSCHAP v2" from the dropdown list, and checking
> the Enable Fast Reconnect. I am not sure that all of those "magic"
> selections are necessary. But I UNchecked some of that "magic"
> selection that made no sense to me, and the wireless link died
> repeatedly after five minutes--until I restored the "magic" selection.
>
> Eleventh, I Enabled the Ethernet wired port.
>
> Then I rebooted. And the WPC54G version 1.2 wireless connection came
> up, and as far as I know has not dropped the link to the WRT54G
> version 2.0 router day or night, through hibernations, reboots, and a
> thunderstorm.
>

I just disabled the WZC service, reinstalled the driver and simple config
it and things became solid as a rock. :) 

Duane :) 
!