Sign in with
Sign up | Sign in
Your question

Toshiba Satalite acting very funny

Last response: in Laptops & Notebooks
Share
September 19, 2012 5:12:39 PM

Hello I have a lot of experience with PC's, fix them and build them all the time. My friend has bought me a Toshiba Satellite L505D that would not get past the splash screen. First thing i did was go into BIOS, i was able to do so, but once i was in the BIOS i could not do anything, keyboard would not work at all. Took laptop apart completely, found no obvious problems,..burnt components, popped caps, etc. cleaned it up made sure fan was attached good. Put laptop back together and boom everything started working but i realized like a dummy i didn't attach the track pad ribbon cable. I took the keyboard back off attached the track pad and then the computer would not get past splash screen and keyboard would no longer work in BIOS again. I don't understand how i can hit f12 to enter BIOS but wont work in BIOS. Plus At 1 point before i re attached the track pad the thing booted all the way to the login screen and keyboard was fully functional in BIOS.
a c 206 D Laptop
September 19, 2012 9:04:41 PM

Unhook the cable again, does it work? Have you tried resetting the BIOS? Keyboard could be bad also.
m
0
l
September 19, 2012 9:33:57 PM

I tried replicating the state it was in when it booted up with the track pad unhooked and got nothing. i cant do anything once im in the BIOS i can only hit f2 or f12 then it does nothing. Can i reset the BIOS the same way as a desktop by removing the CMOS. I think the laptop was dropped prior to me working on it because i can see a big gash in a corner on the keyboard clamshell. Thanks for the reply. Next is trying a usb keyboard but i really dont think its the keyboard since it actually works prior to the BIOS and did work when the computer booted to login the one time.
m
0
l
Related resources
a c 206 D Laptop
September 19, 2012 9:51:17 PM

Depends on the model of the laptop, many you can reset the BIOS by removing the battery, one some you can't to prevent by-passing security passwords.
m
0
l
September 19, 2012 10:11:03 PM

Reset CMOS/bios -- the battery is usually well hidden and 99% of the time for Toshiba's its a permanent soldered one, look online for instructions on the correct way to reset the CMOS (sometimes its by holding down a key on startup, other times near the exposed ram slots there are some solder points to short)

If its not getting passed the bios that can sometimes be HDD - have you tried seeing if it will get passed the bios without any HDD's?

It seems the quality/reliability of Toshiba in recent years is not what it seems im seeing alot of issues with the older A200/L300 (not so much yours but it wouldnt surprise me) where the unit will not function correctly WITH the power pack plugged in, but running off battery the unit will function perfectly - this eventually gets worse and starts to become totally intermittent with random shutdowns, hanging or not booting into windows correctly -- test by booting without the power pack connected.
m
0
l
!