Sign in with
Sign up | Sign in
Your question

internet sharing...

Tags:
  • Computers
  • Internet Connection
  • Internet
  • Networking
Last response: in Networking
Share
April 3, 2002 4:01:52 PM

SITUATION-
lan with 8 clients running W2k-SP2, with 1 server box (W2k-AS)... set up is via "domain" not workgroup...

i have 3 of the clients connected to the internet with dialup...

i am trying to have ALL my clients be able to connect to the internet... so i have setup another box to be used as the "internet connection" computer and "share internet connection" thru the network...

COMPUTER SETUP -
my IP range is: 10.10.1.1 to 10.10.1.50 with a subnet mask of 255.0.0.0

the "internet computer" apparently MUST be given an ip address of 192.168.0.1 with a subnet mask of 255.255.255.0...

PROBLEM -
with this current setup, the internet box is unable to connect to the domain because the address is not in the "scope" of the domain....

what should i do?...

?? should i make the internet computer another "server box"...
?? change the scope of the IP addresses, so the 192 address falls inside the scope?
?? or am i doing something wrong?.....

help - thx

More about : internet sharing

April 4, 2002 7:17:52 AM

change the subnet to 192.168.0.X

Or get yourself a <A HREF="http://www.dlink.com/products/broadband/di704/" target="_new">D-Link DI-704</A> which can do dialup connections.

<i>It's always the one thing you never suspected.</i>
April 4, 2002 6:40:38 PM

just change your client range to 10.10.0.2 - 50 sn/ 255.255.255.0

i went to the tomshardware forums and all i got was this lousy signature.
Related resources
April 4, 2002 8:27:03 PM

can I ask why this would fix the problem? just curious...

<i>It's always the one thing you never suspected.</i>
April 4, 2002 8:44:43 PM

if the server requires the subnet mask to be 255.255.255.0 then you just have to put all the clients on the same subnet. 192.168.0.x 255.255.255.0 would work just as well as 10.10.0.x 255.255.255.0 would.

i went to the tomshardware forums and all i got was this lousy signature.
April 4, 2002 8:55:17 PM

oh I see. The mask was the critical piece of the puzzle. That makes sense now.

<i>It's always the one thing you never suspected.</i>
April 5, 2002 12:38:54 PM

wow...

i am glad the 2 big posters got involved on this puzzle....

just to clarify....

even though the internet box must have an ip address of 192.168.0.1 and my ip range for the office is 10.10.1.x, i will be able to connect to the internet box if i just change the mask to 255.255.255.0....

for my understanding, this new mask "fixes" the first 3 octets to the network, and only the last octet is being used for ip address location.. is that correct...

thx..
April 5, 2002 12:58:06 PM

Quote:
even though the internet box must have an ip address of 192.168.0.1 and my ip range for the office is 10.10.1.x, i will be able to connect to the internet box if i just change the mask to 255.255.255.0....

I'm not totally sure this is your answer. First of all, how do you know the "Internet box" needs an address of 192.168.0.1? Secondly, if you're running Microsoft ICS, doesn't it run a DHCP server by default? If so, have you turned that off so as to configure static IP addresses on the 3 client PC's?

Who is the ISP? Are they supplying you with a static or dynamic IP?

Lastly, IMHO just changing the mask from class A to class C wouldn't necessarily have an effect. But in theory whatever is on the local (your) side of the LAN shouldn't care what the subnet is. Thats what puzzles me. The ICS software should do NAT when it routes the packets to your LAN.

Just another comment (in general). Time and time again I've observed people having more problems than it's worth running ICS. Thats why I always advocate getting a $50 Cable/DSL router. It's just plain easier IMHO. YMMV.

<i>It's always the one thing you never suspected.</i>
April 9, 2002 2:30:38 PM

thanks...

here is my dilemma.... i am on dial-up, so a dsl router would not help....

i need a box to actually dial the phone number and connect to the isp, which the router cannot do.....

i actually have a dsl router, but i cannot use it in this office, at this time....

dsl is brand new to this area, and it is still VERY expensive ($120 per month plus $40 for isp)..... this is what monopolies get you...

to respond to your other questions -

i tried DHCP, with the clients being given an IP address, but this caused too many network problems... i think i just don't know how to configure it properly, so i went with static IP addresses... no problems since it was changed...

the internet box "requires" an ip address of 192.168.0.1 when i turn on "internet sharing", so that is a default within W2k for some reason....

thanks for your help -
April 9, 2002 2:38:35 PM

did you see my previous post about the <A HREF="http://www.dlink.com/products/broadband/di704/" target="_new">DLink DI-704</A>? That router WILL do you dialup for you. I use it and love it.

<i>It's always the one thing you never suspected.</i>
April 10, 2002 1:38:43 PM

i read the "details" of this router, but it made no mention of "phone-dial-up" capability...

it talks about "broadband" access, for DSL and cable, but not for dial up...

so, i thought you had implied "broadband" dial up, as opposed to phone dial up....

if you are actually using it, then i will need to research it more...

HOW do you set the phone number to dial, username, and password?....

can this router be used with a client-server environment?....

thx
April 10, 2002 2:25:42 PM

Quote:
HOW do you set the phone number to dial, username, and password?....

There is a config page where all that stuff can be entered. You can check out the manual <A HREF="http://ftp://ftp.dlink.com/Gateway/di704/Manual/di704_manual_0..." target="_new">here</A>

Quote:
can this router be used with a client-server environment?....

it's a cable/dsl router just like any other. The POTS dialup feature is transparent to the LAN. i.e. if you dialout to a 56K dialup ISP your LAN doesn't see any difference except slower speeds.

<i>It's always the one thing you never suspected.</i>
!