Sign in with
Sign up | Sign in
Your question

Laptop does not start after BIOS update

Last response: in Laptops & Notebooks
Share
September 23, 2012 5:05:08 PM

Hello, good afternoon

First of all I want to apologize because my English is not good. I'm from Spain and I think this forum you can help me. If someone answers, I would ask you please to write the best and simplest way.

I have a notebook ASUS K53SV, bought 14/05/2011. Has 1 year and 4months.

The problem I have is that I updated the bios (with AC on) and as I was finishing the upgrade process went off leaving two leds on (the display and power) and did nothing. I waited a long time and I decided to remove the battery and reconnect. I knew if I had not updated the bios rather not go on the laptop. Indeed, the notebook now does nothing. No lights, no LED, no fan, is dead. Remove the battery and connect the AC power and does nothing.

The bios downloaded directly from the official ASUS website section of this notebook. My old version was the 308 and I downloaded the 320 version.

In my country we have two years warranty but not if I could fix it by resetting the bios. The story is that if I open the laptop and I can not fix it and had to send it in for repair, surely would realize.

What do I do? Why has this happened?

thank you very much

regards
a c 249 D Laptop
September 24, 2012 12:44:03 AM

duplicate post
September 24, 2012 8:01:24 AM

Si, lo siento.

No encontraba este mensaje, era como si estuviera eliminado.
Related resources
April 2, 2013 9:58:00 AM

So does my Asus N43SL! Any helps???
a c 249 D Laptop
April 2, 2013 10:23:57 AM

Ratha_ITC said:
So does my Asus N43SL! Any helps???


Hi :) 

WHY and HOW did you flash it ?

All the best Brett :) 

April 3, 2013 11:04:55 AM

Brett928S2 said:
Ratha_ITC said:
So does my Asus N43SL! Any helps???


Hi :) 

WHY and HOW did you flash it ?

All the best Brett :) 



I just found the Update on the official website, so I downloaded and installed by using Asus Easy Flash Utility, but before updating, I copied and extracted the file update to Drive D, and then I installed it without AC. After installing the update, everything was NOT working even all the LED. Few days later, I found that the file update must be kept or put in a USB drive (update from USB drive only), so is it my fault that I updated from Drive D? I've been trying some solutions from other forums, but nothing can help me. My N43SL will never come back I think, coz the computer store said it was my fault and no more warranty, they don't care. :( 
Sorry for my bad English.
a c 249 D Laptop
April 3, 2013 11:08:24 AM

Hi :) 

Return in to Asus under warranty...done mention the bios flash lol...

All the best Brett :) 
April 3, 2013 11:17:52 AM

Brett928S2 said:
Hi :) 

Return in to Asus under warranty...done mention the bios flash lol...

All the best Brett :) 


Thank for your solution. But I think it won't work. I don't know how to return back to Asus coz there is no Asus Service Center in my country.
!