Cisco catalyst 2948g Uplink to Linksys Switch

Hi, I have a linksys internet router with 4 switch port. I Connect the uplink port on the router to another linskys switch (port 1) and from the uplink of the linksys switch to cisco catalyst 2948g(port 2).
My problem is, I seem to have connectivity problem. I can ping all the computer directly connected to the cisco switch, but I cannot ping any computer that are on the linksys switch or the linksys router. I used regular cat5 patch cable to connect the linksys uplink to port no 2 on the cisco switch. The setting on the cisco switch are all default with 1 default vlan.
What could be the problem ??

Thanks
6 answers Last reply
More about cisco catalyst 2948g uplink linksys switch
  1. do you have good connectivity lights on all your connections?

    where are you pinging FROM? a PC connected to the cisco box? pinging TO other PC's on the same box?

    <i>It's always the one thing you never suspected.</i>
  2. you cant use port 1 and the uplink at the same time on the linksys routers

    i went to the tomshardware forums and all i got was this lousy signature.
  3. All the light connection are on.... I double check not to use the port that shared with the uplink port... Still nothing though.....
  4. that goes for the linksys switch too

    i went to the tomshardware forums and all i got was this lousy signature.
  5. There are only one uplink port on the linksys switch, I used that to connect to the cisco switch. No uplink port on cisco switch....... I connect the uplink port to port 3.
    There was one time it works, but now it doesnt......
    wonder why..... Btw how would you delete all the config on the cisco swith and turn it back to all default factory config ??

    Thanks
  6. im saying you cant use port one when you are using the uplink port on the linksys router and linksys switch.

    i went to the tomshardware forums and all i got was this lousy signature.
Ask a new question

Read More

Linksys Switch Cisco Routers Networking