Sign in with
Sign up | Sign in
Your question

Sager laptop passes bios then hangs

Tags:
  • Laptops
  • BIOS
  • Splash Screen
Last response: in Laptop Tech Support
Share
October 18, 2012 11:33:00 PM

This Sager np-series laptop goes through the bios splash screen then the screen turns black with a single cursor blinking at top left. It hangs there. I cannot see a sager model number but under the battery it says Model W88CU and almost hidden by the bar code label it says CLEVO CO.


This was working fine then suddenly was found one morning powered off and this condition was evident when I tried to start it.

Does anyone know what is wrong???

More about : sager laptop passes bios hangs

October 18, 2012 11:47:36 PM

does the hard disk show up in the bios?

i would remove the hard disk and try to boot, see if you get an error message.
m
0
l
October 18, 2012 11:56:45 PM

I haven't worked with Sager but I've delt with dell and hp notebooks and they usually have a system diagnostic you can go into when pc boots up when splash screen appears. I would try that, if it doesn't have it... go into the bios check to make sure your hard drive settings are correct. I'm assuming it's the hdd... you could take it out and test it by plugging into another pc and run hdd check, test.
m
0
l
Related resources
October 26, 2012 10:16:35 PM

OK- I have tried hirams boot disk and tried fixing the MBR.
That allows it to start windows 7 but as soon as it starts it says it detected a fault and the black screen gives the option to run the startup repair tool. I tried system restore but it failed the only restore point (an update)
I tried start up repair but it didn't work
I tried memory diagnostic- no difference (it boots up on a linux CD anyway so memory is probably ok- it seems like the boot hard drive is the issue).
I tried command prompt and chkdsk /f ... had to dimount the drive as it requested, the it reported no problems.

After all the options the only one left is to restart- back to square 1


I tried a windows 7 cd and ran the repair installation but it couldn't start properly either.
It now shows a "windows boot manager" screen at start up and gives the option to start windows 7 or windows 7 professional (recovered).
If i choose windows 7 it does the same restart thing.
If I choose windows 7 (recovered) it shows a menu for start up options (safe mode etc.)
Whatever I choose here it simply loads the files for a few seconds then the screen shuts down and the bios splash screen appears agin and its back to the windows boot manager screen. If I don't choose within so many seconds it starts up anyway and -flash- back to thje bios splash screen( it says Sager) then the boot manager.

I'm afraid I am busy at work so I had it running to the side of me so couldn't monitor all the screens. It has restarted so many times I couldn't keep track. At one time I managed to get an option to NOT restart on errors (maybe that was the Windows CD) so I chose that and the next start showed a blue screen. Since then it hasn't shown up.

Hirams boot disk again- I tried mini windows xp and it starts like this and gives a desktop.
I can see the drives in my computer.

I attached a USB disk and copied the files to it but hey may not be of any use without the machine running again.

There is a system drive (C:)  and WIndows drive (D:) 
I looked in the C: (system drive) and among the files there is bootmgr, BOOTMGR.BAK, IO.SYS, MSDOS.SYS. The file named BOOTSECT.BAK will open in notepad++
some of the english text there says "a disk read error ocurred; BOOTMGR is missing; BOOTMGR is compressed.

I never saw these messages in the start ups. Don't know what this means.

The Windows drive has the program files and other folders.

In device manager the only disk I see is Volume0 and it says manufacturer unknown
In disk manager I see disk 0 with two partitions (C: System -Healthy active) and (D: Windows healthy)


In the BIOS I see two HItachi drives on SATA ports 1 and 2.
In the boot sequence tried moving the second HDD from 6 up to 2 and booted- I saw ablue screen flash briefly then back to square 1- restart.
So nothing seems to get past this so far.





m
0
l
November 3, 2012 3:16:42 AM

daysyang said:
try Fixing Bootmgr... link has steps

http://www.sevenforums.com/tutorials/104341-bootmgr-mis...


Ok I tried both procedures to fix the MBR and it went through a lot of steps but it still doesn't start up.
I thought about the flash of blue I saw a few times earlier and looked for hours while it tried to boot. I finally saw the option to hit F8 very briefly; so hit F8 and it brought up the options I had seen only once before- to not auto restart on a stop.
This time a blue screen stayed on!! I could read it.

The STOP code is 0x0000007B

It seems this is to do with the hard drive but I don't know anything else.

During the steps above it did try to start a few times and run the chkdsk thing itself but it just kept repeating that and then I removed the windows DVD and it would then only go to a black screen with cursor flashing- stayed like that for hours.

I noticed in the bios that there are 2 HDDs in there- disk 0 and disk 1 yet only one disk shows up in mini Xp when I use hirams boot disk and look in disk manager.
So it sounds like one of these disks is not showing up in windows.
I thought maybe the 2 disks are supposed to be a RAID system, so I checked in BIOS and there is an option to change from ACHI to RAID. I tried this but it still wouldn't boot- in fact it just adds a step in the boot up, showing a screen for a few seconds with a chance to press CTRL+ I to enter the setup for RAID.
That doesn't sound familiar so I exited and eventually found how to reset the bios settings back to ACHI.

Now I remembered that I had tried moving the second Hitachi HDD in the boot sequence up from 6 to 2 in the previous attempts, So I now saw one at 2 and one at 7; I moved 7 up to 2 again and that one down to 7.
Tried a reboot...... still no good. It got to the windows start screen again then asked about repair or start normally.
I chose repair and let it do the startup repair thing again.

It said ( as usual) Attempting Repairs...
Repairing disk errors. This might take over an hour to complete. I went to bed!
m
0
l
November 3, 2012 7:14:28 PM

This morning it had finished that last Startup Repair; it showed most tests had passed but the last one said:
"Root Cause found:
A patch is preventing the system from starting.
Repair Action: System files integrity check & repair

Result: Failed Error code 0x490
Time taken = 759459
- - - - - - - - - - - - - - - - - --

Does this ring a bell with anybody?

Nobody put a system restore point on this laptop so I can't use that.
This machine was bought with Windows 7 already loaded and I don't think we have a reinstall disk.
I have been using another Windows 7 disk to try the repairs but I don't really want to use this disk for a new install and use this licenced copy because it is already on another machine.

It seems a real shame that the files are there when I look in the Hiram's boot mini xp yet I can't get it to boot up properly.

So- current state: it runs BIOS and starts windows but just after it has shown the windows 7 coloured dots circling around for a second, the blue screen flashes on for a split second then it all reboots from bios again.
If I disable auto restart after crash it still shows stop code 7B.
m
0
l
November 3, 2012 9:11:11 PM

More info:
I just tried Hiram boot disk's option for a Linux environment and it has a tool for partitioning/checking.
In there I see a drop down box at top right which has two disks named: /dev/sda and /dev/sdb

In each selection I see the same partitions: system (200MB) and Windows(297.89GB).

Curious.... was this Sager laptop delivered with RAID already configured???
The fact that it has two HDDs inside and they show up in BIOS yet the mini XP of Hiram's boot disk shows only one logical drive in My computer or the Disk manager- with system and windows partitions, seems to suggest to me that is IS a Raid array.

The fact that the linux tool also shows 2 drives with different names but with identical partitions & names ALSO seems to indicate a RAID array.

If so, then the advice I saw on another tom's hardware Sager problem page, to ensure AHCI is set instead of RAID, may be wrong in this case.

Does anyone know if this laptop should be set in BIOS as RAID or AHCI?
Does this mean I should be trying something different??

On this thought I just put the windows dvd in again and went to the repair part; it scanned and showed two windows installations on D: and E:- the mirrored installations???

Not sure what to do now, but have just tried the windows dvd again and got to a command prompt.

I tried chkdsk again and this time noticed that it doesn't actually fail; it says it cannot do it because it has a lock on it. It must dismount the disk to proceed! So i said yes to dismount and it went ahead!

So... I ran chkdsk /f on C;, D:, E: and F:

C: - found no problems
D: - did a lot of inserting and deleting index entries and repaired the security file segment, recovered an orphaned file, found free space marked as allocated.

E: and F: took a while- lots of files to go through, but no problems.

In all drives it "Failed to transfer messages to the event log with status 50."

Then tried a reboot- seected the first windows 7 entry in boot manager- no good blue screen
tried again with second windows 7 entry of boot manager - no good blue screen.

So no improvement.

Tried setting RAID in BIOS again- Aha! now it says BOOTMGR is missing- press Ctrl+Alt +Del to restart.

Hmmmmm. something different- a meaningful error message rather than nothing- so maybe the RAID option IS the correct one to make. tried booting from windows 7 dvd again, selecting Repair.

Told it to repair and restart.
Black screen "one of your disks needs to be checked for consistency" ( Ihave seen this before during all this diagnosis).
I let it go ahead. The windows 7 pro blue background appeared and it said Please wait...


OMG!!! It worked! The loginscreen appeared!
I don't believe it.

I fixed it.

OK for others please note this laptop DOES HAVE RAID enabled. Maybe this is an option- I don't know but this one has it.
So the 2 HDDs are the RAID array- that's why the partitions wetre the same in both disks.

1. a disk error occurred.
2. the user had turned RAID off, or the system somehow disabled it when the error occurred, so it wasn't recognising the RAID array properly or the boot sector.
3. I did not recognise the chkdsk errro it reported so did not tellit to dismount the volume before.


I also wonder what good the RAID was if it didn't allow the laptop to keep running and rebuild the boot record!



First step- I created a restore point!












m
0
l
November 4, 2012 1:07:11 AM

RESOLVED
SUMMARY:
Sager np-series laptop Model W88CU (CLEVO CO.)
Was passing the bios splash screen but before windows started, the screen would turn black with a single cursor blinking at top left and it hung there.

The cause eventually found was some corruption/bad entries on a Hard disk.
Two HDDs are installed as a RAID array but something had disabled the RAID array and left it with both SATA HDDs set in AHCI mode.

The fix that worked was to boot from the WIndows 7 DVD and select Repair.
Then at the Startup repair section, choose to go to the advanced repair options and select CMD prompt.
This laptop has a system partition and a windows partition on each drive labelled C:, D:, E: and F:

I selected each of these drives in turn and in each I ran chkdsk /f (e.g C:> chkdsk /f)
After pressing enter at each ckdsk /f command it complained that it couldn't proceed while a lock was on the drive; it asked if I wanted to dismount the drive.
I typed y and enter. It proceeded correctly and checked the disk.

One disk had multiple errors and these were repaired correctly.
I rebooted and it booted up Windows 7 properly.

Created a System restore point.



m
0
l
November 4, 2012 6:49:41 PM


Oh Dear.

1 day later. I was using the laptop and restarted for purposes of disabling file and print sharing wizard.
When it booted up it said once again that it found inconsistency in C: and would run chkdsk.
It ran for a long time, with many, many, many entries scrolling up concerning repairing index entries etc.

Finalli t finished and windows stared but I wonder if a HDD is bad- maybe about to fail completeely.

I don't know why I don't see any message from the RAID controlelr advising any failure- shouldn't the computer boot up anyway when a mirrored raid is operating?

m
0
l
November 13, 2012 11:26:46 PM

Days later (and many hours of wasted life- The sager still is bad- Windows Updates were old (needed about 30 critical updates.
Every time I tried to update they created a system restore point and installed then it reported they had all failed.

I eventually got 1 or 2 updates to install but each time it said it needed to restart and after restarting it failed to boot up again with a blue screen and stop code.
I have given up now and am trying to get Sager to offer some help.
I don't know if the drives are damaged or if it's a software thing. If the drives are ok then it looks like it needs a full reinstall of Windows.
Luckily my workplace had a clean-up day on Monday and someone found the missing windows 7 disk and carry case and manual! So at least I have the proper disk to install again.

If Sager can fix it or I do, I will report what was necessary.
(By the way Sager tracked my invoice and apparently this is an NP8850.)
m
0
l
November 26, 2012 1:15:13 PM

Final Resolution:

A complete re install was necessary.
I was lucky the Windows 7 OEM re-install disk turned up.
The RAID configuration had to be enabled first then the win 7 install, then the driver disk.
I had to do it twice because the first time I must have missed the format choice and it ended up installed but with lots of old data from the old install!

Finally, after hundreds of updates to get it current it operates again.

Case CLOSED.
m
0
l
!