Sign in with
Sign up | Sign in
Your question

Radical games scarface will not work with windows 7 64 bit

Last response: in Windows 7
July 6, 2010 7:24:01 PM

Cant get Scarface the world is yours to work with Win 7 64 bit, ia there no recourse or it just cant be played on Win 7.

Best solution

a c 288 $ Windows 7
July 7, 2010 3:57:46 PM

Did you check the vendor site?
Related resources
July 7, 2010 7:51:32 PM

Go to Radical, Radical to EA cant find any support for this game but EA is still selling it.
July 7, 2010 8:17:45 PM

Im on Activision site right now there seems to be no support and doesnt show system compatility, on game I own says XP, 2000 WIN. I have WIN 7 64 bit and have tried all compat modes, even downloaded some dx stuff, nothing seems to work so I uninstalled the game. It worked of course when my system was XP. Now when starting game, I can here tony moving and talking but cant see him or mansion. Once you get WIn 7 running new EVGA vid card cant go backwards.
July 8, 2010 10:29:13 PM

cassandraf_winteam said:
If you are using Windows 7 Professional or Ultimate you can play the game in XP Mode. This is a great way to run programs that are not compatible with Windows 7 -

Microsoft Windows Outreach

Using Windows 7 Home Premium, any help would be great, just started playing GTA San Andreas in Vista conmpat mode would love to be able to play Scarface.
July 19, 2010 7:17:07 PM

Best answer selected by Rampage434.
July 19, 2010 7:25:52 PM

The vendor said this game will not work with WIN 7 64 or 32 bit will only work with XP, 2000, dont even think it will work with vista they tolf me unless i had access to those os's couldnt be used. I e]went XP to WIN 7 64 home premium so I dont have Virtual XP, so unless I move up to Professional or Ultimate which I am told might work I wont be able to play it.
July 19, 2010 8:21:49 PM

Sorry for last post spelling.
September 1, 2010 3:13:21 AM

I found a solution you'll love or not...
Scarface (xp dvd, non-pirated version,) :bounce:  Works after this tweak in windows 7 x64 ultimate for me.
No compatibility mode...Use msconfig, boot tab, advanced options, check number of processors set this at 1.
reboot. Works for me! :bounce: 
Running at 1/4 processing power is a bummer. Actually using a SLI setup too... let me get back to you with frame rates 15 minutes.
September 1, 2010 4:14:09 AM

Okay bit longer than 15 minutes...The game seems intended to play at 60 fps vsync, the more fps the faster tony goes.
These graphics settings:
Resolution -1920x1080
Anti aliasing -8x
Special Fx -On
Draw Distance -Far
Anisotropic Filtering -16x
Trilinear Filtering -On
Requires two sli enabled 9800gtx+'s to hold 60 fps vsync, one card produces roughly 47 fps outdoors running. Both cards scale to around a 100 fps out door running.
Regardless it's runs fine and playable for me.

edit added: Vsync isn't done in the game options, requires setting with nvidia control panel controls prior to running the game