Sign in with
Sign up | Sign in
Your question

assigned IP address,how to stop it?

Last response: in Windows XP
Share
Anonymous
June 19, 2005 11:28:00 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I have SBC DSL with a 2Wire router/modem/home portal. The modem needs
to sign my computers with a network assigned IP address in order for
the computers to connect to it and connect to the internet.

My problem is that everyday something happens to XP that makes XP
automatically assign me a IP address instead of the modem. The XP
assigned address is always 162, the modem's address is always a 192
address.

Now, when Panda Antivirus finds a virus and asks me to reboot to
complete the virus deletion, XP takes over my IP address and I can't
connect, I have to do a system restore to get it back the way it
should be, I can't change the IP manually.

Also, when Zonealarm asks me to let IP Config Utility to access the
internet, the IP changes to a XP assigned IP, and again, I have to do
a system restore to get back to my old IP address.

I have XP Home SP1 with all the latest updates except the latest 4,
due to the fact that when I update to the latest 4 updates, XP
assigns the address yet again.

I am virus,adware,spyware free, repaired then reinstalled XP hoping
that will work as well, but it didn't.

So, I am asking how I should go about stopping XP from automatically
assigning me a IP address and letting my 2Wire assign it instead.

This is my first post here, I hope to stay a while :) 

More about : assigned address stop

Anonymous
June 20, 2005 1:17:06 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

"ohgrfreak" <ohgrfreak@gmail-dot-com.no-spam.invalid> wrote in message
news:ucCdnWSRF9UNkCvfRVn_vg@giganews.com...
>I have SBC DSL with a 2Wire router/modem/home portal. The modem needs
> to sign my computers with a network assigned IP address in order for
> the computers to connect to it and connect to the internet.
>
> My problem is that everyday something happens to XP that makes XP
> automatically assign me a IP address instead of the modem. The XP
> assigned address is always 162, the modem's address is always a 192
> address.
....<snip>...

I'm not familiar with that SBC brand DSLModem+Router combo device, but you
are right in that it is the Router part of the device that should be
assigning the IP address of something like 192.168.x.x to your computer. If
at boot the computer cannot obtain an IP address in that range from the
Router then Windows will assign a "place holder" invalid IP address, and yes
if my memory serves me correct it is always the same and starts with 162 in
that case. You should be able to obtain free telephone support from SBC on
this issue, but I can provide a few points of interest regardless.

Now, 2 things must be in place for the computer to obtain a 192-type "LAN"
IP address "from the Router". First, the Router must be configured to be a
"DHCP" server. 2nd, Windows must be configured to obtain that needed LAN
address via DHCP from the Router. Also, Windows must be configured to use
the Router as a "Gateway", meaning you need to know the *ROUTER'S*
"192.168.x.x" LAN type IP address, too. It could be different, but the
Gateway address for most routers is, by default, 192.168.1.1 (you'll need to
check with SBC to know for sure).

In XP, if your "My Network Places" icon is not showing on your desktop then
right click a blank area of your desktop and select Properties, then the
Desktop tab, then click the Customize Desktop tab, and then make sure the
General tab is selected. At minimum, place a checkbox in the My Network
Places option block, and then slowly click OK two times.

Now, right click your XP desktop My Network Places icon and select
Properties. You should then see at least one icon in the "Lan or High Speed
Internet" section. One of them is for where your cable from the Router
connects to your computer; right click it and select Properties. In the
"This connection uses the following items" section, scroll down to where you
see "Internet Protocol (TCP/IP)"; there should already be a check in its
option box, make sure there is and then double-left-click that entry. Now
make sure the option to "Obtain an IP address automatically" is selected.
Also, make sure the "Obtain DNS server address automatically" option is
selected. Now click the Advanced button and then select the IP Settings tab.
In the "Default gateways" section is where you should have the IP address of
your modem+router itself (it's own IP address, which starts with 192). If it
is not there and the correct one needed, then you click the Add button and
enter it and make sure there's a check in the "Automatic metric" option and
then click the Add button. [Again, you might have to ask SBC what that
Gateway address should be. Without it your compuer has no idea how to get to
the device, your modem+router, that connects to the internet.] There should
be only *one* such Gateway address, if an incorrect one exists then
hightlight it (click it one time) in the "Default gateways" section and then
click the Remove button.

With XP, unless a popup happens instructing otherwise, you don't usually
have to reboot for network changes to take effect -- most changes will
happen right away. It doesn't hurt to reboot at this point, though, as then
the changes that were just now made to the networking sections of your
Registry will get saved and you'll have an automatically generated "System
Restore" checkpoint created. Doesn't hurt to make your own System Restore
checkpoint both before making changes and following a boot after having made
changes, too.

That really should do it. If it doesn't then it is possible that the SBC
Modem+Router is itself not configured properly (contact SBC), you've
specified the wrong Gateway address to Windows (contact SBC), or there's
something wrong with XP itself. I do very, very highly recommend that you
get *all* the current XP updates installed ASAP, many of them being
installed will fix XP bugs that weren't known about before the updates came
out to fix them (and this might involve your problem, too). The updates also
protect you against "holes" in XP itself, such holdes are NOT viruses etc.
but DO ALLOW your computer to be compromised if you are connected to the
internet, with or without your personal involvement, and *REGARDLESS* of
your anti-malware utilities that you have installed (I swear this is true).
So do the updates and know that you're working with what is supposed to be
the "fixed, better and more stable" version of XP.
!