Sign in with
Sign up | Sign in
Your question

Clevo D900K USB Device Not Recognized (Malfunction)

October 29, 2012 4:42:35 PM

Hi everyone,

I have a very annoying problem with my laptop that I hope someone can help with?

A while ago I took my laptop to a computer repair shop to be repaired (for a crashing issue, which I ended up fixing myself recently). When they gave me back the laptop they told me "We couldn't fix the crashing issue and Oh you're USB ports have malfunctioned and don't work". The funny thing is my USB ports were fine before I gave them it so I have no idea what they have done :( 

I've read countless forums and suggestions by people online and have tried everything, but I'm still unable to resolve the issue.

I'll give more detail below:

My Laptop is a Widow PC Sting (Also known as a Clevo D900K) which is running Windows XP SP 3.

I have 4 usb ports that say "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it". Everytime I put any USB device into it. (Just to confirm all my USB devices are fine when plugged into my desktop).

When going into device manager and checking my USB devices (even with nothing plugged into them) I see some entries saying "Unknown Device". When I check the properties section it says no drivers are installed for this device. When I try to update the drivers it says that no better match can be found?

I've tried uninstalling all USB entries in device manager (including hidden) and letting them reinstall with a reboot but the issue is still present.

I've unplugged the Laptop from the power supply, removed the battery and let it sit for a while and that didn't seem to resolve the issue.

I've also done the DisableSelectiveSuspend in the registry and it still didn't work.

As mentioned, I think I've tried everything I can think of and it doesn't seem to solve the issue. Does anyone have any ideas?

Also, just to confirm - My USB ports still seem to be getting power to them as I plugged in a USB MP3 player and it started to charge (but still got the "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it" message.

If anyone can help with this it would be greatly appreciated, as I don't really fancy taking my laptop into a repair shop again as they might break something else! :( 
!