Sign in with
Sign up | Sign in
Your question

Acer aspire 5552-3691 wont power on

November 13, 2012 2:34:35 AM

hi, i have a customer laptop she is having problems turning it on. so when you push the power supply button it turns off and in about 3 seconds it turns off.

the steps i tried,

removed all hard ware memory hard drive, cmos battery, ram and wireless nic.

i hold the power button to discharge all the remaining power from the mobo cpu etc. then pushing it a couple of times to make sure it doesn't leave small charge behind. i turned on the laptop with out cmos battery still no luck.so i tried the ram in different slots to see if it works at one point it did. but when i turned it off then switched the memory to see if it was a bad stick or slot it wont start up no matter what stick or slot i use. she told me that when u shake it around a bit some times it turns on. i did the same thing i don't see any results. i believe either the processor is loose or has dirt on one of the pins or not properly seated correctly.



update: i cleaned the ram sticks using a special polishing cloth on the gold pins they where very dirty. its like cleaning a penny with a white cloth all that black crap comes off. so i have a stick on slot 2 if i hold it a certain way it turns on, but some ways it turns on but shows a black screen. it varies which way i hold it some times that certain way wont turn it back on.

also i for got to mention i took out the battery and used just the power supply doing all methods i provided above.

update 2: ok i think i figured out the problem. i believe its either the ram sticks or the slots them self's cause when i power on the laptop with out cmos and ram sticks it stays on until i remove the battery. the power button does not turn it off if i hold it down. all tho it does it some times. when sometimes it turns on and goes past post it shows the boot from lan feature, so if i hold down the power button it does not turn it off i have to turn it off from removing the battery.

update 3: i tried it with out the battery the powered it using the power supply but it does not turn on at all. so i was thinking it might be the power port so i move the connection around a bit and at a certain way it turns on but if i move it turns off automatically. so i think i need to re soldier the power connection, if its damaged i might need to purchase a new one.
!