Games lag when laptop is running on battery!

Hey, I have the MSI GT780DX with nvidia GTX 570M gpu.
When I play games on my battery alone, everything lags.
When I have it plugged into my charger there is no lag at all.
I have my power set to "High Performance" and it still lags.
I have read that I may have to change things in my BIOS.

Here is what i have my settings set to

Advanced settings >

PCI Latency Timer: 32 PCI

SATA Mode: AHCI

Intel SpeedStep: Enabled

iCharger: Disabled

Is their another way I can fix this problem?
7 answers Last reply
More about games laptop running battery
  1. It's not a BIOS problem, because if it was, then there'd be lag even when it's plugged in. If it's lagging only when you run it on battery, then it's a battery problem. How old is the laptop? It might be a simple question of changing the battery.
  2. You have the power set to high performance for "when plugged in" and "battery" as there as always 2 different settings for both modes.

    I don't think it's the battery, as a bad battery just doesn't charge well or hold a charge, not lag the pc. That makes no sense.

    I say it's related to some power management settings. Looking at that laptop, it has all kinds of things like turbo battery, eco mode, all kinds of things. Maybe something is slowing down the video card speed or cpu speed.

    Run some software like MSI after burner to watch your gpu speeds, both plugged in and on battery while gaming, see if they change. If so, look in the video card control panel for power management features. Use something like CPU-Z or some other CPU monitor utils and check CPU speeds while gaming on power and battery. Do they change. Then it's some power management thing you're not seeing.
  3. solution is easy. First click battery icon then choose more power options. On selected plan there will be change plan settings. click on it then there will be change advance power setting. now you will see some options. there will be power management options select it. just change ON BATTERY 100%. this will solve your problem. :)
  4. Yeah, you need to go into Power Management for "High Performance" then click on the advanced options link or button (not sure since I'm at work and the PC uses Win XP). Go through each item and change the setting to either 100% or maximum performance depending on the settings.
  5. Thanks for the replies. But the problem was my battery can't handle high performance games alone :P!
  6. It's not just the battery, I have the same laptop. The bios is designed to force an underclock on the 570m when on battery power. I have the barebone version of your laptop, and mine underclocks from 1500mhz to 575mhz, just by simply unplugging the power cord. I suppose it is to "save" the battery, but still annoying nonetheless.

    Depending on how brave you are, I downloaded nvidia inspector, and overclocked my card slightly when on P8 (performance, not-charging), so I could squeeze out a few more frames per second. Although you can adjust the memory and core clocks, the voltage is locked in at the lower amount.
  7. dude..it is normal for having this kind of situation..^^
    i used to have it on my asus laptop..
    but generally it was all the same
    please refer to this forums..
    however this is for asus users..
    but the contents mainly comprised the same reasons

    http://rog.asus.com/forum/showthread.php?20327-Games-lagging-without-the-charger-is-it-normal

    hope it helps! =D
Ask a new question

Read More

Battery Games Laptops