Sign in with
Sign up | Sign in
Your question

I'd like my Linux box to join my little network

Tags:
Last response: in Linux/Free BSD
Share
September 10, 2003 5:10:57 AM

This is my first foray into Linux, and I'd like this unit to become part of my small office network.

I'm running RedHat 8.0. Tech support doesn't answer me; and I can't figure out how to get the settings right for this machine to join my five other boxes running XP and 98SE. I've read the documentation, but I'm lost.

The five existing computers see and talk to each other just fine through a switch. I can't get the Linux to show up.

All six have the same nics, and are cat5 cabled up. I'm asking for some fundamental help.

More about : linux box join network

September 11, 2003 7:18:04 PM

PScowboy: what you need is Samba, I've gotting Samba to work when I had Mandrake loaded, and it's derived from RedHat so it should help out. For a little while now I've been running Knoppix which boots from a CD and has built in networking tools, sets up the home sharing very easy.

Hope this points you in the right direction.

Tonka
September 12, 2003 12:56:48 AM

As stated, you need Samba. There are two packages to start with - samba client and samba server. Once installed and set to run at startup, you'll have to make sure you are on the same subnet, eg 192.168.0.x and then the same workgroup/domain. Firstly, make sure you can ping the other machines. Once we know where it's at IP wise, we can get into Samba and filesharing specific stuff.

Richard.

<i>Knock Knock, Neo</i>
Related resources
September 12, 2003 3:28:04 AM

Thanks guys! I'll get busy with that in the next day or two and report back.
September 13, 2003 4:56:14 AM

Installed Samba from the CD#2. Changed the Workgroup name in the smb.conf file to match the MS machines.

Using 10.10.10.x as IP addresses and a subnet of 255.0.0.0 on all.

I can ping the Linux box from any of the MS units. But I am unsuccessful in pinging anything from the Linux.
September 14, 2003 7:09:28 AM

Weird. Are you trying to ping by IP or by Name?

<i>Knock Knock, Neo</i>
September 15, 2003 12:25:38 AM

I'm pinging by IP address.

It seems that the ping is not getting out of the Linux box.

Do I have to set up a Gateway? One of the issues mentioned in one of the answering posts was setting up a Domain. I don't get that stuff. I don't think one sets up Domains in Windows? Or,maybe so?

Anyway, I've got every Samba rpm installed that I could find on the CD. But after that, there is no Wizard that comes up to help a guy properly set up the Linux to be accepted in a mixed environment. I know you guys will eventually get me through this.
September 15, 2003 1:28:46 AM

It possibly is the gateway that's the problem. Run "route" and see if tells you the anything meaningful. Setting up a domain isn't an issue until you start using domain names to locate machines.

If you "dont get" this networking stuff, post the contents of /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-eth0 and i'll try to spot anything obviously broken.

<i>Knock Knock, Neo</i>
September 15, 2003 8:03:43 AM

ROUTE
Destination Gateway Mask Flags Use
168.121.1.1 255.255.255.255 uh ppp0
10.0.0.0 255.255.255.0 u eth0
10.10.10.0 255.255.255.0 u eth0
127.0.0.0 255.0.0.0 u lo
default 168.121.1.1 0.0.0.0 ug ppp0

network
NETWORKING=yes
HOSTNAME=localhost.localdomain
GATEWAY=10.10.10.0
GATEWAYDEV=eth0

ifcfg-eth0
USERCTL=no
PEERDNS=no
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:04:5a:7b:D a:2a
BOOTPROTO=none
NETMASK=255.255.255.0
ONBOOT=yes
IPADDR=10.10.10.1
NETWORK=10.0.0.0
BROADCAST=10.10.10.255
GATEWAY=10.10.10.0

This may be a dumb question, but, does Samba have to be installed on the MS machines?
September 16, 2003 12:54:12 AM

Ok, notice the default on the last line when you type route. It's trying to pass traffic out through your ppp interface, which obviously isn't what we want.

Flush the routing table and use:
$ route add default gw 10.10.10.0

See if you can then ping the gateway, if you can (and you should be able to), you're in business.

And no, samba doesn't need to be installed in windows :) 
September 16, 2003 7:40:59 AM

Well, we're getting there! I can now ping in both directions; and localhost is now seen in Network Neighborhood on the MS machines.

But when I click localhost in NN, unfortunately I get an error message saying that it's not accessible.

Also, how do I see the MS units from the Linux box??
September 16, 2003 10:53:48 AM

It's cool that it's working, but I don't think that lame's answer is entirely accurate. Default gateway is for when no other gateway matches. Eth0 should be used for network 10.10.10.0 automatically. The problem is that your NETWORK=10.0.0.0, not 10.10.10.0. Your NETMASK=255.255.255.0, which then puts you on 10.0.0.x not 10.10.10.x.

NN is Netscape Navigator? localhost will refer to a webserver that isn't running :-) I'd recommend giving the machine a less ambiguous name. Take a look at /etc/samba/smb.conf

There are a few apps to access the Windows network from Linux, but for sensible browse and click type of access, I'd recommend KDE3 or Gnome2. If you have bandwidth to burn, take a look at <A HREF="http://www.ximian.com/products/desktop/features.html" target="_new">Ximian Desktop2</A> (free download).


<i>Knock Knock, Neo</i><P ID="edit"><FONT SIZE=-1><EM>Edited by poorboy on 09/17/03 01:01 AM.</EM></FONT></P>
September 16, 2003 7:34:12 PM

NN = Network Neighbourhood I believe. Erm, like poorboy said localhost is usually a reference to the machine you're on :) 

As far as getting the filesharing setup, what's probably lacking here is a correct smb.conf. In said file is where you setup the shares for the linux box. In your smb.conf you'll want to make sure:

workgroup = <name of your workgroup>
netbios name = <something other than localhost :>

For help setting up specific shares either 'man 5 smb.conf' or http://ca.samba.org/samba/docs/man/smb.conf.5.html.

and,
poorboy: not the best answer but probably the easiest :) 
September 17, 2003 3:58:38 PM

I really appreciate the patience you guys are showing while I dork my way through this. Bad news! The ping ability went away, and I'm back to square one.

Poorboy's inference that my netmask was incorrect, induced me to try to "work" the numbers.

Mask______255.0.0.0
Network___10.10.10.0
IPaddr____10.10.10.1
Broadcast_10.10.10.255
Gateway___10.10.10.10

I tried the above, but the system refuses to give me a network of 10.10.10.0 and I still can't ping.

The ifcfg-eth0 file reflects the above numbers, but "route" at the command line gives me:
Destination__________Gateway____________Mask___________Use
10.0.0.0________________*___________255.0.0.0__________eth0
127.0.0.0_______________*___________255.0.0.0__________l0
default_________________*_____________0.0.0.0__________eth0

This is very frustrating for me. I've set up hundreds of Peer to Peers, and Novells in less than an hour each.
September 18, 2003 2:37:43 AM

Nope, the netmask was fine - it was the network that was wrong.

Mask 255.255.255.0
Network 10.10.10.0
IPaddr 10.10.10.1
Broadcast 10.10.10.255
Gateway 10.10.10.1
# probably don't need that last line anyway.

Remember to either reboot or restart the network after making the changes.

<i>Knock Knock, Neo</i>
September 18, 2003 2:40:26 AM

I'm almost wondering if it would be easier just to install RH9 or something, and take advantage of things "just working" and better config tools.

<i>Knock Knock, Neo</i>
September 18, 2003 5:22:39 AM

I made your recommended changes. Rebooted; but it still won't ping. I must be missing something. Domain stuff? Samba stuff?

I've spent over 50 hours on this box trying to get it to work. It's now become a vendetta principle. In my entire techie life, I've never not solved a problem eventually. If I give in to RH9, I will be a beaten man. Please understand.
September 18, 2003 5:38:13 AM

I understand completely (unfortunately). I'm actaully little confused over this one, and that's bugging me bigtime - I'm supposed to know about this stuff...

You're not missing any software, and as shown in your previous post it *can* work when default gateway is pointed at the LAN. Traceroute might give some hints about where it's going wrong.

I guess you've checked out the RedHat doco?
<A HREF="http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual..." target="_new">http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual...;/A>
<A HREF="http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual..." target="_new">http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual...;/A>

<i>Knock Knock, Neo</i>
September 18, 2003 5:52:40 AM

One other thing, according to the RH8 doco, GATEWAY shouldn't be in ifcfg-eth0. I'm not sure you need to set it in /etc/sysconfig/network either, unless someone else on your network is routing traffic to the internet. When you dial out and ppp0 comes up, that will set its own new default gateway anyway.

<i>Knock Knock, Neo</i>
September 18, 2003 7:15:52 AM

$ ifconfig eth0 10.10.10.1 broadcast 10.10.10.255 netmask 255.255.255.0
$ route add default gw 10.10.10.1 netmask 0.0.0.0 metric 1 eth0

try inputting each of these, then trying to ping. and paste the results of an 'ifconfig eth0'
September 18, 2003 5:22:22 PM

I changed default gw to same address as eth0.

The "route" command now pops up the gw right away as the host name, where in the past it took route about a minute to resolve the gw thing.

But alas, I still can't ping in that direction. The Windows machines have no trouble pinging the Linux box, but it does not show up in Network Neighborhood.

I'm freakin' pulling my hair out. Samba is set up perfectly (testparm says so). The nic is known good, the cable is known good. Route, netstat, & ifconfig also confirm that the network is up. We're missing something.
September 19, 2003 6:45:30 AM

I didn't bother reading the whole thread, but I saw that you had samba working. What you need to do is this:
On the RH box:
#netconfig

IPaddress: 10.10.10.1
Mask: 255.0.0.0
Gateway: whatever your gateway is
DNS: whatever your dns is

On the windows pc's:

change addresses to 10.10.10.2 and increment by one for each. Give the mask of 255.0.0.0

The reason you can ping from windows to linux, but not vice versa is because MS's implementation of teh TCP/IP stack does not follow RFC standards, and thus can reach hosts on networks below them. The linux box gives a ICMP reply as it knows the mac even though it thinks it can't reach the network with the windows pc's on.

Dev

---
My Sig:
))
(( ___________________
|||_____________|_____|
September 20, 2003 2:20:02 AM

Thanks for coming on board with this.

I punched in the numbers you suggested. Actually, I only typed in the IP address, and then the tool filled in everything else. I had no reason to not accept defaults. I don't have a real gw or nameserver. It's just a small internal office wanting to learn to use Linux.

Alas, STILL CAN'T PING. The boss is of the opinion now to scrap this deal. I've been trying to get this machine into their existing network for two weeks now and it won't work.
September 23, 2003 5:14:07 AM

I am a little confused, but check that all your subnet masks are the same. In your posts you state that you have the mask of 255.0.0.0 (or /8 IOW), but the output shows 255.255.255.0

To make this work follow these instructions to the letter:
1. Determine netmask. Whether you want to use a /8 (255.0.0.0) or /24 (255.255.255.0) does not matter much for your setup, so choose the one you prefer. However, all machines need to have the same mask!!!!

On the Win boxes change the addresses to 10.10.10.x where x is any number (except 0 if you use a /24 mask).

On the Linux box:
# netconfig
IP Address: 10.10.10.x (same rule as above for x)
Mask: Either 255.0.0.0 or 255.255.255.0 (must be same for all boxes)

Network: This will be either 10.0.0.0 for a /8 mask or 10.10.10.0 for a /24 mask. Very important not to mess this up.
Gateway: Whatever gateway you have
Nameserver: Ditto

Now open a command prompt on the windows boxes:
C:\ipconfig /all

This will give you all the information on the IP settings. Make sure that all masks are the same and that all addresses are 10.10.10.x.

Then on the Linux machine:
#ifconfig -a

Make sure that IP address is 10.10.10.x and mask is the same as the windows boxes. (I can not remember if the mask is given in Hexadecimal on RedHat. If it does then ff: is the same as 255. and 00 is the same as 0.

Now ping all the hosts from every host, i.e. ping all the machines from the linux box, then repeat for all the windows boxes.

If you still don't have connectivity, change the cable. I have seen some strange issues from slightly broken cables. the most extreme was one where NetBios could communicate but not TCP/IP... That could be the case for you, but you should make sure that your addressing is correct first.

If you still have problems, please post the output of "ipconfig /all" and "ifconfig -a" from all the hosts.

Hope this helps...

Dev

---
My Sig:
))
(( ___________________
|||_____________|_____|
September 23, 2003 5:20:04 AM

I decided to scrap the existing 10.10.10 numbers, and try something else. I deleted eth0 and started over using netconfig, which fills everything in for you after the IP address is entered. I get this:

Ip_____192.168.1.1
Mask___255.255.255.0
GW_____192.168.1.254
B'cast_192.168.1.255

It also set up the default network of 192.168.1.0

My route table is perfect:
Destination___________GW_____________Mask_________IFace
192.168.1.0_________0.0.0.0_____255.255.255.0_______eth0
127.0.0.0___________0.0.0.0_______255.0.0.0_________lo
0.0.0.0__________192.168.1.254_____0.0.0.0__________eth0

ifconfig confirms the nic is configured and up & running.
route -n and netstat -rn confirms that the network is setup.
Samba client & server are set up during boot.

Everything looks perfect, but this Linux will not ping my Windows machines (I don't think it's getting out of the box), nor is it visible in Network Neighborhood. What did I miss doing, that is not allowing this unit to join the existing computers?

Ipconfig on the Windows units: (showing first one, others same except macs & last # of IP addr.
Description........................Linksys LNE100TX(v5)
Physical Address...................00-04-5A-83-C1-27
DHCP Enabled.......................No
IP Address.........................192.168.1.2
Subnet Mask........................255.255.255.0
(Everything else is blank-no entries)

Ifconfig eth0:
Link encap:Ethernet HWaddr 00:04:5A:7B:D A:2A
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 METRIC:1
RXpackets:364 errors:0 dropped:0 overruns:0 frame:0
TXpackets:125 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RXbytes:57190 (55.8Kb) TXbytes:18931 (18.4Kb)
Interrupt:5 Base address:0x6000

The only thing I'm not sure of is that metric of 1. That usually means an external gateway, which I do not have. If it means I have to somehow change that to 0, how do I do that?
September 23, 2003 6:43:29 AM

In IP addressing you have to be on the same network in order to talk to another host. By changing to 192.168.x.x you are on a different net than the windows machines. I'll try to explain this, but don't worry if you get lost or don't know all the terms.

Any serious network addressing scheme has a host portion and a network portion. The function of the subnet mask is to determine which part of an IP address is the network and which part is made from that network's host addresses. Let's take the network addresses 10.0.0.0 and 192.168.1.0. For the 10.0.0.0 we will have a mask of 255.0.0.0 and for the 192.168.1.0 network we'll have 255.255.255.0.

These numbers are "human readable" format of binary numbers so let's take a look at how these numbers look in binary.

IP: 10. 0. 0. 0
Binary: 0001010.00000000.00000000.00000000

IP: 192. 168. 1. 0
Binary: 11000000.10101000.0000001.00000000

Mask: 255. 0. 0. 0
Binary: 11111111.00000000.00000000.00000000

Mask: 255. 255. 255. 0
Binary: 11111111.11111111.11111111.00000000

The binary masks are always a row of 1's to the left and 0's to the right. All the 0's denote the host portion of the mask (TCP/IP zealots disregard this sentence ;) . If you have a pc with the address 192.168.1.10 the .10 represents the host portion. If we change this number to 192.168.1.40 the pc can still talk to the other pc's (given none of them already has the .40 address). However, if we change the .1 to a .2 (so we have 192.168.2.10) it can no longer see the other machines.

Now let's take the binary form of the 192.168.1.0 address and pair it with the binary form of 255.255.255.0

IP: 11000000.10101000.00000001.00000000
Mask: 11111111.11111111.11111111.00000000

All the binary digits above the 1's in the mask denote the network. What this means is that once any number above the 1's in the mask change you are on a DIFFERENT NETWORK! This again means that you can no longer communicate with the host on the previous network.

Now imagine you have 3 computers on this network with host id .10, .20 and .30 and they can all communicate.
Host 1: 192.168.1.10/24
Host 2: 192.168.1.20/24
Host 3: 192.168.1.30/24

On the last host we decide to change the 1 in the third octet (the digits between the dots are called octets since they are representative of 8 bits as shown above).

Host1: 192.168.1.10/24
Host2: 192.168.1.20/24
Host3: 192.168.2.20/24 #notice the 2 in the third octet.

Binary again:
Host1: 11000000.10101000.00000001.00001010
Host2: 11000000.10101000.00000001.00010100
Host3: 11000000.10101000.00000001.00011110 (before change)
Host3: 11000000.10101000.00000010.00011110 (After change)

To be continued (work emergency)

Ok, here we go again:

Host3: 11000000.10101000.00000001.00011110 (before change)
MaskA: 11111111.00000000.00000000.00000000 /8
MaskC: 11111111.11111111.11111111.00000000 /24

Host3: 11000000.10101000.00000010.00011110 (After change)
MaskA: 11111111.00000000.00000000.00000000 /8
MaskC: 11111111.11111111.11111111.00000000 /24

Now compare the bits we changed with the different masks and you can see that for mask A those bits are above 0's, but for mask C the same bits are above a 1. Above I stated that as long as the bits that change (in the address) are above 1's (in the mask) the network also changes, and that the bits above 0's in the mask only change the host address and thus stays on the same network.
Now you can see that if you use your addressing scheme with 10.10.10.x you can be on either the 10.0.0.0 or the 10.10.10.0 network and you get problems.

I hope this makes sense and that you can figure out your problem.

Dev
---
My Sig:
))
(( ___________________
|||_____________|_____|
September 24, 2003 4:13:05 AM

I understand all of that, Dev. But perhaps you didn't read the whole post. I changed all the Windows machines to the 192.168.1 network as well. Check out ipconfig summary.
All six machines are 192.168.1.1-6
Linux does not ping any of the MS boxes. The ping is not getting out of there. I changed the cable to Belkin new. Same result.
September 25, 2003 5:32:31 AM

Can you ping your loopback (127.0.0.1)? If no, make sure that the driver is right and that the NIC is not broken.

If yes, try to install Ethereal (it may already be installed on your RedHat box if you chose to do it during the install) and see if any packets come from the linux host. You may also inadvertently have configured a firewall to block ICMP (to lessen risk of DoS).
Lastly make sure that no NIDS/IDS is running so that it blocks ICMP.

Also, I took some time writing my last post and did not see your post with the output that I was asking for. I guess you were waay ahead of me :) 

Dev



---
My Sig:
))
(( ___________________
|||_____________|_____|
September 26, 2003 6:52:29 AM

127.0.0.1 (Broadcast) successfully pinged 127.0.0.0
The nic is known good.

As to the rest of the stuff you mention, I have no Admin experience at all with Linux. This is my first box.

I don't know how to check the driver for the nic.
I installed ethereal, but don't know what to do with it.
I don't know if there is a firewall blocking ICMP, nor do I know how to look for it.
I don't know anything about NIDS/IDS; or if it's there.

Sorry, this hasn't been easy for any of us.
September 28, 2003 3:40:09 AM

After rereading this thread I am thinking that it is a driver problem. If know what NIC you have I can find out (or you can google) what the module is called.
Also do a:
# service iptables stop (instead of iptables it might be netfilter. I can't remember..)

That will kill your firewall.

You probably don't have any IDS's installed (Intrusion Detection Systems) if you don't know.

In ethereal you just open it and go to the capture menu and capture some packets. Don't worry about that unless you really want to learn how to sniff a network, (which can be very useful to know by the way).

Also could you give me the output of the lsmod command?

Dev

---
My Sig:
))
(( ___________________
|||_____________|_____|
September 28, 2003 4:46:25 AM

Flushing the firewall with "iptables stop" enabled me to ping both directions. Of course, that begs the question if I want to run this box without its' protection? I am assuming, now that we know what was preventing communication, that it can be fixed? reconfigured? replaced by something less intrusive?

The nic is Linksys LNE100TXv5.

lsmod: I'm only giving you names, figuring that's all you needed.
sr_mod .............18200
emu10k1 ............69128
ac97_codec .........14600
sound ..............74196
soundcore ...........6500
parport_pc .........19044
lp ..................8996
parport ............37152
autofs .............13332
tulip ..............43840
ide-scsi ...........12176
scsi_mod ..........107608
ide-cd .............35808
cdrom ..............33728
mousedev ............5588
keybdev .............2976
hid ................22340
input ...............5920
usb-uhci ...........26412
usbcore ............78944
ext3 ...............70880
jbd ................51988

There are two other very minor gliches, if you wouldn't mind imparting your wisdom to:

On bootup, /etc/fstab/modprobe can't find module-block-major-2. Is this of any concern?

The sound does not play upon login into the desktop. Sound occurs everywhere else.

I am most in your debt for all this time and patience you've extended me. Thank you!! Some day I'd like to buy you your favorite repast.
September 28, 2003 6:11:22 AM

Communication lasted about 20 minutes. Then Linux disappeared from NN, and I could no longer ping the Windows boxes. When I went over to the Linux box, there were flames burning on the screen on a black background. All the other times I had left this unit and come back later, the screen was just black. I hope you're going to tell me this is someone's joke for a screensaver.

I rebooted Linux, stopped the firewall, and could not ping even once. This thing gets curiouser and curiouser. Very depressing.
September 29, 2003 9:03:56 AM

Re the flames, yes it's a screensaver. As far as firewalls go, IIRC RedHat has a security level selector, accessable via GUI and via 'setup' at the shell. Setting that to it's lowest level should turn all firewalling off. You may also be running the portsentry service which can block access, but it shouldn't affect a simple ping. You can turn it off if in doubt, using either the shell or gui.

<i>Knock Knock, Neo</i>
September 30, 2003 6:48:28 AM

Ok, so we found that the firewall was one of the problems. I totally forgot about port sentry, and although I doubt it is the problem you might want to turn it off.
Try to ping the loopback (127.0.0.1) whenever you can not ping out. Also run an "ifconfig -a" to make sure that the eth0 is there. These two steps are just there to eliminate the basics. Also check cables.
I'm sort of stumped at the moment as to what this can be. Since it works with the current driver (tulip BTW) I don't think it's the card. You stopped iptables... i'm currently out of ideas, but that may be because I have worked waaay to hard over the last few weeks and only gotten about 3 hours of sleep every night. I think I'll go home and sleep and then try to figure it out.

What you could do, though tedious, is to do an
# ls /etc/rc5.d
and look at all the scripts starting with an S, then look those up online (google for them without the S and the number). If you find that one of these do something restrictive to your network you can rename them, for example like this with iptables.
# mv /etc/rc5.d/S**iptables /etc/rc5.d/s**iptables

where ** is the number that iptables has. These scripts must start with a capital S (to be started) or capital K (to be stopped). Any script not starting with a K or S will not be processed, so a good way to modify these is to change to a lower case s or k. That way you know that it used to be started in case you made a mistake.

I never heard of that module you mentioned, but it seems to be related to your hard drive or other block device. I'll see what I can come up to tomorrow after some sleep (if they don't call me in AGAIN!!!)

Finally, Linux is the king of poor screensavers... sorry you had to see that 8^)

Dev

---
My Sig:
))
(( ___________________
|||_____________|_____|
October 1, 2003 6:56:08 AM

I've had those periods of employment when one can't get enough sleep. Been there; done that. Hope that turns around for you.

Here's the latest for today at this office.
In Applications - System Settings - Security level.........I set firewall to none.
In Server Settings - Services.......I have portmap shut off.
I invoke service iptables stop.
With these three done, I CANNOT ping the Windows boxes, and it is not seen in NN.
Other days when I just did one of those, I could ping and communicate for awhile. Then it would stop. Then the next bootup, that particular trick would not work any more.
The hardware is all known good.

Over the last five years, I've done (and maintained) hundreds of small networks. This is the first one I can't get going. The manager of this office is pulling the plug on this. He will never touch anything Linux again. This box is going back to Windows.

Too bad. I really gave it a good try. I converted a Windows box to Linux RH 8.0. Everything default on the installation. Spent three days getting all the updates done. But this box refused to get in with the others, despite all the skillful help from you guys' posts.

What was most troubling was that RedHat has no tech support. This office paid the $60 for a basic entitlement. All this really gets you is the privilege to stay updated on the RPMs. You can't get anyone on the phone (we would have paid for it!); and the two e-mail addresses I got refused to help this problem. For me, not a Linux engineer, this is unconscionable.

I've been around computers since '83. This was a very bitter defeat for me. I will NEVER touch Linux again; and the eight people associated with this particular office don't want to hear anything more.

This thread is over for me.
October 1, 2003 8:48:58 AM

I'm sorry to hear that, but completely understand.

What's more, as a long time Linux user, developer and admin, I'm at a loss as to why you had that series of problems. Sorry it had to go this way, and that you couldn't have tried a different distro.

Re the support issue, yeh, the $60 gets you priority access to updates and things (can get them for free, btw, but not as quick in busy periods), but for RedHat techhie help you'd have to pay for an Enterprise version. I'm suprised a boxed version (I asume) of RH8 didn't come with install/setup support, but then I guess it's getting on a bit now.

Edit: RedHat's <A HREF="http://www.redhat.com/support/techsupport/production/GS..." target="_new">support policy</A> covers the 8.0 support issue specifically.

Hopefully things go smoother with the new setup. :-)

<i>Knock Knock, Neo</i><P ID="edit"><FONT SIZE=-1><EM>Edited by Poorboy on 10/01/03 10:56 PM.</EM></FONT></P>
October 2, 2003 4:08:47 AM

Thank you Poorboy and Dev! You guys gave me your best, and it was much appreciated. Down deep in my heart, I would still like to know what the glich was. Oh well; life isn't always a bowl of cherries. All the best.
Paul
October 6, 2003 8:53:24 AM

I am sorry that I never finished finding out what was wrong with your setup, but my work closed shop last week and it has been a little hectic around here. I know I probably can not persuade you, but you could try Knoppix (Linux from a bootable CD. Doesn't need hard drive). Once you "get it" you'll find that there are so many uses for Linux, and that it can really help you get the job done (whatever it might be).

Dev

---
My Sig:
))
(( ___________________
|||_____________|_____|
!