Sign in with
Sign up | Sign in
Your question

Extremely frustrating unrecognized wireless usb mouse and keyboard...

Last response: in Laptops & Notebooks
Share
November 23, 2012 6:29:40 AM

Hello,

I am really frustrated here. I have a Toshiba satellite c675d-s7109 notebook and I am having a headache trying to get a simple auto-install wireless keyboard and mouse working on it. The notebook is running Win7 Home Premium x64 and the brand of the keyboard and mouse is 'Trust'. I have tried plugging another wireless mouse and it worked. I tried plugging the 'Trust' wireless mouse and keyboard on another notebook and they both worked as well. So both are working well, but not together for some reason. Upon connecting the USB dongle, an unrecognized device pop-up appears in win7 labelled unknown device.

What I tried to do:

1- Went to the wireless keyboard and mouse manufacturer website and 'supposedly' installed their Windows 7 x64 driver based on the model number found on the back of the mouse ( 16609-02). The driver installs fine under programe files in the folder 'wireless keyboard driver' which obviously did not solve the problem after restart.

2- Uninstalled all USB controllers in Device manager and removed the laptop battery for two minutes and restarted while the dongle but it did not work either.

3- Went to Toshiba's official page and tried to find a mobo driver update but all I found was a superusb update that did not work either.

4- Tried uninstalling and reinstalling in safe mode, Nothing.

5- Tried to 'update' driver manually for the unknown device after I installed the Trust driver and windwos reported that ' Drivers for that device are up to date' but still, nothing happened.

Any other suggestions? pleaaase...

THank you
a b D Laptop
November 23, 2012 7:17:41 AM

Very long shot, but maybe worth a try: enable Legacy USB emulation. Quote from the user guide:
Quote:
TOSHIBA Hardware Setup is the TOSHIBA configuration
management tool available through the Windows® operating
system. To access it:
❖ Click Start, All Programs, TOSHIBA, Utilities, and then
HWSetup, or click the TOSHIBA Hardware Settings icon in
the Optimize tab of TOSHIBA Assist.
The TOSHIBA HWSetup screen appears.
...
USB—Allows you to enable or disable USB Legacy Emulation
(
November 26, 2012 5:32:54 AM

Did not work...:( 
!