Sign in with
Sign up | Sign in
Your question

How to stop sharing RAM in windows 7

Last response: in Windows 7
Share
July 10, 2010 6:47:56 AM

Hello,
My OS is Windows 7 64 bit.
when i go to;
Control Panel > Performance Information & tools > view and print detailed performance and system informaion.,, It shows these information under Graphics.;-

Total Available graphics memory - 2815
Dedicated Graphic Memory 1024
Shared system memory - 1791.

So, how i stop sharing my system memory. Sharing system memory will decrease RAM?
July 10, 2010 5:12:52 PM

dumisoft said:
Hello,
My OS is Windows 7 64 bit.
when i go to;
Control Panel > Performance Information & tools > view and print detailed performance and system informaion.,, It shows these information under Graphics.;-

Total Available graphics memory - 2815
Dedicated Graphic Memory 1024
Shared system memory - 1791.

So, how i stop sharing my system memory. Sharing system memory will decrease RAM?



FYI....It really helps if you provide system specs when asking for help. In this case, however, you're most likely using on-board graphics (the reason for the dedicated graphics memory). You'd have to add a graphics card (with it own dedicated memory) to stop using shared mem.

My systems looks like this (I'm using on-board graphics as well, for now):

More details about my computer


Component Details Subscore Base score
Processor AMD Athlon(tm) II X3 440 Processor 6.8 4.1
Determined by lowest subscore

Memory (RAM) 2.00 GB 5.5
Graphics ATI Radeon HD 4250 4.1
Gaming graphics 887 MB Total available graphics memory 5.4
Primary hard disk 40GB Free (67GB Total) 5.9
Windows 7 Professional

System
--------------------------------------------------------------------------------

Manufacturer System manufacturer
Model System Product Name
Total amount of system memory 2.00 GB RAM
System type 64-bit operating system
Number of processor cores 3

Storage
--------------------------------------------------------------------------------

Total size of hard disk(s) 67 GB
Disk partition (C:)  40 GB Free (67 GB Total)
Media drive (D:)  CD/DVD

Graphics
--------------------------------------------------------------------------------

Display adapter type ATI Radeon HD 4250
Total available graphics memory 887 MB
Dedicated graphics memory 256 MB
Dedicated system memory 0 MB
Shared system memory 631 MB
Display adapter driver version 8.710.0.0
Primary monitor resolution 1440x900
DirectX version DirectX 10


Hope this helps.
July 11, 2010 3:56:57 AM

mikey5802 said:
FYI....It really helps if you provide system specs when asking for help. In this case, however, you're most likely using on-board graphics (the reason for the dedicated graphics memory). You'd have to add a graphics card (with it own dedicated memory) to stop using shared mem.

My systems looks like this (I'm using on-board graphics as well, for now):

More details about my computer


Component Details Subscore Base score
Processor AMD Athlon(tm) II X3 440 Processor 6.8 4.1
Determined by lowest subscore

Memory (RAM) 2.00 GB 5.5
Graphics ATI Radeon HD 4250 4.1
Gaming graphics 887 MB Total available graphics memory 5.4
Primary hard disk 40GB Free (67GB Total) 5.9
Windows 7 Professional

System
--------------------------------------------------------------------------------

Manufacturer System manufacturer
Model System Product Name
Total amount of system memory 2.00 GB RAM
System type 64-bit operating system
Number of processor cores 3

Storage
--------------------------------------------------------------------------------

Total size of hard disk(s) 67 GB
Disk partition (C:)  40 GB Free (67 GB Total)
Media drive (D:)  CD/DVD

Graphics
--------------------------------------------------------------------------------

Display adapter type ATI Radeon HD 4250
Total available graphics memory 887 MB
Dedicated graphics memory 256 MB
Dedicated system memory 0 MB
Shared system memory 631 MB
Display adapter driver version 8.710.0.0
Primary monitor resolution 1440x900
DirectX version DirectX 10


Hope this helps.


No.... :(  .I've installed separate one. My graphic card is nVidia GeForce 9400GT - 1GB - DDR2 - 128 bit.
Related resources
July 11, 2010 10:51:36 AM

Usually if you have a integrated GPU you would have to go into your bios to change the ammount of memory that you're sharing with it. Also try disabling it in windows device manager to prevent any problems since you're already running a dedicated one right now. I hope this works I had to do this when I had an Emachines computer and bought a 9600SE years ago... Let me know if it works.
a b } Memory
a b $ Windows 7
July 11, 2010 2:08:06 PM

dumisoft said:
No.... :(  .I've installed separate one. My graphic card is nVidia GeForce 9400GT - 1GB - DDR2 - 128 bit.

In that case, you need to turn off onboard graphics via the BIOS.
July 11, 2010 2:17:04 PM

Just ignore what its saying. I have various win 7 installs on numerous computer setups with and without onboard graphics and for some reason they all show shared memory yet its never used as shown in processor manager or any other program. Do not know why it does it, it just does.
July 13, 2010 3:25:01 AM

whats happening is you have 1gb dedicated gfx memory. Your card also has access to system memory when it runs out of dedicated memory, that is the shared memory. It doesn't actually use that memory all the time, but it is available if it needs it.
!