Sign in with
Sign up | Sign in
Your question

Fido's T610 on Roger's Network not working!!!

Last response: in Network Providers
Share
Anonymous
June 21, 2005 9:08:22 PM

Archived from groups: alt.cellular.fido (More info?)

Hi I have a Fido T610 (using city fido... yay!),


However now that my area has switched to rogers my phone doesn't work
any more. That is, it works on the fido network, but on the roger's
network I get all sorts of screeching and beeps and noise coming out of
the handset when I make or receive a call.

I notice that the T610 uses these bands: 850/1800/1900

while the equivalent phone sold by rogers... the T637... uses these
frequencies: 900/1800/1900

Is the the cause of my problems?

Fido Technicians keep saying they are talking to sony ericsson about
the problem with no resolution so far.

Anyone else with these problems? I'm in Mtl...

-Joe
Anonymous
June 22, 2005 5:23:37 AM

Archived from groups: alt.cellular.fido (More info?)

I use a T610 with no problems at all. I don't use city fido, though, I'm
in Ottawa. I got it shortly before the switch to Rogers and haven't
noticed any change.

Rob


"Joedornan" <joedornan@hotmail.com> wrote in news:1119398902.023331.127040
@g49g2000cwa.googlegroups.com:

> Hi I have a Fido T610 (using city fido... yay!),
>
>
> However now that my area has switched to rogers my phone doesn't work
> any more. That is, it works on the fido network, but on the roger's
> network I get all sorts of screeching and beeps and noise coming out of
> the handset when I make or receive a call.
>
> I notice that the T610 uses these bands: 850/1800/1900
>
> while the equivalent phone sold by rogers... the T637... uses these
> frequencies: 900/1800/1900
>
> Is the the cause of my problems?
>
> Fido Technicians keep saying they are talking to sony ericsson about
> the problem with no resolution so far.
>
> Anyone else with these problems? I'm in Mtl...
>
> -Joe
>
>
!