Sign in with
Sign up | Sign in
Your question

System Restore Problem

Last response: in Windows XP
Share
July 11, 2005 2:39:55 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

My PC has two hard drives, C: the system drive and D: which contains all my
documents.
I tried to do a System Restore and got the following message:

"Changes made to drive(s) C:\ after this point cannot be reversed because
the drive was either excluded from System Restore monitoring, or was turned
off or removed." I've tried several restore points and always get the same
message.

I have followed the instructions for enabling the drive i.e. Control Panel-
System -System Restore but drive C: is not even shown. Under status it just
says "(D:)  Monitoring".

I recently replaced the C: drive with a larger one. I did not rebuild the
system but used Drive Copy to create an image. I wonder if this might be
behind the problem.

Any advice will be gratefully received.

Nick.

More about : system restore problem

Anonymous
July 11, 2005 6:15:20 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi Nick,

After changing the drive is seems System Restore still thinks the old
drive D: drive is C:
Disable System Restore from monitoring all drives. Reboot the system
and enable SR on C:
All restore points will be lost, but that doesn't matter much sense
they don't work anyway.
If the D: drive contains data files there is no need to have SR
monitor it.
How to Disable and Enable System Restore
http://bertk.mvps.org/html/disablesr.html

Here are some additional tip on keeping System Restore Healthy.
http://bertk.mvps.org/html/healthy.html

--
Regards,
Bert Kinney MS-MVP Shell/User
http://dts-l.org/

Nick wrote:
> My PC has two hard drives, C: the system drive and D:
> which contains all my documents.
> I tried to do a System Restore and got the following
> message:
>
> "Changes made to drive(s) C:\ after this point cannot be
> reversed because the drive was either excluded from
> System Restore monitoring, or was turned off or removed."
> I've tried several restore points and always get the same
> message.
>
> I have followed the instructions for enabling the drive
> i.e. Control Panel- System -System Restore but drive C:
> is not even shown. Under status it just says "(D:) 
> Monitoring".
>
> I recently replaced the C: drive with a larger one. I did
> not rebuild the system but used Drive Copy to create an
> image. I wonder if this might be behind the problem.
>
> Any advice will be gratefully received.
>
> Nick.
July 12, 2005 12:43:07 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi Bert,
Thanks for your reply.
I'm not able to disable SR. I check the box, click Apply and get the warning
that I'll lose my restore points. I click OK but nothing happens.
I have also tried this in Safe Mode.
I've posted a screenshot of the display at
http://www.charybdis.dsl.pipex.com/panel.html
Only one drive is recognized.
It looks to me as if there is some inconsistency in the registry.
Nick.

"Bert Kinney" <bert@NSmvps.org> wrote in message
news:o dWN8VkhFHA.1412@TK2MSFTNGP09.phx.gbl...
> Hi Nick,
>
> After changing the drive is seems System Restore still thinks the old
> drive D: drive is C:
> Disable System Restore from monitoring all drives. Reboot the system
> and enable SR on C:
> All restore points will be lost, but that doesn't matter much sense
> they don't work anyway.
> If the D: drive contains data files there is no need to have SR
> monitor it.
> How to Disable and Enable System Restore
> http://bertk.mvps.org/html/disablesr.html
>
> Here are some additional tip on keeping System Restore Healthy.
> http://bertk.mvps.org/html/healthy.html
>
> --
> Regards,
> Bert Kinney MS-MVP Shell/User
> http://dts-l.org/
>
> Nick wrote:
> > My PC has two hard drives, C: the system drive and D:
> > which contains all my documents.
> > I tried to do a System Restore and got the following
> > message:
> >
> > "Changes made to drive(s) C:\ after this point cannot be
> > reversed because the drive was either excluded from
> > System Restore monitoring, or was turned off or removed."
> > I've tried several restore points and always get the same
> > message.
> >
> > I have followed the instructions for enabling the drive
> > i.e. Control Panel- System -System Restore but drive C:
> > is not even shown. Under status it just says "(D:) 
> > Monitoring".
> >
> > I recently replaced the C: drive with a larger one. I did
> > not rebuild the system but used Drive Copy to create an
> > image. I wonder if this might be behind the problem.
> >
> > Any advice will be gratefully received.
> >
> > Nick.
>
>
Related resources
Anonymous
July 12, 2005 12:43:08 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi Nick,

Reinstalling System Restore should the drive letter problem.

Note: The following file is located in a hidden folder. To view hidden
files follow these steps:
Open Control Panel - Folder Options - View tab, select "Show hidden
files and folders" and uncheck "Hide extensions for known file types",
click OK.

Open Windows Explorer and navigate to the windows\inf folder.

Find the sr.inf file, right click on it and select Install.

If the Files Needed dialog box appears, click Browse and point to the
i386 folder on the Windows XP CD or to the i386 folder on the hard
drive, if it exists.

--
Regards,
Bert Kinney MS-MVP Shell/User
http://dts-l.org/

Nick wrote:
> Hi Bert,
> Thanks for your reply.
> I'm not able to disable SR. I check the box, click Apply
> and get the warning that I'll lose my restore points. I
> click OK but nothing happens.
> I have also tried this in Safe Mode.
> I've posted a screenshot of the display at
> http://www.charybdis.dsl.pipex.com/panel.html
> Only one drive is recognized.
> It looks to me as if there is some inconsistency in the registry.
> Nick.
>
> "Bert Kinney" wrote
>> Hi Nick,
>>
>> After changing the drive is seems System Restore still
>> thinks the old drive D: drive is C:
>> Disable System Restore from monitoring all drives.
>> Reboot the system and enable SR on C:
>> All restore points will be lost, but that doesn't matter
>> much sense they don't work anyway.
>> If the D: drive contains data files there is no need to
>> have SR monitor it.
>> How to Disable and Enable System Restore
>> http://bertk.mvps.org/html/disablesr.html
>>
>> Here are some additional tip on keeping System Restore
>> Healthy. http://bertk.mvps.org/html/healthy.html
>>
>> --
>> Regards,
>> Bert Kinney MS-MVP Shell/User
>> http://dts-l.org/
>>
>> Nick wrote:
>>> My PC has two hard drives, C: the system drive and D:
>>> which contains all my documents.
>>> I tried to do a System Restore and got the following message:
>>>
>>> "Changes made to drive(s) C:\ after this point cannot be
>>> reversed because the drive was either excluded from
>>> System Restore monitoring, or was turned off or
>>> removed." I've tried several restore points and always
>>> get the same message.
>>>
>>> I have followed the instructions for enabling the drive
>>> i.e. Control Panel- System -System Restore but drive C:
>>> is not even shown. Under status it just says "(D:)  Monitoring".
>>>
>>> I recently replaced the C: drive with a larger one. I
>>> did not rebuild the system but used Drive Copy to
>>> create an image. I wonder if this might be behind the problem.
>>>
>>> Any advice will be gratefully received.
>>>
>>> Nick.
July 12, 2005 1:15:25 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi Bert,
I followed your instructions and all is now ok.
Thanks again.
Nick.

"Bert Kinney" <bert@NSmvps.org> wrote in message
news:eUXAq6lhFHA.2852@TK2MSFTNGP15.phx.gbl...
> Hi Nick,
>
> Reinstalling System Restore should the drive letter problem.
>
> Note: The following file is located in a hidden folder. To view hidden
> files follow these steps:
> Open Control Panel - Folder Options - View tab, select "Show hidden
> files and folders" and uncheck "Hide extensions for known file types",
> click OK.
>
> Open Windows Explorer and navigate to the windows\inf folder.
>
> Find the sr.inf file, right click on it and select Install.
>
> If the Files Needed dialog box appears, click Browse and point to the
> i386 folder on the Windows XP CD or to the i386 folder on the hard
> drive, if it exists.
>
> --
> Regards,
> Bert Kinney MS-MVP Shell/User
> http://dts-l.org/
>
> Nick wrote:
> > Hi Bert,
> > Thanks for your reply.
> > I'm not able to disable SR. I check the box, click Apply
> > and get the warning that I'll lose my restore points. I
> > click OK but nothing happens.
> > I have also tried this in Safe Mode.
> > I've posted a screenshot of the display at
> > http://www.charybdis.dsl.pipex.com/panel.html
> > Only one drive is recognized.
> > It looks to me as if there is some inconsistency in the registry.
> > Nick.
> >
> > "Bert Kinney" wrote
> >> Hi Nick,
> >>
> >> After changing the drive is seems System Restore still
> >> thinks the old drive D: drive is C:
> >> Disable System Restore from monitoring all drives.
> >> Reboot the system and enable SR on C:
> >> All restore points will be lost, but that doesn't matter
> >> much sense they don't work anyway.
> >> If the D: drive contains data files there is no need to
> >> have SR monitor it.
> >> How to Disable and Enable System Restore
> >> http://bertk.mvps.org/html/disablesr.html
> >>
> >> Here are some additional tip on keeping System Restore
> >> Healthy. http://bertk.mvps.org/html/healthy.html
> >>
> >> --
> >> Regards,
> >> Bert Kinney MS-MVP Shell/User
> >> http://dts-l.org/
> >>
> >> Nick wrote:
> >>> My PC has two hard drives, C: the system drive and D:
> >>> which contains all my documents.
> >>> I tried to do a System Restore and got the following message:
> >>>
> >>> "Changes made to drive(s) C:\ after this point cannot be
> >>> reversed because the drive was either excluded from
> >>> System Restore monitoring, or was turned off or
> >>> removed." I've tried several restore points and always
> >>> get the same message.
> >>>
> >>> I have followed the instructions for enabling the drive
> >>> i.e. Control Panel- System -System Restore but drive C:
> >>> is not even shown. Under status it just says "(D:)  Monitoring".
> >>>
> >>> I recently replaced the C: drive with a larger one. I
> >>> did not rebuild the system but used Drive Copy to
> >>> create an image. I wonder if this might be behind the problem.
> >>>
> >>> Any advice will be gratefully received.
> >>>
> >>> Nick.
>
>
Anonymous
July 15, 2005 2:45:57 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

You're welcome Nick.

Just curious, when C: was replaced with a new drive moved to D: did
you format the old drive or just delete the windows files from it.

--
Regards,
Bert Kinney MS-MVP Shell/User
http://dts-l.org/


Nick wrote:
> Hi Bert,
> I followed your instructions and all is now ok.
> Thanks again.
> Nick.
>
> "Bert Kinney" <bert@NSmvps.org> wrote in message
> news:eUXAq6lhFHA.2852@TK2MSFTNGP15.phx.gbl...
>> Hi Nick,
>>
>> Reinstalling System Restore should the drive letter
>> problem.
>>
>> Note: The following file is located in a hidden folder.
>> To view hidden files follow these steps:
>> Open Control Panel - Folder Options - View tab, select
>> "Show hidden files and folders" and uncheck "Hide
>> extensions for known file types", click OK.
>>
>> Open Windows Explorer and navigate to the windows\inf
>> folder.
>>
>> Find the sr.inf file, right click on it and select
>> Install.
>>
>> If the Files Needed dialog box appears, click Browse and
>> point to the i386 folder on the Windows XP CD or to the
>> i386 folder on the hard drive, if it exists.
>>
>> --
>> Regards,
>> Bert Kinney MS-MVP Shell/User
>> http://dts-l.org/
>>
>> Nick wrote:
>>> Hi Bert,
>>> Thanks for your reply.
>>> I'm not able to disable SR. I check the box, click Apply
>>> and get the warning that I'll lose my restore points. I
>>> click OK but nothing happens.
>>> I have also tried this in Safe Mode.
>>> I've posted a screenshot of the display at
>>> http://www.charybdis.dsl.pipex.com/panel.html
>>> Only one drive is recognized.
>>> It looks to me as if there is some inconsistency in the
>>> registry. Nick.
>>>
>>> "Bert Kinney" wrote
>>>> Hi Nick,
>>>>
>>>> After changing the drive is seems System Restore still
>>>> thinks the old drive D: drive is C:
>>>> Disable System Restore from monitoring all drives.
>>>> Reboot the system and enable SR on C:
>>>> All restore points will be lost, but that doesn't
>>>> matter much sense they don't work anyway.
>>>> If the D: drive contains data files there is no need to
>>>> have SR monitor it.
>>>> How to Disable and Enable System Restore
>>>> http://bertk.mvps.org/html/disablesr.html
>>>>
>>>> Here are some additional tip on keeping System Restore
>>>> Healthy. http://bertk.mvps.org/html/healthy.html
>>>>
>>>> --
>>>> Regards,
>>>> Bert Kinney MS-MVP Shell/User
>>>> http://dts-l.org/
>>>>
>>>> Nick wrote:
>>>>> My PC has two hard drives, C: the system drive and D:
>>>>> which contains all my documents.
>>>>> I tried to do a System Restore and got the following
>>>>> message:
>>>>>
>>>>> "Changes made to drive(s) C:\ after this point cannot
>>>>> be reversed because the drive was either excluded from
>>>>> System Restore monitoring, or was turned off or
>>>>> removed." I've tried several restore points and always
>>>>> get the same message.
>>>>>
>>>>> I have followed the instructions for enabling the
>>>>> drive
>>>>> i.e. Control Panel- System -System Restore but drive
>>>>> C:
>>>>> is not even shown. Under status it just says "(D:) 
>>>>> Monitoring".
>>>>>
>>>>> I recently replaced the C: drive with a larger one. I
>>>>> did not rebuild the system but used Drive Copy to
>>>>> create an image. I wonder if this might be behind the
>>>>> problem.
>>>>>
>>>>> Any advice will be gratefully received.
>>>>>
>>>>> Nick.
Anonymous
July 15, 2005 6:38:23 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hey Nick and Bert, I had a similar situation when I had to replace my old
WINXP-SP2 drive. I to bought a bigger drive and when I set up the new drive,
it appeared to copy the entire system without a problem. When I switched
drives and attempted to start the System Restore I would consistently get
abends from either the 'Help System Restore' or when I tried to access it
from the System ASR tab.

Bert I followed your suggestion in this email by clicking on the sr.ini
file. I am curious about this because when I pointed to my XP install cd it
installed older files than what is currently on my system. Should this be of
concern to me? If so, is there a simple solution to restoring the updated
files and dll's that were replaced?
"Bert Kinney" <bert@NSmvps.org> wrote in message
news:uEHRSdOiFHA.1428@TK2MSFTNGP10.phx.gbl...
> You're welcome Nick.
>
> Just curious, when C: was replaced with a new drive moved to D: did you
> format the old drive or just delete the windows files from it.
>
> --
> Regards,
> Bert Kinney MS-MVP Shell/User
> http://dts-l.org/
>
>
> Nick wrote:
>> Hi Bert,
>> I followed your instructions and all is now ok.
>> Thanks again.
>> Nick.
>>
>> "Bert Kinney" <bert@NSmvps.org> wrote in message
>> news:eUXAq6lhFHA.2852@TK2MSFTNGP15.phx.gbl...
>>> Hi Nick,
>>>
>>> Reinstalling System Restore should the drive letter
>>> problem.
>>>
>>> Note: The following file is located in a hidden folder.
>>> To view hidden files follow these steps:
>>> Open Control Panel - Folder Options - View tab, select
>>> "Show hidden files and folders" and uncheck "Hide
>>> extensions for known file types", click OK.
>>>
>>> Open Windows Explorer and navigate to the windows\inf
>>> folder.
>>>
>>> Find the sr.inf file, right click on it and select
>>> Install.
>>>
>>> If the Files Needed dialog box appears, click Browse and
>>> point to the i386 folder on the Windows XP CD or to the
>>> i386 folder on the hard drive, if it exists.
>>>
>>> --
>>> Regards,
>>> Bert Kinney MS-MVP Shell/User
>>> http://dts-l.org/
>>>
>>> Nick wrote:
>>>> Hi Bert,
>>>> Thanks for your reply.
>>>> I'm not able to disable SR. I check the box, click Apply
>>>> and get the warning that I'll lose my restore points. I
>>>> click OK but nothing happens.
>>>> I have also tried this in Safe Mode.
>>>> I've posted a screenshot of the display at
>>>> http://www.charybdis.dsl.pipex.com/panel.html
>>>> Only one drive is recognized.
>>>> It looks to me as if there is some inconsistency in the
>>>> registry. Nick.
>>>>
>>>> "Bert Kinney" wrote
>>>>> Hi Nick,
>>>>>
>>>>> After changing the drive is seems System Restore still
>>>>> thinks the old drive D: drive is C:
>>>>> Disable System Restore from monitoring all drives.
>>>>> Reboot the system and enable SR on C:
>>>>> All restore points will be lost, but that doesn't
>>>>> matter much sense they don't work anyway.
>>>>> If the D: drive contains data files there is no need to
>>>>> have SR monitor it.
>>>>> How to Disable and Enable System Restore
>>>>> http://bertk.mvps.org/html/disablesr.html
>>>>>
>>>>> Here are some additional tip on keeping System Restore
>>>>> Healthy. http://bertk.mvps.org/html/healthy.html
>>>>>
>>>>> --
>>>>> Regards,
>>>>> Bert Kinney MS-MVP Shell/User
>>>>> http://dts-l.org/
>>>>>
>>>>> Nick wrote:
>>>>>> My PC has two hard drives, C: the system drive and D:
>>>>>> which contains all my documents.
>>>>>> I tried to do a System Restore and got the following
>>>>>> message:
>>>>>>
>>>>>> "Changes made to drive(s) C:\ after this point cannot
>>>>>> be reversed because the drive was either excluded from
>>>>>> System Restore monitoring, or was turned off or
>>>>>> removed." I've tried several restore points and always
>>>>>> get the same message.
>>>>>>
>>>>>> I have followed the instructions for enabling the
>>>>>> drive
>>>>>> i.e. Control Panel- System -System Restore but drive
>>>>>> C:
>>>>>> is not even shown. Under status it just says "(D:) 
>>>>>> Monitoring".
>>>>>>
>>>>>> I recently replaced the C: drive with a larger one. I
>>>>>> did not rebuild the system but used Drive Copy to
>>>>>> create an image. I wonder if this might be behind the
>>>>>> problem.
>>>>>>
>>>>>> Any advice will be gratefully received.
>>>>>>
>>>>>> Nick.
>
>
Anonymous
July 17, 2005 6:35:26 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi,

Did you use a pre SP2 CD for the reinstall?

--
Regards,
Bert Kinney MS-MVP Shell/User
http://dts-l.org/


tjdarth wrote:
> Hey Nick and Bert, I had a similar situation when I had
> to replace my old WINXP-SP2 drive. I to bought a bigger
> drive and when I set up the new drive, it appeared to
> copy the entire system without a problem. When I switched
> drives and attempted to start the System Restore I would
> consistently get abends from either the 'Help System
> Restore' or when I tried to access it from the System ASR
> tab.
> Bert I followed your suggestion in this email by clicking
> on the sr.ini file. I am curious about this because when
> I pointed to my XP install cd it installed older files
> than what is currently on my system. Should this be of
> concern to me? If so, is there a simple solution to
> restoring the updated files and dll's that were replaced?


>>>
>>> "Bert Kinney" wrote
>>>> Hi Nick,
>>>>
>>>> Reinstalling System Restore should the drive letter problem.
>>>>
>>>> Note: The following file is located in a hidden folder.
>>>> To view hidden files follow these steps:
>>>> Open Control Panel - Folder Options - View tab, select
>>>> "Show hidden files and folders" and uncheck "Hide
>>>> extensions for known file types", click OK.
>>>>
>>>> Open Windows Explorer and navigate to the windows\inf folder.
>>>>
>>>> Find the sr.inf file, right click on it and select Install.
>>>>
>>>> If the Files Needed dialog box appears, click Browse
>>>> and point to the i386 folder on the Windows XP CD or
>>>> to the i386 folder on the hard drive, if it exists.
!