Sign-in / Sign-up
Your question
Closed

BSOD on boot, ClassPNP.sys

Tags:
  • Drivers
  • Blue Screen
  • Windows 7
Last response: in Windows 7
July 12, 2010 7:52:26 AM

Hey everyone!
Got a bit of a problem,
Rebooted the other day and have been getting a BSOD with code:
0x0000007B (0xFFFFF990009A9928, 0xFFFFFFFFC0000034, 0x0000000000000000, 0x0000000000000000)

Nothing's been changed in the system. The last update was my Catalyst drivers being updated but they've been working fine since.
I've got Ubuntu running on the same disk (the Intel SSD) so I have access to the windows partition.
I've tried basically everything in the windows recovery menu, Tried all the restore/recovery stuff. The repair failed and mentioned "Bad Driver" as the cause. None of the restore or backup files work. It seems to rollback fine but still won't get past the flying dots screen without BSoD.

It can't get into Safe Mode but when it tries, it always crashes when loading ClassPNP.sys
I have a virtualized version of the OS running in Virtualbox in Ubuntu, so I tried booting that, copying ClassPNP, moving it over to Ubuntu through the Virtualbox shared folders and then substituting it for the actual driver installed on my disk version (whole System32 folder is backed up btw)

Still no dice. Even went so far as to copy over the whole drivers folder and it still did nothing.

Then thinking it's a BIOS problem, flashed the newest version of that. Still nothing. I've also fiddled with the BIOS settings and reset them to default and it's had no effect.

Also when enabling bootlogging, I can't seem to find the ntbtlog.txt file. It's supposed to be in \Windows correct?

Just for full disclosure regarding hardware, my rear output fan died a while ago because it needs oil. Unfortunately I've yet to go pick up some so it's still not running. Got the sides off the case though with a fan blowing on it/me and everything is still running at low temps. It's also booted fine several times since so I don't think that would be the problem.

Just took out the Killer NIC and reseated the ram. No onboard video so I can't take out the grafx. Also reseated the Sata cable for the SSD but that did nothing. I've tried to do everything possible to eliminate hardware as a possible cause, plus Ubuntu runs fine, passed mem checks, etc.

So does anyone know what I can do to fix this short of reinstalling? Like I said I've got a virtual hard drive with Win7 installed in Virtualbox to pull files from so I can copy anything over. There doesn't seem to be any other solutions online apart from the copy over driver fix which I've already tried.

Thanks for anyone's help :hello: 

Specs as follows:
Core i7 920
Asus P6T6 WS Revolution Mobo
6 GiB Mushkin 1600 ram
Intel 80 GB SSD (Win 7 & Ubuntu System drive)
WD 2TB HDD (Data Drive)
Pioneer BD-RW Blueray Drive
Sapphire Vapor-X HD 4870 2GB GDDR5 PCI-E
Corsair 1000w psu
CoolerMaster V8 Cpu cooler
Killer Xeno Pro NIC
Windows 7 Ultimate 64

More about : bsod boot classpnp sys

July 12, 2010 8:24:18 AM

Sorry guys, for some reason I thought my specs were in my signature. :sarcastic: 
Post edited to include them now.
Score
0
July 12, 2010 4:45:32 PM

No Windows 7 ninjas who know what else I can do?
I'd prefer not to have to reinstall if it's not necessary, but I guess I'll start backing up my system drive.
Score
0
Related resources
December 20, 2010 5:34:01 PM

I have exactly the same problem. I have a fresh install of windows 7 on my SATA flash drive.
The only thing really changed is the new ati 10.12 drivers and i changed the drive from IDE mode to AHCI.
I have a GA-P55A-U4 mainboard with an aditional marvell SATA controller. At first i hat the drive connected to that controller.
It didnt work. Finally it startet do work as i connected it to the standard P55 controller working in RAID mode.
That was yesterday. Right now my main PC stopped working again.

I will try to replace the classpnp.sys file somehow.

Did you find any solution?
Score
0

Best solution

October 1, 2011 8:25:17 PM

Had very similar problem this morning. Tried everything, Bios reset, memory test, switched to my second drive with windows on it, same problem. Always stops on classpnp.sys. Then I unpluged the rgb cable to the monitor - it is PNP, right? That was it!!!
Share
a b \ Driver
a b $ Windows 7
October 2, 2011 8:26:30 PM

This topic has been closed by Mousemonkey
Score
0
October 9, 2011 12:10:29 AM

Best answer selected by kyranc.
Score
0