Sign-in / Sign-up
Your question

Restore default security permissions for the hard disk partitions

Tags:
  • Security
  • Hard Drives
  • Permissions
  • Windows 7
Last response: in Windows 7
Anonymous
a b $ Windows 7
a b 8 Security
July 12, 2010 12:54:43 PM

Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64

More about : restore default security permissions hard disk partitions

a b $ Windows 7
July 12, 2010 5:28:55 PM

Hello intruderprime, It sounds like you need to readjust your User Account Control Settings. To do so log-in to the administrator account on your PC and follow these steps:

1. Click Start, and then click Control Panel.
2. In Control Panel, click User Accounts.
3. In the User Accounts window, click User Accounts.
4. In the User Accounts tasks window, click Turn User Account Control on or off.
5. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Yes.
6. In the Security section of the Windows Solution Center page, click Adjust UAC Settings.
7. On the User Account Control Settings page:
- To disable UAC, move the slider to Never notify, and then click OK.
- To enable UAC or change levels of notification, move the slider to the appropriate notification option, and then click OK.
If you decide to disable UAC, you will need to restart your computer in order to save the new settings.

Another option is to do a system restore to a time before you changed permissions in the first place.

Let us know what happens!
Cheers,
Cassandra
Microsoft Windows Outreach


m
0
l
a c 706 $ Windows 7
a b 8 Security
July 13, 2010 3:06:03 PM

Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64


Did you remove yourself from the rights of the drive as well? I have seen that happen, and it's not pretty. System Restore may work, but you may run into an issue where the program can't write anything to the drive because you removed all permissions even for System. Good idea not to mess with things unless you know the how, and sometimes as important, the why.

When you go to the Security tab of the area you changed, what is in there?
m
0
l
Related resources
November 11, 2011 11:16:04 PM

hang-the-9 said:
Did you remove yourself from the rights of the drive as well? I have seen that happen, and it's not pretty. System Restore may work, but you may run into an issue where the program can't write anything to the drive because you removed all permissions even for System. Good idea not to mess with things unless you know the how, and sometimes as important, the why.

When you go to the Security tab of the area you changed, what is in there?

OMG ! That's exactly what i just did. I was trying to make it so the other account didn't have access to download anything. Now, it's preventing admin as well. I can't go back and change anything nor can I do system restore. HELP !?
m
0
l
a c 610 $ Windows 7
a b 8 Security
November 11, 2011 11:17:34 PM

Start a new thread and you will receive replies
m
0
l
November 12, 2011 12:21:58 AM

SR-71 Blackbird said:
Start a new thread and you will receive replies


Sorry, I don't know how to.
m
0
l
February 18, 2012 12:08:15 PM

hang-the-9 said:
Did you remove yourself from the rights of the drive as well? I have seen that happen, and it's not pretty. System Restore may work, but you may run into an issue where the program can't write anything to the drive because you removed all permissions even for System. Good idea not to mess with things unless you know the how, and sometimes as important, the why.

When you go to the Security tab of the area you changed, what is in there?


Hello,

Right click on the drive that is giving the issue, select properties, security, add, advanced,select find now ( leave the seach field blank.), Choose the names you are missing. You should have
creator owner,
sytem.
administrator
users
m
0
l
December 10, 2012 1:41:28 PM

Having this same problem in Win7. Turning off UAC fixed it. Don't know why, but THANK YOU CASSANDRA!!!

cassandraf_winteam said:
Hello intruderprime, It sounds like you need to readjust your User Account Control Settings. To do so log-in to the administrator account on your PC and follow these steps:

1. Click Start, and then click Control Panel.
2. In Control Panel, click User Accounts.
3. In the User Accounts window, click User Accounts.
4. In the User Accounts tasks window, click Turn User Account Control on or off.
5. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Yes.
6. In the Security section of the Windows Solution Center page, click Adjust UAC Settings.
7. On the User Account Control Settings page:
- To disable UAC, move the slider to Never notify, and then click OK.
- To enable UAC or change levels of notification, move the slider to the appropriate notification option, and then click OK.
If you decide to disable UAC, you will need to restart your computer in order to save the new settings.

Another option is to do a system restore to a time before you changed permissions in the first place.

Let us know what happens!
Cheers,
Cassandra
Microsoft Windows Outreach
m
0
l
February 5, 2013 10:14:01 AM

Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64





Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.
m
0
l
April 16, 2013 8:34:34 AM

the steps worked !!
good work @mvallalraj

Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.
m
0
l
April 23, 2013 7:39:06 PM

mvallalraj said:
Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64


Please where do I find this "partition" tab on my laptop as I have locked myself absolutely out of making any changes.




Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.


m
0
l
July 19, 2013 12:47:32 AM

TheExecutweet said:
mvallalraj said:
Quote:

Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.
Quote:


Quote:


Thanks a lot!! you saved my life. :*:love: 
m
0
l
August 24, 2013 9:29:41 PM

i am having a same problem and mine is
after i follow your steps i coudn't go through edit "

Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit

it says access denied at when i click on edit

-> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."
m
1
l
October 2, 2013 1:42:05 AM

Use Permissions Time Machine v1.0 to restore default permissions to folder or files or registry keys it's free and fast and easy
http://goo.gl/730w8z
m
0
l
December 1, 2013 12:03:02 PM

I use Permissions Time Machine v1.2 to restore permissions to folder or files or registry keys
i download it from amyd projects blog
m
0
l
January 23, 2014 6:38:44 AM

mvallalraj said:
Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64





Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.


Thank you very much-it worked just like you said! They should ask you if you're sure you want to make these changes beforehand, especially when you are taking away your own( or everyone's) permissions!:bounce: 
m
0
l
July 15, 2014 3:00:27 PM

hang-the-9 said:
Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64


Did you remove yourself from the rights of the drive as well? I have seen that happen, and it's not pretty. System Restore may work, but you may run into an issue where the program can't write anything to the drive because you removed all permissions even for System. Good idea not to mess with things unless you know the how, and sometimes as important, the why.

When you go to the Security tab of the area you changed, what is in there?


I did what this guy did and what you explained but with my local disk. I havent had any luck looking for the solution. I basically am not admin anymore. I cannot install anything , run task manager and access my local disk. Please help me
m
0
l
July 29, 2014 3:20:46 AM

mallavraj u have raised many fallen dicks:bounce: 
m
0
l
August 11, 2014 10:55:58 PM

I did the same thing, first you unlock the hidden adminstrator account logon , steps are here http://www.howtogeek.com/howto/windows-vista/enable-the...

that link is for windows 7, 8 , and vista , then go in and change your ownership or permissions like @mvallalraj said
worked for me , best of luck buddy

m
0
l
August 12, 2014 12:52:03 AM

And that’s it!

After that, the files permissions were reset and I could access them back again.
m
0
l
September 17, 2014 12:05:16 AM

mvallalraj said:
Quote:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64





Right Click on Partition -> Properties -> Security -> advanced -> Owner tab -> edit -> Other Users or Groups -> advanced -> find now -> click on "Users" or "Administrator" -> ok -> click on "replace owner on subcontainers and objects" -> apply.

It will show the message

"If you have just taken ownership of this object, you will need to close and reopen this object's properties before you can view or change permissions."

hit "ok" and close all. now you can access the files and folders.



Hey.. I am facing almost same situation with my WD Passport 1TB drive. My system got crashed recently & i got to replaced my motherboard etc. Now when i connect the drive it prompts for a password & once the drive is unlocke, it kept loading, I can see it on my drives list however i cannot access it I would really appreciate your help. I have some important data on this drive which i cant afford to loose.

I am on Windows 8 64bit system. I have other WD drives as well but only this one is giving problem since this is the only drive on which i enabled the security (password protected) Just a guess.
m
0
l
November 19, 2014 8:20:23 AM

Did the same thing. Removed a few groups because of a corrupted bin on the hdd. After that I could not regain access to it. So I went to the security settings of the hdd i couldn't get access to and to another hdd that didnt have this problem.
Then manually add the groups that were deleted. Use the working hdd as example of the security settings.
After re-adding these groups and reboot, the hdd was accessible again.
MiisszBerry said:
hang-the-9 said:
Did you remove yourself from the rights of the drive as well? I have seen that happen, and it's not pretty. System Restore may work, but you may run into an issue where the program can't write anything to the drive because you removed all permissions even for System. Good idea not to mess with things unless you know the how, and sometimes as important, the why.

When you go to the Security tab of the area you changed, what is in there?

OMG ! That's exactly what i just did. I was trying to make it so the other account didn't have access to download anything. Now, it's preventing admin as well. I can't go back and change anything nor can I do system restore. HELP !?


m
0
l
December 12, 2014 3:31:38 PM

cassandraf_winteam said:
Hello intruderprime, It sounds like you need to readjust your User Account Control Settings. To do so log-in to the administrator account on your PC and follow these steps:

1. Click Start, and then click Control Panel.
2. In Control Panel, click User Accounts.
3. In the User Accounts window, click User Accounts.
4. In the User Accounts tasks window, click Turn User Account Control on or off.
5. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Yes.
6. In the Security section of the Windows Solution Center page, click Adjust UAC Settings.
7. On the User Account Control Settings page:
- To disable UAC, move the slider to Never notify, and then click OK.
- To enable UAC or change levels of notification, move the slider to the appropriate notification option, and then click OK.
If you decide to disable UAC, you will need to restart your computer in order to save the new settings.

Another option is to do a system restore to a time before you changed permissions in the first place.

Let us know what happens!
Cheers,
Cassandra
Microsoft Windows Outreach




I can get as far as
Control Panel>User Accounts>User Accounts.
after that I do not see. "Turn User Account Control on or off."
m
0
l
December 17, 2014 9:53:18 AM

Hi if ur using english version of windows, type UAC in the search box. Then press enter, the settings menu should come right up.
HAL9003 said:
cassandraf_winteam said:
Hello intruderprime, It sounds like you need to readjust your User Account Control Settings. To do so log-in to the administrator account on your PC and follow these steps:

1. Click Start, and then click Control Panel.
2. In Control Panel, click User Accounts.
3. In the User Accounts window, click User Accounts.
4. In the User Accounts tasks window, click Turn User Account Control on or off.
5. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Yes.
6. In the Security section of the Windows Solution Center page, click Adjust UAC Settings.
7. On the User Account Control Settings page:
- To disable UAC, move the slider to Never notify, and then click OK.
- To enable UAC or change levels of notification, move the slider to the appropriate notification option, and then click OK.
If you decide to disable UAC, you will need to restart your computer in order to save the new settings.

Another option is to do a system restore to a time before you changed permissions in the first place.

Let us know what happens!
Cheers,
Cassandra
Microsoft Windows Outreach




I can get as far as
Control Panel>User Accounts>User Accounts.
after that I do not see. "Turn User Account Control on or off."


m
0
l
December 21, 2014 1:35:59 AM

Anonymous said:
Hello,
I have changed the permissions for the access of files and folders in the security tab of given in the properties of the Hard Disk Partition.Now I other users of the same computer cannot access the drive or make changes there. I tried hard to solve the problem but the output is "Access Denied". Any way to make this permissions to its default(or The normal state which it was).
My OS is Windows 7 Ultimate x64


I recently committed this crime against our trusty hard-drives. I, however, did not stop until I was able to restore previous permission/s on my hard-drive. Luckily I was able to come across this file created by someone who did the same thing of removing/changing permission/s accidentally.

Believe me when I tell you, it works. I will understand that you might be skeptic on trying it out. But you can try to scan the file after download before running it, I did.

P.S.

I'm also running Win 7 Pro x64
m
0
l
January 5, 2015 4:41:14 PM

If you lost some kind of rights yourself first unlock hidden admin account
Run cmd.exe as administrator and type in "Net user administrator /active:yes"

Log into that account.
Take ownership of the lost partition
Propreties ->advanced->owner->edit->click on administrator->check replace to subcontainers->apply

fix Permissions for user or group of users
Propreties->advanced->Change permission->add user or group->set permisions->check replace all child object permission

Done

Relog to your original account
in cmd type Net user administrator /active:no
m
0
l