Can't run a TimeDemo on Quake III w/ Asus 7700 AGP

I just installed an Asus 7700 Deluxe AGP video card (GeForce 2 GTS). I was eager to see my performance gains in frames-per-second by running a timedemo in QUAKE III. I have run tons of timedemo's with my previous Voodoo card without any problems. Whenever I pull down the console with this new card installed, and try to run the time demo (#1), it loads the wrong timedemo at first, and then it kicks me back out to the main menu of Quake III without running the demo. Kind of a pisser, eh? I can't run either demo at all. My AGP is set to 2x in the bios, not 4x as I've heard this can cause problems. I have the original drivers that came with the retail pack installed right now.

Anyone run into this problem before?

Thanks,
MB
4 answers Last reply
More about timedemo quake asus 7700
  1. Is quake 3 set to run in minigl mode for voodoo? Check for updates on those drivers too.
  2. Yeah, I think so maybe. When I look in Quake III and I check out the "open GL" mode, my only choice there is "voodoo". I had a Voodoo 3 3000 prior to my installing this Asus GeForce II GTS card. I tried uninstalling quake and reinstalling, but this didn't help any. Where can I get updates to run in gl mode? Is that what I need. Right now, when I try to run timedemo #1, it loads up timedemo #2 (that fuzzy load screen when you launch a new game in quake iii), and then never goes into the timedemo. It just kicks me out to the main menu without running the demo. I never had this problem with my voodoo card.

    MB
  3. If your running 1.27g patch on Quake3 you cant run time demos. Its something that got screwed up with the patch. I tried running some after I patched and they would load then crash out to the front screen. So much for patching, fix one thing screw up another.
  4. Ahhhhh. Now I see. And here I thought that I had screwed something up. Any word on a patch......uh...for their patch?

    Thanks,
    MB
Ask a new question

Read More

Graphics Cards Asus Graphics