Installation DVD won't register

So I just built a pc
ASRock 890FX Deluxe3 mobo, phenom II x4 965 BE, sony optiarc dvd drive,
WD 1TB caviar black 7200rpm sata III, OCZ Vertex 30GB ssd, 8GB OCZ RAM, Antec 750W PSU, Powercolor Radeon HD 5770 1GB gpu

I've been trying to install Windows 7 but it won't even register the DVD (but it knows the drive itself is there) and keeps telling me to insert the boot drive or whatever.

I downloaded the .iso from the microsoft store and burned it to the dvd. could there be something wrong with the way I burned it?

Or could there be something wrong with the DVD drive?

I tried installing SimplyMepis this morning and that DVD worked...sort of...except it wouldn't let me install mepis, though i think that might've been a configuration problem. :/

Oh and this is my first ever build.
6 answers Last reply
More about installation register
  1. Did you seet the boot order in BIOS to DVD as first drive?

    Once the OS is installed, you can change it back to first Hard drive.
  2. ^Yeah I did. And then I just tried booting from a usb drive (which I also configured as first drive for that attempt) and then the next screen was just a blank black screen.

    gahh i have no idea what's going on
  3. BIOS sees the optical drive? IDE or SATA?

    Can you check the drive in another computer? Or buy another DVD drive (less than $25.00, which I hate to ask)?
  4. BIOS definitely does see the optical drive, it's SATA
  5. Ensure bios set to IDE nor AHCI for sata port optical drive is plugged into.
  6. Actually...I fixed it...

    Heh...it's rather embarrassing... I mixed up DVD burning software and ended up just copying the .iso onto the dvd instead of burning the image onto it...lol

    Problem solved! Haha
Ask a new question

Read More

DVD Windows 7