Sign in with
Sign up | Sign in
Your question

Reverse turbo boost

Last response: in Laptops & Notebooks
Share
December 24, 2012 4:56:30 AM

Hey. For some reason, on my lenovo y580, the 3610qm clocks at 3.3ghz when idle (browsing and such), but decreases to 2.3ghz when ingame. its like a reverse turbo boost or something. how could I fix this?

More about : reverse turbo boost

a c 439 D Laptop
December 24, 2012 6:08:40 AM

What's your CPU temps? The CPU could be throttling down due to high temps.
December 24, 2012 12:53:22 PM

jaguarskx said:
What's your CPU temps? The CPU could be throttling down due to high temps.

I just checked this. on idle my cpu temps are ~50c. ingame the speeds downclock once they reach 60c or so, so its not this issue thats causing it I think.
Related resources
a b D Laptop
December 24, 2012 1:32:01 PM

This makes perfect sense.

You have a 2.3GHz cpu, now TURBO brings it up to 3.3, but only when you load a single core up(and then it can idle out the other cores).

If your game used 2 more, it can not go all the way. Chances are you get times with some mid speeds, but turbo is made to allow single threaded(even 2 and 3 threaded) programs to run faster. It is somewhat hard to run 3-4 fully loaded threads within a 45 watt power envelope.

This can vary as said with temperatures,load(power consumption) and even the way the laptop makers sets up the system.

You would try to maximum performance power option to see if it lets it go higher.
December 24, 2012 1:41:21 PM

nukemaster said:
This makes perfect sense.

You have a 2.3GHz cpu, now TURBO brings it up to 3.3, but only when you load a single core up(and then it can idle out the other cores).

If your game used 2 more, it can not go all the way. Chances are you get times with some mid speeds, but turbo is made to allow single threaded(even 2 and 3 threaded) programs to run faster. It is somewhat hard to run 3-4 fully loaded threads within a 45 watt power envelope.

This can vary as said with temperatures,load(power consumption) and even the way the laptop makers sets up the system.

You would try to maximum performance power option to see if it lets it go higher.

on my other laptop which used and amd chip, its possible to make it so that the cpu operates at the turbo speed all the time. would it be possible to manually overclock the cpu on this one also? ive no experience with mobile i7 chips :x
thanks!

p.s. the reason im trying to fix this is because on BF3, if I enable the graph that shows gpu and cpu usage, I can see frequent millisecond spikes on the cpu usage which causes a stutter which is really annoying
a b D Laptop
December 24, 2012 1:55:59 PM

I think your AMD had cool,n,quiet

Those chips had the MAX speed set for the top end(and lower speeds to save power). Intel's Turbo actually allows the chips to overclock past the max as long as certain requirements are met(within power/temp limits and not all cores loaded.)

Under power options try to set high performance then the cpu will clock up at the drop of a hat.

Some users say that HT(Hyper threading causes problems since they are not real cpus, so you may be able to disable it in the bios to see if it helps or not.)

Last thing is if you have an Nvidia card, you may be able to set an option(Power Management mode -> Adaptive to Prefer max performance) in the Nvidia control panel to prevent the card from changing its frequency as well. This should be set as a profile for the game and not a default as you do not want the video card clocked up all day long in a laptop.
December 24, 2012 2:06:47 PM

nukemaster said:
I think your AMD had cool,n,quiet

Those chips had the MAX speed set for the top end(and lower speeds to save power). Intel's Turbo actually allows the chips to overclock past the max as long as certain requirements are met(within power/temp limits and not all cores loaded.)

Under power options try to set high performance then the cpu will clock up at the drop of a hat.

Some users say that HT(Hyper threading causes problems since they are not real cpus, so you may be able to disable it in the bios to see if it helps or not.)

Last thing is if you have an Nvidia card, you may be able to set an option(Power Management mode -> Adaptive to Prefer max performance) in the Nvidia control panel to prevent the card from changing its frequency as well. This should be set as a profile for the game and not a default as you do not want the video card clocked up all day long in a laptop.

the messed up part is that on this laptop, in the bios there are literally no cpu related options. I set the max performance mode in every place I found, but the speed still clocks down at about 1min into the game :( 
December 24, 2012 3:16:25 PM

There is nothing wrong with your system.

Your CPU Clock Speed 2.3 GHz, it goes to 3.3 GHz, which is the Max Turbo Frequency.

However when it doesn´t need speed, it down-clock itself below the clock speed in order to reduce energy.

It is part of enhanced Intel SpeedStep Technology, which "is an advanced means of enabling high performance while meeting the power-conservation needs of mobile systems. Conventional Intel SpeedStep Technology switches both voltage and frequency in tandem between high and low levels in response to processor load. Enhanced Intel SpeedStep Technology builds upon that architecture using design strategies such as Separation between Voltage and Frequency Changes, and Clock Partitioning and Recovery." http://www.intel.com/cd/channel/reseller/asmo-na/eng/20...
!