Sign in with
Sign up | Sign in
Your question

could not start the automatic updates service on local com..

Last response: in Windows XP
Share
Anonymous
July 18, 2005 4:33:01 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

When I try to download automatic updates on the Microsoft Windows website (by
clicking "Windows Update" on the start menu) I receive the following error
page:



[Error number: 0x8024001E]
The site cannot continue because one or more of these Windows services is
not running:

Automatic Updates (allows the site to find, download and install
high-priority updates for your computer)
Background Intelligent Transfer Service (BITS) (helps updates download more
quickly and without problems if the download process is interrupted)
Event Log (keeps a record of updating activities to help with
troubleshooting, if needed)
To make sure these services are running:
1. Click Start, and then click Run.
2. Type services.msc and then click OK.
3. In the list of services, double-click on Automatic Updates and then click
Properties.
4. In the Startup type list, select Automatic and click Apply.
5. Verify that the Service status is started, if the Service Status is
Stopped click on the Start Button.
6. In the list of services, double-click on Background Intelligent Transfer
Service (BITS) and then click Properties.
7. In the Startup type list, select Manual and click Apply.
8. Verify that the Service status is started, If the Service Status is
Stopped click on the Start Button.
9. In the list of services, double-click on Event Log and then click
Properties.
10. In the Startup type list, select Automatic and click Apply.
11. Verify that the Service status is started, If the Service Status is
Stopped click on the Start Button.


I followed the instructions and find that both Background Intelligent
Transfer Service and Event Log are both alreADY running and set to
"automatic". But, "Automatic Updates" is stopped, and when I try to start it,
I get the following error:

could not start the automatic updates service on local computer error
0x80070057 the parameter is incorrect

There is a space for "start parameters", but I have no idea what to enter
into this input field.

I am using Microsoft Windows XP Professional Edition version 2002.

The path (which I cannot seem to change) is the following:
D:\WINDOWS\system32\svchost.exe -k netsvcs --- (I thought that maybe the "K"
switch was causing the incorrect parameter problem, but I cannot change it by
typing into the field - it will not let me access it)

Please help.

Thank You.
JG
Anonymous
July 18, 2005 12:43:05 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi

Is the Remote Prodecure Call (RPC) Service running?

--

Will Denny
MS-MVP Windows Shell/User
Please reply to the News Groups


"Jeffrey G" <Jeffrey G@discussions.microsoft.com> wrote in message
news:26D1FADC-0A49-40E5-8780-DECC94EEA320@microsoft.com...
> When I try to download automatic updates on the Microsoft Windows website
> (by
> clicking "Windows Update" on the start menu) I receive the following error
> page:
>
>
>
> [Error number: 0x8024001E]
> The site cannot continue because one or more of these Windows services is
> not running:
>
> Automatic Updates (allows the site to find, download and install
> high-priority updates for your computer)
> Background Intelligent Transfer Service (BITS) (helps updates download
> more
> quickly and without problems if the download process is interrupted)
> Event Log (keeps a record of updating activities to help with
> troubleshooting, if needed)
> To make sure these services are running:
> 1. Click Start, and then click Run.
> 2. Type services.msc and then click OK.
> 3. In the list of services, double-click on Automatic Updates and then
> click
> Properties.
> 4. In the Startup type list, select Automatic and click Apply.
> 5. Verify that the Service status is started, if the Service Status is
> Stopped click on the Start Button.
> 6. In the list of services, double-click on Background Intelligent
> Transfer
> Service (BITS) and then click Properties.
> 7. In the Startup type list, select Manual and click Apply.
> 8. Verify that the Service status is started, If the Service Status is
> Stopped click on the Start Button.
> 9. In the list of services, double-click on Event Log and then click
> Properties.
> 10. In the Startup type list, select Automatic and click Apply.
> 11. Verify that the Service status is started, If the Service Status is
> Stopped click on the Start Button.
>
>
> I followed the instructions and find that both Background Intelligent
> Transfer Service and Event Log are both alreADY running and set to
> "automatic". But, "Automatic Updates" is stopped, and when I try to start
> it,
> I get the following error:
>
> could not start the automatic updates service on local computer error
> 0x80070057 the parameter is incorrect
>
> There is a space for "start parameters", but I have no idea what to enter
> into this input field.
>
> I am using Microsoft Windows XP Professional Edition version 2002.
>
> The path (which I cannot seem to change) is the following:
> D:\WINDOWS\system32\svchost.exe -k netsvcs --- (I thought that maybe the
> "K"
> switch was causing the incorrect parameter problem, but I cannot change it
> by
> typing into the field - it will not let me access it)
>
> Please help.
>
> Thank You.
> JG
Anonymous
July 18, 2005 9:39:49 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

From http://v4.windowsupdate.microsoft.com/troubleshoot/
See section "Error 80070057 during Scan"

<quote>

Problem Description:

Customer will see error 0x800A138F when scanning for updates, but the
Windows Update.log file will show error 0x80070057.

This appears to be an issue with the program Netop which enters a driver
entry into the enum\root\unknown key in the registry.

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{63C35530-D3DF-11D3-8F5D-0060B0A3612B}\0000]
"ProviderName"="Danware Data A/S"
"DriverDesc"="NetOp Driver 3 ver. 7.00 (2002014)"
"DriverDate"="Jan 14 2002"
"DriverVer"="7.00 (2002014)"
"MatchingDeviceId"="danware_netop_driver3"

Both the DriverDate and DriverVer are not formatted properly
......
....

</quote>




--
Ramesh, Windows XP MVP
http://windowsxp.mvps.org


"Jeffrey G" <Jeffrey G@discussions.microsoft.com> wrote in message
news:26D1FADC-0A49-40E5-8780-DECC94EEA320@microsoft.com...
> When I try to download automatic updates on the Microsoft Windows website
> (by
> clicking "Windows Update" on the start menu) I receive the following error
> page:
>
>
>
> [Error number: 0x8024001E]
> The site cannot continue because one or more of these Windows services is
> not running:
>
> Automatic Updates (allows the site to find, download and install
> high-priority updates for your computer)
> Background Intelligent Transfer Service (BITS) (helps updates download
> more
> quickly and without problems if the download process is interrupted)
> Event Log (keeps a record of updating activities to help with
> troubleshooting, if needed)
> To make sure these services are running:
> 1. Click Start, and then click Run.
> 2. Type services.msc and then click OK.
> 3. In the list of services, double-click on Automatic Updates and then
> click
> Properties.
> 4. In the Startup type list, select Automatic and click Apply.
> 5. Verify that the Service status is started, if the Service Status is
> Stopped click on the Start Button.
> 6. In the list of services, double-click on Background Intelligent
> Transfer
> Service (BITS) and then click Properties.
> 7. In the Startup type list, select Manual and click Apply.
> 8. Verify that the Service status is started, If the Service Status is
> Stopped click on the Start Button.
> 9. In the list of services, double-click on Event Log and then click
> Properties.
> 10. In the Startup type list, select Automatic and click Apply.
> 11. Verify that the Service status is started, If the Service Status is
> Stopped click on the Start Button.
>
>
> I followed the instructions and find that both Background Intelligent
> Transfer Service and Event Log are both alreADY running and set to
> "automatic". But, "Automatic Updates" is stopped, and when I try to start
> it,
> I get the following error:
>
> could not start the automatic updates service on local computer error
> 0x80070057 the parameter is incorrect
>
> There is a space for "start parameters", but I have no idea what to enter
> into this input field.
>
> I am using Microsoft Windows XP Professional Edition version 2002.
>
> The path (which I cannot seem to change) is the following:
> D:\WINDOWS\system32\svchost.exe -k netsvcs --- (I thought that maybe the
> "K"
> switch was causing the incorrect parameter problem, but I cannot change it
> by
> typing into the field - it will not let me access it)
>
> Please help.
>
> Thank You.
> JG
Related resources
Anonymous
July 19, 2005 4:16:05 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Yes, the Remote Procedure Call service was started (and on automatic and
greyed out).

The remote Procedure Call Locator was on manual and stopped. I set it to
automatic and started it and clicked apply.

Then I tried the Automatic Updates again and got the same error "could not
start the automatic updates service on local computer error 0x80070057 the
parameter is incorrect"

HEEEELLLPPPP!!!!

"Will Denny" wrote:

> Hi
>
> Is the Remote Prodecure Call (RPC) Service running?
>
> --
>
> Will Denny
> MS-MVP Windows Shell/User
> Please reply to the News Groups
>
>
> "Jeffrey G" <Jeffrey G@discussions.microsoft.com> wrote in message
> news:26D1FADC-0A49-40E5-8780-DECC94EEA320@microsoft.com...
> > When I try to download automatic updates on the Microsoft Windows website
> > (by
> > clicking "Windows Update" on the start menu) I receive the following error
> > page:
> >
> >
> >
> > [Error number: 0x8024001E]
> > The site cannot continue because one or more of these Windows services is
> > not running:
> >
> > Automatic Updates (allows the site to find, download and install
> > high-priority updates for your computer)
> > Background Intelligent Transfer Service (BITS) (helps updates download
> > more
> > quickly and without problems if the download process is interrupted)
> > Event Log (keeps a record of updating activities to help with
> > troubleshooting, if needed)
> > To make sure these services are running:
> > 1. Click Start, and then click Run.
> > 2. Type services.msc and then click OK.
> > 3. In the list of services, double-click on Automatic Updates and then
> > click
> > Properties.
> > 4. In the Startup type list, select Automatic and click Apply.
> > 5. Verify that the Service status is started, if the Service Status is
> > Stopped click on the Start Button.
> > 6. In the list of services, double-click on Background Intelligent
> > Transfer
> > Service (BITS) and then click Properties.
> > 7. In the Startup type list, select Manual and click Apply.
> > 8. Verify that the Service status is started, If the Service Status is
> > Stopped click on the Start Button.
> > 9. In the list of services, double-click on Event Log and then click
> > Properties.
> > 10. In the Startup type list, select Automatic and click Apply.
> > 11. Verify that the Service status is started, If the Service Status is
> > Stopped click on the Start Button.
> >
> >
> > I followed the instructions and find that both Background Intelligent
> > Transfer Service and Event Log are both alreADY running and set to
> > "automatic". But, "Automatic Updates" is stopped, and when I try to start
> > it,
> > I get the following error:
> >
> > could not start the automatic updates service on local computer error
> > 0x80070057 the parameter is incorrect
> >
> > There is a space for "start parameters", but I have no idea what to enter
> > into this input field.
> >
> > I am using Microsoft Windows XP Professional Edition version 2002.
> >
> > The path (which I cannot seem to change) is the following:
> > D:\WINDOWS\system32\svchost.exe -k netsvcs --- (I thought that maybe the
> > "K"
> > switch was causing the incorrect parameter problem, but I cannot change it
> > by
> > typing into the field - it will not let me access it)
> >
> > Please help.
> >
> > Thank You.
> > JG
>
>
>
Anonymous
July 19, 2005 4:21:03 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thank you Ramesh BUT:

No such registry entry exists on my computer and I have not installed netop.
Someone else (in another forum) mentioned a possible date string being in the
wrong format for a certain sound driver (in the registry).

I used the "FIND" command to search the entire registry sequentially from
January to December and changed every instance from the format (ie.) "January
1, 1979" to the format 01/01/1979.

I only found three or four entries in the long format, and changing them did
not help.

Thanks,
JG

"Ramesh, MS-MVP" wrote:

> From http://v4.windowsupdate.microsoft.com/troubleshoot/
> See section "Error 80070057 during Scan"
>
> <quote>
>
> Problem Description:
>
> Customer will see error 0x800A138F when scanning for updates, but the
> Windows Update.log file will show error 0x80070057.
>
> This appears to be an issue with the program Netop which enters a driver
> entry into the enum\root\unknown key in the registry.
>
> [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{63C35530-D3DF-11D3-8F5D-0060B0A3612B}\0000]
> "ProviderName"="Danware Data A/S"
> "DriverDesc"="NetOp Driver 3 ver. 7.00 (2002014)"
> "DriverDate"="Jan 14 2002"
> "DriverVer"="7.00 (2002014)"
> "MatchingDeviceId"="danware_netop_driver3"
>
> Both the DriverDate and DriverVer are not formatted properly
> ......
> ....
>
> </quote>
>
>
>
>
> --
> Ramesh, Windows XP MVP
> http://windowsxp.mvps.org
>
>
> "Jeffrey G" <Jeffrey G@discussions.microsoft.com> wrote in message
> news:26D1FADC-0A49-40E5-8780-DECC94EEA320@microsoft.com...
> > When I try to download automatic updates on the Microsoft Windows website
> > (by
> > clicking "Windows Update" on the start menu) I receive the following error
> > page:
> >
> >
> >
> > [Error number: 0x8024001E]
> > The site cannot continue because one or more of these Windows services is
> > not running:
> >
> > Automatic Updates (allows the site to find, download and install
> > high-priority updates for your computer)
> > Background Intelligent Transfer Service (BITS) (helps updates download
> > more
> > quickly and without problems if the download process is interrupted)
> > Event Log (keeps a record of updating activities to help with
> > troubleshooting, if needed)
> > To make sure these services are running:
> > 1. Click Start, and then click Run.
> > 2. Type services.msc and then click OK.
> > 3. In the list of services, double-click on Automatic Updates and then
> > click
> > Properties.
> > 4. In the Startup type list, select Automatic and click Apply.
> > 5. Verify that the Service status is started, if the Service Status is
> > Stopped click on the Start Button.
> > 6. In the list of services, double-click on Background Intelligent
> > Transfer
> > Service (BITS) and then click Properties.
> > 7. In the Startup type list, select Manual and click Apply.
> > 8. Verify that the Service status is started, If the Service Status is
> > Stopped click on the Start Button.
> > 9. In the list of services, double-click on Event Log and then click
> > Properties.
> > 10. In the Startup type list, select Automatic and click Apply.
> > 11. Verify that the Service status is started, If the Service Status is
> > Stopped click on the Start Button.
> >
> >
> > I followed the instructions and find that both Background Intelligent
> > Transfer Service and Event Log are both alreADY running and set to
> > "automatic". But, "Automatic Updates" is stopped, and when I try to start
> > it,
> > I get the following error:
> >
> > could not start the automatic updates service on local computer error
> > 0x80070057 the parameter is incorrect
> >
> > There is a space for "start parameters", but I have no idea what to enter
> > into this input field.
> >
> > I am using Microsoft Windows XP Professional Edition version 2002.
> >
> > The path (which I cannot seem to change) is the following:
> > D:\WINDOWS\system32\svchost.exe -k netsvcs --- (I thought that maybe the
> > "K"
> > switch was causing the incorrect parameter problem, but I cannot change it
> > by
> > typing into the field - it will not let me access it)
> >
> > Please help.
> >
> > Thank You.
> > JG
>
>
!