Sign in with
Sign up | Sign in
Your question

low fps in quake3!

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
March 22, 2001 6:39:00 PM

Hi all, i just bought quake3 and i'm getting kinda low frame rates
my specs
duron 800
128mb 133mhz
radeon 64mb ddr
sb live

i know my comp isn't that great, but it's not that bad either, so why the hell am i getting low fps?
i'm not sure about how many fps i get but i can feel it losing frames.
i run it at
1024*768 32bit color, everythink maxed
Please can someone help as i just keep pumping endless amounts of money into my system and game performance is just [-peep-]
Thanx in advance

More about : low fps quake3

March 22, 2001 11:26:08 PM

hey these are my Results with Driver 3056
Thunderbird 800
128 mb Pc133 4way bankinterleave on
SB live
Radeon 64mb DDR

Normal(FPS)
640x480 800x600 1024x768
109.3 101.7 82.1

High Quality
640x480 800x600 1024x768
108.4 100 78.2

@ default Clock speed 183/366
March 23, 2001 2:46:46 AM

What are your FPS? Which version of QuakeIII are you running? The most current is 127h which I highly recommend. Need more info in order to help. As in operating system, driver using and any tweaks that you have done if any. Which 4in1 drivers are you using if you have a via system? In W2k at max settings, compressed textures, lightmap at 1152x864x32 I run 61FPS. At 1024x768x32 I get around 75FPS. This is without overclocking my Radeon. I have an IWILL KK266 with a T-Bird 650@884.

<P ID="edit"><FONT SIZE=-1><EM>Edited by noko on 03/22/01 11:47 PM.</EM></FONT></P>
Related resources
Can't find your answer ? Ask !
March 23, 2001 11:28:22 AM

the first thing you can do to improve the performance is switch from 32 bit to 16 bit color. i can't really notice the difference in the games i play (in the color) but i do notice that the fps will go up everytime. then (of course) make sure you have all the latest drivers ... yada yada you know the rest.

<font color=red>yeah baby, my kung fu's the best...</font color=red>
March 23, 2001 1:13:57 PM

no difference in 32bit and 16bit colour? Yo Toonces U need to get your eyes checked or a better monitor! And he as a Radeon Card not a nvidia card droping to 16bit colour won't produce alot more frames per second! Radeon doesn't suffer from a big FPS drop like the GTS 2 card when in 32bit!
March 23, 2001 10:34:29 PM

Plus the Radeon is frankly terrible looking in 16bit colors, yechie.
Anonymous
a b U Graphics card
March 24, 2001 9:52:26 AM

hey noko, i'm currnetly running win98se with radeon driver 7041 and via 4in1 driver 2.25a. I've heard there's a newer via driver with a much better agp driver is this true?
Oh yeah and i'm just running the out of the box version of quake3, what do i type into the console to display my fps?
thanx
Anonymous
a b U Graphics card
March 24, 2001 9:55:51 AM

o yeah and i haven't done any tweaks, i did try a different radeon driver but during the installation it said FOR INTERNAL USE ONLY across the screen but i tried it anyway and my comp just died, so i had to format
March 24, 2001 11:40:47 AM

Update those drivers. Via is up to 4.29. Be sure not to run in turbo for the AGP and AGP 4x in your bios at the same time with Radeon.

Someone post the benchmark commands please. It's been too long for me and I don't remember exactly.

<b><A HREF="http://www.seti.tomshardware.com/" target="_new">How fast is your PC</A></b>
March 24, 2001 3:24:16 PM

Console commands:
timedemo 1
demo demo127
This is for version 127h.
Get the newest 4in1 429 here:
<A HREF="http://www.viahardware.com/download/index.shtm#4in1" target="_new">http://www.viahardware.com/download/index.shtm#4in1&lt;/A>

I run turbo and with AGP4x without any problems and with faster benchmarks. I don't recommend using Normal for the Via AGP driver because that will place AGP transfer rates to 1x, unless you have alot of problems when in Turbo. Basically with Win9x, when bios AGP 4x Mode is Enabled and AGP driver is in Turbo then you will get AGP4x. When disabled and driver in turbo you will be in AGP 2x. When in normal, regardless of your bios AGP 4x mode setting you will be in AGP 1x.
March 24, 2001 10:47:05 PM

Same here, Radeon 64 vivo Retail. What are your QuakeIII benchmarks?
March 25, 2001 4:41:02 AM

With:

Win Me
ABIT 750 (classic) Via 4.29
256MB Ram
Radeon 64 MB 7097 drivers
sblive
nic
scsi

AGP 4X (thanks NOKO tried it again and it works although I don't remember seeing the Turbo option in 4.29?)

Open GL (GPU settings) @ Qaulity

Q3 settings:
10x7
32bit
Light map
G details high
testure detail slider just past 1/2 way
testure qual 16 bit
bilinear
sound high
All eye candy (marks on walls ect...)

demo127 56.6 & 56.8 (no reboot, just shut everything off after reading post and ran)

How come when I went to run demo001 it wouldn't?

<b><A HREF="http://www.seti.tomshardware.com/" target="_new">How fast is your PC</A></b>
March 25, 2001 4:47:47 AM

What resolution where you in, also try 32bit textures and Trilinear filtering. I have the same problem trying to run Demo001 from the menus, it doesn't run.
March 25, 2001 4:49:58 AM

Run Via 429 4in1 driver and install it over again to ensure you are in Turbo mode. The 4in1 drivers are designed to write over themselves without problems.
March 25, 2001 2:58:16 PM

Just changed to

32 bit textures
trilinear
and moved the slider all the way over

55.1 & 55.1 FPS

will redo the AGP now to make sure. From what I remember 4.29 doesn't ask. I'll be back.

<b><A HREF="http://www.seti.tomshardware.com/" target="_new">How fast is your PC</A></b>
March 25, 2001 3:26:33 PM

Let me do a fresh batch of benchmarks, I will be using W2k 3116 drivers. Hey you can get 128x Anisotropic Filtering with the Radeon. It makes QuakeIII look like a whole new game with very little hit on FPS. Be back in a little bit.
March 25, 2001 4:19:37 PM

1024x768x32 max everything, 128x Anisotropic Filtering, sharpest detail in drivers, W2K

65.3FPS without texture compresstion
73.7FPS with texture compression

New ATI drivers scream in OpenGL for W2k. Will try WinMe and post later. Havn't been in WinMe for over a week. Note: to turn on texture compression in QuakeIII type this in the console:
<font color=blue><b>seta r_ext_compressed_textures 1</font color=blue></b> (this is for 1.27h, other versions are different)
To turn off:
<font color=blue><b>seta r_ext_compressed_textures 0</font color=blue></b>
Make sure Radeon driver OpenGL setting for compressed textures is enable also. You should see a significant jump in frame rate. I use non-compressed textures, reason, quality geek I am.

To turn on 128x Anisotropic filtering use Humas Raid-On tweaker:
<A HREF="http://www.geocities.com/SiliconValley/Cable/9070/Radeo..." target="_new">http://www.geocities.com/SiliconValley/Cable/9070/Radeo...;/A>
Go to menu <b>Special Settings</b> in menu <b>Special Settings</b> a pop up display gives you a number of Radeon sliders to adjust. If you want to know the Registry setting let me know and I will guide you through it.
March 25, 2001 5:02:53 PM

1024x768x32 max everything, 128x Anisotropic Filtering, sharpest detail in drivers, WinMe, 3087 drivers

1024x768x32

66.7FPS without texture compresstion
72.4FPS with texture compression

Pretty much the same as in W2k. I am running Radeon at stock clock of 182.25mhz for both tests in WinMe and W2k.
!