Sign in with
Sign up | Sign in
Your question

Picaview Problem With WinXP Pro SP2

Last response: in Windows XP
Share
Anonymous
July 23, 2005 12:49:07 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I recently installed SP2 over WinXP Pro SP1 and suddenly my Picaview
couldn't preview animated GIF files anymore when I right click them.
What is the matter? Could somebody help me please? Thanks in advance.
Anonymous
July 24, 2005 1:46:29 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

From ACD Systems - PicaView FAQ

<quote>

Question:
Does PicaView 2.0 work with Windows XP running Service Pack 2?

Answer:
No. Once Service Pack 2 is installed on the system PicaView will no longer
function. To get PicaView running again you will need to remove Service Pack
2

</quote>

See:
http://www.acdsystems.com/english/support/knowledgebase...
Copyright © 2005 ACD Systems

--
Ramesh, Windows XP MVP
http://windowsxp.mvps.org


"juck jones" <juckjones@gmail.com> wrote in message
news:1122133746.976612.308110@o13g2000cwo.googlegroups.com...
>I recently installed SP2 over WinXP Pro SP1 and suddenly my Picaview
> couldn't preview animated GIF files anymore when I right click them.
> What is the matter? Could somebody help me please? Thanks in advance.
>
Anonymous
July 24, 2005 10:24:44 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thanks, Ramesh for the info. Now, at least I know the cause of my
problem. Of course, I won't remove/uninstall SP2! But is there any
chance that there could be a fix to this problem via registry editing?
Again, my thanks.

Juck
Related resources
Anonymous
July 24, 2005 10:50:44 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Ok. That's good enough for me. I'll leave it at that. A pleasant day to
you, Ramesh.
Anonymous
July 24, 2005 11:01:02 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

No idea, Juck. I don't have this s/w.

--
Ramesh, Windows XP MVP
http://windowsxp.mvps.org


"juck jones" <juckjones@gmail.com> wrote in message
news:1122211484.186666.303220@g44g2000cwa.googlegroups.com...
> Thanks, Ramesh for the info. Now, at least I know the cause of my
> problem. Of course, I won't remove/uninstall SP2! But is there any
> chance that there could be a fix to this problem via registry editing?
> Again, my thanks.
>
> Juck
>
Anonymous
July 24, 2005 11:36:04 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

You're welcome Juck.

--
Ramesh, Windows XP MVP
http://windowsxp.mvps.org


"juck jones" <juckjones@gmail.com> wrote in message
news:1122213044.003414.120710@o13g2000cwo.googlegroups.com...
> Ok. That's good enough for me. I'll leave it at that. A pleasant day to
> you, Ramesh.
>
September 28, 2007 5:28:26 PM

Picaview's functionality seems to be restricted by Xp Sp2's Data Execution Prevention (DEP) program. Switching it off in the boot.ini file allows Picaview to operate on my machine as normal.
I cannot say this will work for everyone.

To deactivate DEP which you should not do according to some as it may make your computer vunerable to system files being changed, change the the boot.ini file to read:

[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=AlwaysOff /fastdetect

Make sure to make a copy of boot.ini first.
Also please note that Picaview has also been reported as causing trouble for the "Open With..." item on the right click context menu in explorer. So I suggest a back up of the registry as well.

Picaview like TrayMenu from Wei Ke seem to be frowned upon because they give too much control to the end user. At least that is the way it seems to me. Proceed with caution please, but I have found the above works.
August 3, 2008 4:45:38 PM

I was able to get picaview to work with XP SP2 by going to system properties then clicking the advanced tab and going to performance settings. I then clicked on Data Execution Prevention and selected 'Turn on DEP for all programs and services except those I select.' I checked the box on Windows Explorer and then clicked 'add'. Browse to the \program files\acd systems\plugins folder and type *.* in the filename box. Then you select the plugin that is causing the error. In my case it was the IDE_ACDStd.apl. Click apply then ok. You will have to restart the system and everything will work...at least it did for me.

Good luck.
September 6, 2008 4:40:38 PM

@bigone5500...

Your post solved a big problem for me...but I had to make one other adjustment.

Just doing the DEP dance for the Plugins didn't work so I tried - again - to reinstall Picaview - more than once - but I kept on getting the message that (paraphrasing here) "The application could not start because "xerces-c_2_6.dl" could not be found."

So, I went back into the Data Execution "stop you from using your purchased software because MS doesn't want you to use it" section and did exactly the same thing with xerces-c_2_6.dll...rebooted and "Viola!" As soon as XP opened I could use Picaview!

I have copied your post into a notebook file and saved it on an external disk so that it will be there if I ever run into a similar problem again.

Thanks loads!

<Edit to add>: Oddly enough, I tried...just for the heck of it...to install Picaview again, and still received the message about "xerces-c_2_6.dll" but it appears to be just for the Picaview install program as it doesn't happen with other install progs. Picaview still works alright though and that's the main thing. There is a lot to be said for being able to right click on a pic and see what it is without having to open a complete program.

January 27, 2010 12:49:32 PM

I was able to get picaview to work
with XP SP2 by going to system properties
then clicking the advanced tab and going to
performance settings.
I then clicked on Data Execution Prevention
and selected 'Turn on DEP for all programs and
services except those I select.' I checked the box
on Windows Explorer and then clicked 'add'.
Browse to the \program files\acd systems\plugins folder and type
*.* in the filename box. Then you select the plugin that is causing
the error. In my case it was the IDE_ACDStd.apl. Click apply then ok.
You will have to restart the system and everything will work...at least it did for me.
January 27, 2010 12:51:00 PM

It may take 2 or 3 reboots or repeating the steps be4 you see it working, but it does start to work .
!