Sign in with
Sign up | Sign in
Your question
Closed

Seagate Freeagent Go on Windows 7

Last response: in Windows 7
Share
September 12, 2009 3:19:01 PM

Has anyone tried using a Seagate Freeagent Go on Windows 7? My 64bit system isn't even recognizing the hardware.

Best solution

a b $ Windows 7
September 12, 2009 6:56:41 PM

Im using the Freeagent Go 160GB without a problem. Using it with both Win7 32bit and Win 7 64bit.
Are you trying to use your Freeagent as the boot drive?
Share
a b $ Windows 7
September 12, 2009 7:43:46 PM

I'm using Freeagent 250GB no problem, try rebooting with it plugged in. Otherwise check it on another computer.
Score
0
Related resources
October 26, 2009 1:53:27 AM

me too, using 320GB Freeagent Go with no problem. Is yours old or new version?
Score
0
Anonymous
a b $ Windows 7
December 29, 2009 3:48:14 PM

I'm having issues with my 320 Gig Freeagent Go. It works fine on my XP laptop, but Windows 7 (64 bit) recognizes the drive and tells me that it needs to be formatted before it can be used (it's already NTFS).

Oddly enough, it used to work fine on my Vista desktop until I re-installed Vista, now it tells me the same thing about needing to be formatted.

Both Vista and 7 recognize the drive and state the correct size and say that they are healthy active partitions. The drive is full of pictures, music and Virtual hard drives from Virtual Box. Any ideas?
Score
0
January 10, 2010 8:46:10 AM

hi im having the same problem as getaglance. Im using 500GB freeAgent go on my win 7 notebook. Cant be detected?
Score
0
Anonymous
a b $ Windows 7
January 14, 2010 1:34:05 AM

I had problems at first, but I finally solved the problem and it is now working fine. Here is what you need to do. Click on the windows button (formerly Start), in the box that says "Search programs and file", type in "Computer Management" without the " ". In the main window (the big window", Double clcik on "Storage", then double click on Disk Management. You should no be looking at a list of all of the drives attached to and recognized by Windows Disk Management, if you scroll down you should see your free agent drive listed, you need to right click on it and select "Mark Drive as Active", after marking active is complete, you will need to right click on it again, and then select "Change drive letter and path", after this is complete, your drive will be usable.
Score
0
March 6, 2010 4:57:46 PM

[SOLVED In Another Way]
I had trouble with my Windows 7 Ultimate 64 workstation, although it worked on my Windows 7 64 laptop and another XPx64 Pro workstation. The trouble was an extension USB cable (the laptop and XP machine didn't use such a cable). It caused the drive to mount/unmount many times per second, however, when the drive was connected directly to a USB port with the short cable provided by Seagate, it worked fine. Perhaps that extra cable wasn't providing enough power to the Seagate. This phenomenon went un-noticed when using external drives that used their own wall outlet power supplies.
Score
0
March 7, 2010 2:30:20 AM

SOLVED!!
followed instructions (computer management/ diskmanagement) and renamed drive.

Thank You

I have Windows 7 64-bit premium and FreeAgent 120
Score
0
July 5, 2010 1:26:44 AM

hello guys,

still in trouble for me, I have a gateway laptop with windows 7 64 bits

and it seems at least phisically working I can see it in device manager and computer management

but in computer management, the 2 options mark as active and change drive letter are shadowed

see screeshots





thanks
Score
0
August 9, 2010 1:13:46 AM

I am trying to solve my same problem like you suggest, but when I right click and try to select change drive letter and path, it tells me the disk management console view is not up to date. I clicked refresh; I unplugged and replugged the usb connection, and I even rebooted the computer. Nothing changes. It does work on my old XP, and I can see it under hardware/storage devices, but I cannot access it at all. Any more suggestions would be super. Thanks!!
Score
0
a b $ Windows 7
August 10, 2010 2:29:09 AM

This topic has been closed by Mousemonkey
Score
0
!