Sign in with
Sign up | Sign in
Your question

HDD locked and cannot be initialized (correct password known..)

Last response: in Laptops & Notebooks
Share
January 21, 2013 2:50:18 AM

Few months ago my 8 years old Qosmio G40-129 has died..
Today i bought a new computer:
Quote:
Operating System
MS Windows 7 Ultimate 64-bit
Motherboard
ASUSTeK COMPUTER INC. M5A97 R2.0 (Socket 942)
Hard Drives
59GB INTEL SS DSC2CT060A3 SATA Disk Device (SATA)
:fou:  244GB FUJITSU MHY2250BH SATA Disk Device (SATA) :fou: 


The problem is that i did not found the way to unlock FUJITSU HDD with master password in BIOS. It was locked on previous PC. I know the password but I cannot find any way to unlock it with any password type (master, user) that I can type in BIOS. Actually I think that only passwords that I found there are locking BIOS itself and have no influence on ddrives..
HDD is correctly found by BIOS, Speccy and by Windows "Computer Management" but.. It did not initialize it in any way.
http://img22.imageshack.us/img22/9302/errorpg.jpg
Another, identical HDD is working properly but was never locked with password on previous PC.

I have tried almost everything.. SlimDrivers, GParted on Ubuntu 11.04, HDD Unlock (without hdd initialization it cannot do anything), MicrosoftFixIt and i even tried to encrypt it over with TrueCrypt (same I/O error). By the way.. On the HDD there is one hidden True Crypt partition. Maybe that is causing some problems.

I cannot unlock HDD without initializing it and i cannot initialize it without unlocking it. So.. How do i unlock that piece of :fou:  ?! Any ideas?

Btw.. I dont even care if I will keep the data. Backup 4 life!
a b D Laptop
January 21, 2013 2:52:38 AM

ATAPWD software in dos?
January 21, 2013 3:37:31 AM

getochkn said:
ATAPWD software in dos?

Nope..
http://www.sevenforums.com/tutorials/46707-ms-dos-boota...
I used this tutorial to create msd-dos flash drive. Than I did everything as said here - http://www.rockbox.org/lock.html
And ATAPWD said.. "No ATA drives detected".
So i checked it out and connected another HDD (actual system drive that works) and it didnt detect it aswell. But! Why is it looking for ATA if what I should be searching is actually SATA? Stupid me. I just lost 15 minutes of life but at least have some more knowledge. Thx.
Do you know any msdos aplications that are able to find SATA? :]
Related resources
January 21, 2013 8:19:51 AM

Well.. I tried MHDD and I don't know what exactly went wrong but it didn't work. After installing Magic Boot Disk ( from here - http://hddguru.com/software/2006.02.10-Magic-Boot-Disk/ ) on USB drive and run as emulated floppy, the app was not even on the floppy. So i did try another way - not to emulate anything, change the drive letter, and still i could not run mhdd.exe... :/ 

Does anyone have a full tutorial "how am i supposed to run mhdd?"
a b D Laptop
January 21, 2013 1:28:13 PM

Can't you put it back in the original PC to unlock it.

It may also be the way dos is detecting it because it's a SATA drive. Are their options in your BIOS to switch SATA between IDE and ACHI mode? Try switching that and see if DOS pick's it up then and use ATAPWD.
January 21, 2013 1:37:53 PM

I did switch it between IDE and ACHI (as in "manual) but it didnt change anything.. :/ 
a b D Laptop
January 21, 2013 3:10:12 PM

I think the BIO HD password is only active on boot drives, so maybe try removing your other HD with just this HD, set as a boot drive, then reboot and see if it asks for PW, then go into BIOS and try and remove it.
January 22, 2013 1:09:29 AM

Well.. It is not BIOS password. Still I dont know what exactly it is. SMART analysis is saying that HDD is working fine but any format/structure analysis app cannot read or write anything that is on it.
I checked all possible linux apps and none worked. :/ 
!