Sign in with
Sign up | Sign in
Your question

Please help with failed BIOS update with GEforceMX

Last response: in Graphics & Displays
Share
June 25, 2001 10:47:09 PM

I have (had?) a ABIT MX2. I flashed the BIOS to the latest MX2_1024.exe
This is what I got on the screen afterwards:
FLASH UPDATE SUCCESSFUL
COMPARING ENTIRE ROM
ERROR: NO ROM SIGNATURE CAN BE FOUND (ROM PROBABLY BLANK OR NON-FUNCTIONAL)
ERROR:COULD NOT GET ROM SIZE
ERROR: COMPARING EEPROM WITH FILE
a:\
So once it got to the A prompt I figured it was done the flash. I rebooted and the monitor shut off and stayed off. I shut off the computer completely to include the power. Booted up and nothing. Changed Vid cards and I could see the BIOS ID of the old Diamond I'm using now. Changed back to the MX. Nothing. But I can boot up with the floppy that I used to flash the MX BIOS with because it has the sys files on it. I just can't see what's going on. I tried reflashing it but its hard when you can't see what's there. I typed:
NVFLASH MX2_0124.EXE (as I did to flash originally)
I can see that it's reading the floppy. I don't remember what it asked to do next. I do remember that at some point I had to type in YES in caps to proceed with the flash upgrade.
Can anyone help? Is this redeemable? I think I can still flash it. I just can't see what's on the monitor. I can type in NVFLASH MX2_0124 and the program will read the floppy but, I don't remember what the next steps are because I can't see 'em to answer them!!! Can anyone tell me what the steps are to flash? I need someone to be my eyes.
Anonymous
a b U Graphics card
June 25, 2001 10:59:42 PM

get a pci video card and plug the monitor into that. Boot with the a drive like you have and flash the agp card.
June 25, 2001 11:16:35 PM

That seems like a good idea. I have a PCI VID card I can use. But, I feel that I need more info. How will I be able to flash the MX and not the one in the PCI slot. Not to mention, I still won't be able to see what's going on with the MX flasher.(?)
Related resources
Anonymous
a b U Graphics card
June 26, 2001 12:18:56 AM

the flasher program should see the agp card. You will be able to see what is going on because you'll be using the pci card with the monitor.
June 26, 2001 4:23:47 AM

I've been fart'in around with this thing on and off for hours, now. I've been trying that alternative with the PCI vid card. Using the two vid card theory; I've been typing in variations of this: NVFLASH -MX_0018C.EXE I've exchanged EXE for ROM but the most consistant thing I get on the screen is " Please use - or / to start command line parameters." This has me stumped. I thought I tried all that. I also get this when I try. This is the read me that comes with the BIOS:

Commands:
Example of use: NVFLASH -s4 -fBIOS.ROM -l
-f Flash the ROM using , then do compare and ~CRC32.
-b Read ROM and save to .
-k Read ROM and compare with .
-x Xfer TV data from file to AT29LV512; SST29LE/VE512 SST39VF512.
-v Display file version and ~CRC32 (if no filename, acts on ROM).
-t Display 256 bytes of ROM, at offset C000h
-e Erase the ROM.
-d Display 256 bytes of ROM, at offset 0.
-c Check for supported EEPROM.
-l Don't light keyboard LEDs.
-p Don't pause if ROMfile & chip PCI VenID, DevID mismatch.
-h Reboot the PC after other tasks completed.
-w Write protect ROM (only works on some ROMs).
-r Remove ROM Write protect. (only works on some ROMs).
-a List all supported device indexes.
-m Enable Macintosh (FCode) compatible mode.
-g Force a specific device index.
-i Force specific device instance (use with -g).
-? Display Help
-s# Silence level:
default All progress messages, all beeps.
#=1 No progress messages, no beeps.
#=2 No progress messages, no progress beeps.
#=3 No progress messages.
#=4 No progress beeps.
#=5 No beeps.


Does this make any sense? What am I doing wrong? How should I use - or / ??? Thankyou!
Anonymous
a b U Graphics card
June 26, 2001 4:36:33 AM

hmm, I'm not experienced with this flasher, purhaps the techinical support of the company that made the card could help you out.
June 26, 2001 5:36:42 AM

I am glad you didn't have this problem with yours MX. You really would have been mad.
a b U Graphics card
June 26, 2001 8:18:08 PM

Just use the command line they gave you (NVFLASH -s4 -fBIOS.ROM -1) if BIOS.ROM is the name of your BIOS file. Or give me the card and I'll fix it-so long and thanks for all the fish.

Cast not thine pearls before the swine
June 27, 2001 1:02:45 AM

OK. I just wanna say: THANKS! Using the pci vid card as the primary display device and leaving the agp in,(cool trick) I was able to use this:
A:/>nvflash -s4 -fmx_0018c.rom ...AND IT WORKED! HA! The progie said it found two devices to flash the one in the PCI slot or the one in the AGP choose 1 for AGP and 0 for PCI.
All is OK now. Thanx again!
!