Sign in with
Sign up | Sign in
Your question

Computer Description greyed out

Last response: in Windows XP
Share
Anonymous
August 6, 2005 4:53:49 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Running XP Home SP2
Following "Start | Control Panel | System I Computer Name" I cannot
change the Computer description as the box is greyed out.

Someone with XP PRO had same problem but my registry is not the same.

Hope someone can help.

John


--
lemnd

More about : computer description greyed

November 18, 2009 11:11:52 PM

If the "File and Printer Sharing for Microsoft Networks" Service is not bound to the Network Interface being used for communication; the Computer Description will be greyed out.

Removing the Service from the Network Interface will remove the lanmanserver registry key and all subkeys and parameters attached to it.

Rebinding the Service to the Network Interface will restore the lanmanserver key and default parameters, but will not save any previously defined Computer Description. The field will not be initiated, it will be empty.

This can be verified by binding and then checking the Computer Description box, it will be editable. Then unbinding and checking the Computer Description box, it will be un-editable and greyed out.

There is no need to reboot before observing the Computer Description, it will be greyed and un-greyed as soon as the binding or un-binding process completes.. which takes a few seconds.

---

To un-bind, right click My Network Places, select properties, right click the enabled Interface with blue screens, select properties.

From the "This connection uses the following items:" combo box choose "File and Printer Sharing for Microsoft Networks". Press "Uninstall".

Then verify the Computer Description is "greyed out".

Right Click "My Computer" select "Properties", then Computer Name tab.

---

To bind, right click My Network Places, select properties, right click the enabled Interface with blue screens, select properties. Press "Install..." select "Service" then "Add"

Choose Manufacturer "Microsoft" and Network Service: "File and Printer Sharing for Microsoft Networks", press "OK"

Then verify the Computer Description is "not greyed out".

Right Click "My Computer" select "Properties", then Computer Name tab.

---

Be careful not to use simple command line tools like

net config server /srvcomment:"comment"

This will disable "autotune" features installed as part of the binding process, as a side effect of setting the "one" parameter but none of the others.

- John W.
November 18, 2009 11:20:08 PM

Additional:

On XP Home its more likely your dealing with a dialup or alternative type of guarded network connection.

Microsoft KB recommends un-binding File and Printer Sharing from such an interface (particularly when ICS sharing was enabled) in early editions of XP, pre-SP2 I believe. After Windows Firewall became available this was less of a common practice.

Other reasons it might be un-bound include a desire to disable certain features of a default install, and/or present a more secure network foot print where alternative means of security are too complex or difficult to set up. And or an LSP incident with the network stack.

- John W.
Related resources
November 19, 2009 2:43:43 PM

That thread was from 2005, it's good that you are trying to help, and sharing your knowledge, but the original poster might not even have the same computer anymore.

But anyway feel free to try to help any of the other guys with more recent questions.

And please don't be offended, I just think that is better if we try to help the guys that are having the problems right now.

Peace.
November 19, 2009 10:42:39 PM

Point taken.

This just solved a problem for about 75 users on a state wan network.

!