Sign in with
Sign up | Sign in
Your question

Disk Defragmenter

Last response: in Windows XP
Share
August 8, 2005 7:39:02 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

When l try to defrag my hard disk l get this message box
DISK DEFRAGMENTER
Disk defragmenter had detected that Chkdsk is scheduled to run on Volume:( C:) 
Please run Chkdsk /F
When I run Chkdsk /f l am still unable to defrag my hard disk how can l turn
off Chkdsk.

More about : disk defragmenter

August 9, 2005 7:41:24 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Russell,
if memory serves me correctly, chkdsk needs to auto-run on the next bootup, after that then you
should be able to run defrag again.
hope this helps.
Paul


"Russell" <Russell@discussions.microsoft.com> wrote in message
news:3377DA1D-E558-43A7-A3FA-B42B2F002DB0@microsoft.com...
When l try to defrag my hard disk l get this message box
DISK DEFRAGMENTER
Disk defragmenter had detected that Chkdsk is scheduled to run on Volume:( C:) 
Please run Chkdsk /F
When I run Chkdsk /f l am still unable to defrag my hard disk how can l turn
off Chkdsk.
August 10, 2005 5:01:03 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Paul l still get this message when l try to defrag straight after boot up

"Paul" wrote:

> Russell,
> if memory serves me correctly, chkdsk needs to auto-run on the next bootup, after that then you
> should be able to run defrag again.
> hope this helps.
> Paul
>
>
> "Russell" <Russell@discussions.microsoft.com> wrote in message
> news:3377DA1D-E558-43A7-A3FA-B42B2F002DB0@microsoft.com...
> When l try to defrag my hard disk l get this message box
> DISK DEFRAGMENTER
> Disk defragmenter had detected that Chkdsk is scheduled to run on Volume:( C:) 
> Please run Chkdsk /F
> When I run Chkdsk /f l am still unable to defrag my hard disk how can l turn
> off Chkdsk.
>
>
August 11, 2005 1:40:08 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Russell,
what it is saying is that chkdsk needs to fix a problem on your volume c:
i.e. chkdsk /f . I couldn't tell you how to disable chkdsk, to me that doesn't sound like the way
to go anyway- you need to correct the errors and that will turn off the chkdsk (sorry if this sounds
basic but I've found the best way to correct problems on computers is to think in in basic &
black/white terms and start investigating.... start with what you know, then go from there).

how are you starting chkdsk, ru starting it from a command prompt or are you starting it from your
windows cd? I'm not sure whether it has any basis or not to this problem but I'm just investigating
(my thinking is the 1st option would be running it from the GUI which MAY be causing a conflict of
some sort with defrag) ... I personally would use the later of the 2 options myself. from what
you've said it tells me that chkdsk hasn't fixed the problem, so...why not? why not try the other
way and see if that does the trick, can't hurt can it?

here's a clue that I would follow up on...now I'm not saying this is the answer, not at all, but its
just something I came across that I hadn't heard about before that relates to chkdsk & defrag
problems so it sparked my curiosity... just a note of warning, it does say that you should be pretty
competent before playing in this area (which I am assuming you are not overly so) but that doesn't
stop you from investigating and possibly giving a professional a heads up to what the problem could
be, if you get my meaning. anyway here's the clue:

"You cannot defragment volumes that the file system has marked as dirty, which indicates possible
corruption. You must run chkdsk on a dirty volume before you can defragment it. You can determine if
a volume is dirty by using the fsutil dirty query command. "

PROCEED AT YOUR OWN RISK.

my next advice would be to contact a real professional to get their advice- try here:
http://www.microsoft.com/communities/MVP/MVP.mspx

let me know how you get on, I'd be very interested.
good luck.
Paul


"Russell" <Russell@discussions.microsoft.com> wrote in message
news:A9377DC5-299B-41D6-99A4-550E6D95D5C9@microsoft.com...
Paul l still get this message when l try to defrag straight after boot up

"Paul" wrote:

> Russell,
> if memory serves me correctly, chkdsk needs to auto-run on the next bootup, after that then you
> should be able to run defrag again.
> hope this helps.
> Paul
>
>
> "Russell" <Russell@discussions.microsoft.com> wrote in message
> news:3377DA1D-E558-43A7-A3FA-B42B2F002DB0@microsoft.com...
> When l try to defrag my hard disk l get this message box
> DISK DEFRAGMENTER
> Disk defragmenter had detected that Chkdsk is scheduled to run on Volume:( C:) 
> Please run Chkdsk /F
> When I run Chkdsk /f l am still unable to defrag my hard disk how can l turn
> off Chkdsk.
>
>
!