Lenovo y580 bad performance ?

I just recently installed a couple games I enjoyed on my crappy desktop (6 yrs. old + 7750) like witcher 2, skyrim, dota 2 . . . will try gw2, sc2

I was expecting better performance than what I am getting.

Witcher 2: the auto-detected to all high settings, but when I play the game all I get is 15-25 fps, and in the beginning cut scene when Geralt is running in forest is only 6-8 fps ?
Skyrim: auto-detected to low settings because in gpu can only select hd 4000 graphics so I set it to all high. when in a cave and there are lights coming from holes in the ceiling I see a noticeable fps drop, also when outdoors the game is overall a little sluggish
Dota 2: don't really worry about problems with fps :D

I suspect that the laptop is using the intel 4000 but I don't think that an integrated gpu could pull off 25 fps on high settings in witcher 2 . . . so kinda lost as to what might be the problem or maybe my expectations were just too high, and a gtx660m isn't much of an improvement over my shitty 6yr old desktop with 7750 :) ( I played skyrim on it all high settings 30-35 fps)
4 answers Last reply
More about lenovo y580 performance
  1. Ensure that all your drivers are up to date, and that the laptop is plugged directly into a power source.

    Be sure you have high performance mode selected, and that the Optimus Physical switch is turned on to enable the GTX 660m to be selected.
  2. I just updated to the newest drivers today and tried playing Witcher 2 after that. My laptop is always plugged in. In the power plan options there is "high performance" and also "Lenovo dynamic graphics" which one should I choose? as to the optimus switch, the y580 dosnt actually have a physical switch to enable the "optimus feature", I think it is the power plan I listed above that enables it
  3. go to device manager and ensure the 660m is enabled and functioning properly

    or download 3d mark 11 and run it. If you get a score around 1000, its using the Intel HD 4000. If you get a score around 2500, its using the 660m.
  4. In the nvidia control panel go to "manage 3D settings", then Program Settings and be sure the .exe for the game is set to use the "High Performance Nvidia Processor"

    You may have to manually add the .exe for the game. I have the y570 and that works for me when a game doesn't use the Nvidia processor.

    For me Skyrim auto-sets everything to high with 8x AA and 8x AF. I turn that down and manage decent frame rates while still going to an external monitor.
Ask a new question

Read More

Performance FPS Laptops