Wrong icon displaying for JPGs

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hello,

I've got XP Pro SP2. My JPE, JPEG, JPG files are displaying the Netscape
icon next to them even though I have gone to Windows Explorer > Tools >
Folder Options and set it up so that Photoshop opens each of these file
types. The Photoshop icon is displayed in the Folder Options as it should
be, and the files do open in Photoshop, but if I go to File > Open in
Photoshop, all of these files have the Netscape icon. How do I make it so
the Photoshop icon is displayed for these? Thanks.

Mark
9 answers Last reply
More about wrong icon displaying jpgs
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    insMark,
    You really don't want Photoshop as your default for opening jpegs. It's
    too memory intensive! Use the default Windows program for that.

    "Mark Christensen" wrote:

    > Hello,
    >
    > I've got XP Pro SP2. My JPE, JPEG, JPG files are displaying the Netscape
    > icon next to them even though I have gone to Windows Explorer > Tools >
    > Folder Options and set it up so that Photoshop opens each of these file
    > types. The Photoshop icon is displayed in the Folder Options as it should
    > be, and the files do open in Photoshop, but if I go to File > Open in
    > Photoshop, all of these files have the Netscape icon. How do I make it so
    > the Photoshop icon is displayed for these? Thanks.
    >
    > Mark
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Mark,

    Start Regedit.exe and navigate to:

    HKEY_CLASSES_ROOT\.JPG
    HKEY_CLASSES_ROOT\JPEGFILE

    Export the contents to REG files and post them here.

    Alternately,
    Repair image file type associations in Windows XP:
    http://windowsxp.mvps.org/imgassofix.htm

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "Mark Christensen" <markc@ssbrakes.com> wrote in message
    news:%239monlnnFHA.3656@TK2MSFTNGP09.phx.gbl...
    > Hello,
    >
    > I've got XP Pro SP2. My JPE, JPEG, JPG files are displaying the Netscape
    > icon next to them even though I have gone to Windows Explorer > Tools >
    > Folder Options and set it up so that Photoshop opens each of these file
    > types. The Photoshop icon is displayed in the Folder Options as it should
    > be, and the files do open in Photoshop, but if I go to File > Open in
    > Photoshop, all of these files have the Netscape icon. How do I make it so
    > the Photoshop icon is displayed for these? Thanks.
    >
    > Mark
    >
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    OK, here's what I got:

    Windows Registry Editor Version 5.00


    [HKEY_CLASSES_ROOT\.jpeg]

    "PerceivedType"="image"

    @="MozillaJPEG"

    "Content Type"="image/jpeg"

    "PreviousAssociation"="MozillaJPEG"

    "PerceivedType_old"="image"

    "Roxio7.OldVal"="Photoshop.JPEGFile"


    [HKEY_CLASSES_ROOT\.jpeg\OpenWithProgids]

    "jpegfile"=hex(0):


    [HKEY_CLASSES_ROOT\.jpeg\PersistentHandler]

    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"


    AND


    Windows Registry Editor Version 5.00


    [HKEY_CLASSES_ROOT\.jpg]

    "PerceivedType"="image"

    @="MozillaJPEG"

    "Content Type"="image/jpeg"

    "PreviousAssociation"="MozillaJPEG"

    "Roxio7.OldVal"="Photoshop.JPEGFile"

    "PerceivedType_old"="image"


    [HKEY_CLASSES_ROOT\.jpg\OpenWithProgids]

    "jpegfile"=hex(0):


    [HKEY_CLASSES_ROOT\.jpg\PersistentHandler]

    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"


    Thanks for your help!


    "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    news:u3e22konFHA.1416@TK2MSFTNGP09.phx.gbl...
    > Mark,
    >
    > Start Regedit.exe and navigate to:
    >
    > HKEY_CLASSES_ROOT\.JPG
    > HKEY_CLASSES_ROOT\JPEGFILE
    >
    > Export the contents to REG files and post them here.
    >
    > Alternately,
    > Repair image file type associations in Windows XP:
    > http://windowsxp.mvps.org/imgassofix.htm
    >
    > --
    > Ramesh, Windows XP MVP
    > http://windowsxp.mvps.org
    >
    >
    > "Mark Christensen" <markc@ssbrakes.com> wrote in message
    > news:%239monlnnFHA.3656@TK2MSFTNGP09.phx.gbl...
    >> Hello,
    >>
    >> I've got XP Pro SP2. My JPE, JPEG, JPG files are displaying the Netscape
    >> icon next to them even though I have gone to Windows Explorer > Tools >
    >> Folder Options and set it up so that Photoshop opens each of these file
    >> types. The Photoshop icon is displayed in the Folder Options as it
    >> should
    >> be, and the files do open in Photoshop, but if I go to File > Open in
    >> Photoshop, all of these files have the Netscape icon. How do I make it
    >> so
    >> the Photoshop icon is displayed for these? Thanks.
    >>
    >> Mark
    >>
    >
  4. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Type in Start, Run:

    cmd /c ASSOC .jpg=jpegfile
    cmd /c ASSOC .jpeg=jpegfile

    Followed by this command:

    regsvr32 shimgvw.dll

    Logoff and login back.

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "Mark Christensen" <markc@ssbrakes.com> wrote in message
    news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    > OK, here's what I got:
    >
    > Windows Registry Editor Version 5.00
    >
    >
    >
    > [HKEY_CLASSES_ROOT\.jpeg]
    >
    > "PerceivedType"="image"
    >
    > @="MozillaJPEG"
    >
  5. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    OK, the Netscape icon is no longer showing up next to the files, but the
    icon that is showing is still not the one I want. How change I change what
    icon is showing? I know I've done this before but can't remember how. I
    really appreciate the help!

    Mark


    "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    news:uqVwvApnFHA.3960@TK2MSFTNGP12.phx.gbl...
    > Type in Start, Run:
    >
    > cmd /c ASSOC .jpg=jpegfile
    > cmd /c ASSOC .jpeg=jpegfile
    >
    > Followed by this command:
    >
    > regsvr32 shimgvw.dll
    >
    > Logoff and login back.
    >
    > --
    > Ramesh, Windows XP MVP
    > http://windowsxp.mvps.org
    >
    >
    > "Mark Christensen" <markc@ssbrakes.com> wrote in message
    > news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    >> OK, here's what I got:
    >>
    >> Windows Registry Editor Version 5.00
    >>
    >>
    >>
    >> [HKEY_CLASSES_ROOT\.jpeg]
    >>
    >> "PerceivedType"="image"
    >>
    >> @="MozillaJPEG"
    >>
    >
  6. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Use the File Types dialog to change the icon now.

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "Mark Christensen" <markc@ssbrakes.com> wrote in message
    news:enJW2IpnFHA.3544@TK2MSFTNGP15.phx.gbl...
    > OK, the Netscape icon is no longer showing up next to the files, but the
    > icon that is showing is still not the one I want. How change I change
    > what icon is showing? I know I've done this before but can't remember
    > how. I really appreciate the help!
    >
    > Mark
    >
    >
    > "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    > news:uqVwvApnFHA.3960@TK2MSFTNGP12.phx.gbl...
    >> Type in Start, Run:
    >>
    >> cmd /c ASSOC .jpg=jpegfile
    >> cmd /c ASSOC .jpeg=jpegfile
    >>
    >> Followed by this command:
    >>
    >> regsvr32 shimgvw.dll
    >>
    >> Logoff and login back.
    >>
    >> --
    >> Ramesh, Windows XP MVP
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >> news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    >>> OK, here's what I got:
    >>>
    >>> Windows Registry Editor Version 5.00
    >>>
    >>>
    >>>
    >>> [HKEY_CLASSES_ROOT\.jpeg]
    >>>
    >>> "PerceivedType"="image"
    >>>
    >>> @="MozillaJPEG"
    >>>
    >>
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    That's the thing - the Photoshop icon is displaying in the File Types dialog
    (just like it was before) but it is still not displaying in Windows Explorer
    nor in Photoshop's File > Open. Intead of the Netscape icon displaying, a
    mainly white icon with a little bit of orange and red in the center is
    displayed.

    "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    news:OfAW0JpnFHA.2920@TK2MSFTNGP14.phx.gbl...
    > Use the File Types dialog to change the icon now.
    >
    > --
    > Ramesh, Windows XP MVP
    > http://windowsxp.mvps.org
    >
    >
    > "Mark Christensen" <markc@ssbrakes.com> wrote in message
    > news:enJW2IpnFHA.3544@TK2MSFTNGP15.phx.gbl...
    >> OK, the Netscape icon is no longer showing up next to the files, but the
    >> icon that is showing is still not the one I want. How change I change
    >> what icon is showing? I know I've done this before but can't remember
    >> how. I really appreciate the help!
    >>
    >> Mark
    >>
    >>
    >> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    >> news:uqVwvApnFHA.3960@TK2MSFTNGP12.phx.gbl...
    >>> Type in Start, Run:
    >>>
    >>> cmd /c ASSOC .jpg=jpegfile
    >>> cmd /c ASSOC .jpeg=jpegfile
    >>>
    >>> Followed by this command:
    >>>
    >>> regsvr32 shimgvw.dll
    >>>
    >>> Logoff and login back.
    >>>
    >>> --
    >>> Ramesh, Windows XP MVP
    >>> http://windowsxp.mvps.org
    >>>
    >>>
    >>> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >>> news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    >>>> OK, here's what I got:
    >>>>
    >>>> Windows Registry Editor Version 5.00
    >>>>
    >>>>
    >>>>
    >>>> [HKEY_CLASSES_ROOT\.jpeg]
    >>>>
    >>>> "PerceivedType"="image"
    >>>>
    >>>> @="MozillaJPEG"
    >>>>
    >>>
    >>
    >>
    >
  8. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Is this the icon you're seeing?
    http://windowsxp.mvps.org/images/thbimg.JPG

    >> the Photoshop icon is displaying in the File Types dialog

    Don't worry about that. Click the "Advanced" button and change the icon. If
    nothing helps , try imgassofix.htm link a try.

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "Mark Christensen" <markc@ssbrakes.com> wrote in message
    news:uXEOPTpnFHA.3408@tk2msftngp13.phx.gbl...
    > That's the thing - the Photoshop icon is displaying in the File Types
    > dialog (just like it was before) but it is still not displaying in Windows
    > Explorer nor in Photoshop's File > Open. Intead of the Netscape icon
    > displaying, a mainly white icon with a little bit of orange and red in the
    > center is displayed.
    >
    > "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    > news:OfAW0JpnFHA.2920@TK2MSFTNGP14.phx.gbl...
    >> Use the File Types dialog to change the icon now.
    >>
    >> --
    >> Ramesh, Windows XP MVP
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >> news:enJW2IpnFHA.3544@TK2MSFTNGP15.phx.gbl...
    >>> OK, the Netscape icon is no longer showing up next to the files, but the
    >>> icon that is showing is still not the one I want. How change I change
    >>> what icon is showing? I know I've done this before but can't remember
    >>> how. I really appreciate the help!
    >>>
    >>> Mark
    >>>
    >>>
    >>> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    >>> news:uqVwvApnFHA.3960@TK2MSFTNGP12.phx.gbl...
    >>>> Type in Start, Run:
    >>>>
    >>>> cmd /c ASSOC .jpg=jpegfile
    >>>> cmd /c ASSOC .jpeg=jpegfile
    >>>>
    >>>> Followed by this command:
    >>>>
    >>>> regsvr32 shimgvw.dll
    >>>>
    >>>> Logoff and login back.
    >>>>
    >>>> --
    >>>> Ramesh, Windows XP MVP
    >>>> http://windowsxp.mvps.org
    >>>>
    >>>>
    >>>> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >>>> news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    >>>>> OK, here's what I got:
    >>>>>
    >>>>> Windows Registry Editor Version 5.00
    >>>>>
    >>>>>
    >>>>>
    >>>>> [HKEY_CLASSES_ROOT\.jpeg]
    >>>>>
    >>>>> "PerceivedType"="image"
    >>>>>
    >>>>> @="MozillaJPEG"
    >>>>>
    >>>>
    >>>
    >>>
    >>
    >
    >
  9. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Yes, that's now what I'm seeing.

    "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    news:eWS5nipnFHA.4056@TK2MSFTNGP10.phx.gbl...
    > Is this the icon you're seeing?
    > http://windowsxp.mvps.org/images/thbimg.JPG
    >
    >>> the Photoshop icon is displaying in the File Types dialog
    >
    > Don't worry about that. Click the "Advanced" button and change the icon.
    > If nothing helps , try imgassofix.htm link a try.
    >
    > --
    > Ramesh, Windows XP MVP
    > http://windowsxp.mvps.org
    >
    >
    > "Mark Christensen" <markc@ssbrakes.com> wrote in message
    > news:uXEOPTpnFHA.3408@tk2msftngp13.phx.gbl...
    >> That's the thing - the Photoshop icon is displaying in the File Types
    >> dialog (just like it was before) but it is still not displaying in
    >> Windows Explorer nor in Photoshop's File > Open. Intead of the Netscape
    >> icon displaying, a mainly white icon with a little bit of orange and red
    >> in the center is displayed.
    >>
    >> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    >> news:OfAW0JpnFHA.2920@TK2MSFTNGP14.phx.gbl...
    >>> Use the File Types dialog to change the icon now.
    >>>
    >>> --
    >>> Ramesh, Windows XP MVP
    >>> http://windowsxp.mvps.org
    >>>
    >>>
    >>> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >>> news:enJW2IpnFHA.3544@TK2MSFTNGP15.phx.gbl...
    >>>> OK, the Netscape icon is no longer showing up next to the files, but
    >>>> the icon that is showing is still not the one I want. How change I
    >>>> change what icon is showing? I know I've done this before but can't
    >>>> remember how. I really appreciate the help!
    >>>>
    >>>> Mark
    >>>>
    >>>>
    >>>> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
    >>>> news:uqVwvApnFHA.3960@TK2MSFTNGP12.phx.gbl...
    >>>>> Type in Start, Run:
    >>>>>
    >>>>> cmd /c ASSOC .jpg=jpegfile
    >>>>> cmd /c ASSOC .jpeg=jpegfile
    >>>>>
    >>>>> Followed by this command:
    >>>>>
    >>>>> regsvr32 shimgvw.dll
    >>>>>
    >>>>> Logoff and login back.
    >>>>>
    >>>>> --
    >>>>> Ramesh, Windows XP MVP
    >>>>> http://windowsxp.mvps.org
    >>>>>
    >>>>>
    >>>>> "Mark Christensen" <markc@ssbrakes.com> wrote in message
    >>>>> news:uGzza9onFHA.2080@TK2MSFTNGP14.phx.gbl...
    >>>>>> OK, here's what I got:
    >>>>>>
    >>>>>> Windows Registry Editor Version 5.00
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> [HKEY_CLASSES_ROOT\.jpeg]
    >>>>>>
    >>>>>> "PerceivedType"="image"
    >>>>>>
    >>>>>> @="MozillaJPEG"
    >>>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>
    >>
    >
Ask a new question

Read More

Windows Explorer Photoshop Microsoft Windows XP