Sign in with
Sign up | Sign in
Your question

What if i cannot access windows advanced boot options menu on acer aspire

Last response: in Laptops & Notebooks
Share
February 19, 2013 6:31:39 PM

Hello,
I have an Acer Aspire 5610Z Series and I have had many issues with it. The other day I was on like normal then the computer froze. I tried to avoid the force shut down but it was my only option. When I went to turn it back on, it wouldn't do anything so I pressed F2 to try and enter safe mode. A window popped up stating that I need to insert the Device Media for the Drivers. Well first off, I don't have that disk anymore and my CD Drive hasn't worked in a couple years (rarely it will work for a short minute). When I tried to close the window, the computer froze again forcing me to shut it down. The next several attempts to try and enter safe mode and do a system restore failed. The computer will turn on, but will halfway load through the Boot Up Screen then freeze. Pressing F2 and F8 no longer work. And now the only way to shut down the computer is to unplug the power cord (the computer no longer runs on it's battery)...the screen will stay on for about 5 minutes, make several loud beeps, then shut down.

I have a feeling I might just need to get a new laptop. I've had it since 2007 and have had problems since 2010...
a b D Laptop
February 19, 2013 6:37:36 PM

I would try using the recovery partition and let it restore back to the factory install. I don't know what that is for your laptop, but it sometimes is the F10 key when booting-up. Usually you would lose anything that you had on it.
m
0
l
February 19, 2013 7:18:56 PM

it's F8 for safe mode.
m
0
l
a b D Laptop
February 19, 2013 8:07:12 PM




Press "Power" and turn on your Acer Aspire 5610Z.

2


Press and hold "ALT" on your keyboard.




3


Press and hold "F10" on your keyboard. This will boot your Acer Aspire 5610Z into the built-in recovery partition. Follow the directions on screen to recover your notebook computer

m
0
l
Related resources
!