Sign in with
Sign up | Sign in
Your question

Cannot set the Virtual Memory other than C drive

Last response: in Windows XP
Share
Anonymous
August 18, 2005 4:49:13 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Hi, I hope someone can help me
I recently reinstalled my WinXP SP2, I noticed windows
kept placing virtual memory pagefile into my C drive even
I set it to D drive.
Generally after I changed setting in the virtual memory
setting, after the first reboot, it was ok but when I reboot
again, it put the pagefile to C drive again. I went back
and looked at the setting, the setting showed the virtual
memory was set to D drive, ie as I set before, but
currently using C drive.

I didn't had this problem before i reinstall WinXP

I have 3 HDD, 2 of them running in raid 0
winxp installed in D drive in first partition of the
RAID array.
C Drive is partitioned to about 2GB FAT16 for
lagacy software etc...
D Drive about 60GB NTFS


Thanks
Anonymous
August 18, 2005 4:49:14 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Why put xp in D: drive,by default all software,updates,and xp itself
are set for C: You can set it to D: but why throw a wrench in it to begin
with.....As for the page file,in system properties,click on the drive and
adjust,
then click set 2X,if its not clicked twice,the settings usually wont take
place..

"hiryu" wrote:

> Hi, I hope someone can help me
> I recently reinstalled my WinXP SP2, I noticed windows
> kept placing virtual memory pagefile into my C drive even
> I set it to D drive.
> Generally after I changed setting in the virtual memory
> setting, after the first reboot, it was ok but when I reboot
> again, it put the pagefile to C drive again. I went back
> and looked at the setting, the setting showed the virtual
> memory was set to D drive, ie as I set before, but
> currently using C drive.
>
> I didn't had this problem before i reinstall WinXP
>
> I have 3 HDD, 2 of them running in raid 0
> winxp installed in D drive in first partition of the
> RAID array.
> C Drive is partitioned to about 2GB FAT16 for
> lagacy software etc...
> D Drive about 60GB NTFS
>
>
> Thanks
>
Anonymous
August 19, 2005 2:11:03 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thanks for you help

But I've tried what you said many times, the setting did take
palce but only for next boot, after that, it changed back
to use C: only after another reboot. But I can't set it
everytime before shuting down or rebooting my computer.
The other work around is keep C: full, so the windows would use
the D:, but this is not practical option.

BTW,

It doesn't matter which drive to install the winxp,
and the default of most software,updates,and xp is not set
for C:, they actually read the environment variables
eg %WINDIR% to know where winxp installed. Only poorly
written programs don't.

D drive is the first drive of RAID 0 array, so I want windows
to be installed in a fast drive.

C: drive, i've installed win98 and DOS for some of my legacy
software.


=?Utf-8?B?QW5kcmV3IEUu?= <eckrichco@msn.com> wrote in
news:D 99E871C-DC7B-44AF-93FE-D6018083F737@microsoft.com:

> Why put xp in D: drive,by default all software,updates,and xp itself
> are set for C: You can set it to D: but why throw a wrench in it to
> begin with.....As for the page file,in system properties,click on the
> drive and
> adjust,
> then click set 2X,if its not clicked twice,the settings usually wont
> take
> place..
Anonymous
August 19, 2005 2:25:35 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I solved the problem by puting the pagefile into other
partition of the RAID array (G: drive, still NTFS). I don't know
why the windows doesn't like my D: drive.
The only difference of G: is smaller.
!