Sign in with
Sign up | Sign in
Your question

Direct 3d problem?

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
November 13, 2001 3:00:58 AM

Heya, i never used to have this problem and i dont know when i began happening. Im running an AMD Athlon 1.2 with 256meg SDram and a Geforce 2 GTS 32meg (Asus 7700 deluxe) Im also running WINDOWS 2000 professional.

I recently installed UNREAL TOURNAMENT but noticed that the graphics were terrible. When attempting to run the game in Direct3d it is jerky and the graphics are terrible, even while running at a resolution of 640x480 with 16bit colors. Yet the game runs perfectly (although dark, and the brightness doesnt change) in OpenGL, i can even run at 1024x768+. At this time i had ASUS's most recent drivers for my video card and directX 8.0 installed.

I tried changing the drivers around, using nvidia's drivers and directX8.1 and using the UT 436 patch, but still no luck. It's strange seeing how I should have far better performance using Direct3d than OpenGL. Im also getting very poor framerates in VideoCard benchmarking programs (5.6fps in particle fury)..

Another thing is that Rogue Spear runs fine on my machine and im able to run at resolutions of 1280x1024+........

Does anyone have any idea what could possibly be going wrong.

More about : direct problem

November 13, 2001 11:28:39 AM

Re download direct X from www.microsoft.com/directx

Install it over the top of itself. Other than that, no real definate answers.
Anonymous
a b U Graphics card
November 13, 2001 1:06:00 PM

i've tried this, when switching from directX 8.0 to 8.1

no luck :( 

ahhhh! hellp
Related resources
November 13, 2001 8:27:27 PM

have you check with unreal (help) to see if its w2k problem? some game do not like that operating system
Anonymous
a b U Graphics card
November 13, 2001 8:59:52 PM

yes, i've checked unreals page and the build 436 version is recomended for windows 2000.... So im at a loss.

any other idea's?
Anonymous
a b U Graphics card
November 14, 2001 2:06:22 AM

I am having exactly the same problem with an ASUS 6800 GEForce 2 DDR card in UT. Stuttering when playing, slow frame rates, the whole magilla exactly as described. Switch to Open GL and all is OK for awhile (dark as described) but that didn't last either. I'm running Windows 98 so I doubt it can be traced to a single operating system.

PS I also tried to change to the newest NVidia drivers, DirectX 8, etc. No go. Worse actually so I went back to the ASUS 6800 drivers.
November 14, 2001 2:37:56 AM

There's a patch for teh OGL to make it run well. Try that.

If it's working...overclock it!
Anonymous
a b U Graphics card
November 14, 2001 4:21:18 AM

even if i do decide to run it in openGL my Direct3d performace is very poor, as shown in benchmarking programs.

:(  why do these kind of problems always happen to me .
Anonymous
a b U Graphics card
November 14, 2001 9:47:18 AM

I have a similar problem. My configuration is: AMD Athlon 1200MHz, Rhino KT133A-ASP mainboard with VIA chipset, Gainward Geforce2 MX200 graphics card with 32MB memory, SB 128 PCI, 256MB base memory, win2k + SP2, directX8.1

I tested my computer with MadOnion's 3DMark 2001 and the result was 1100. My friend have a system with AMD Duron 800 MHz, Geforce2 MX and win '98. His result was 2000.
I think my computer should outperform his but...

I have now tried following tricks to get it work:
- Updated VIA chipset drivers.
- Updated latest NVIDIA drivers.
- Updated directX8.0 to 8.1

Nothing helps. Im loosing my hope. Is downgrading to '98 only way to solve this?
Anonymous
a b U Graphics card
November 14, 2001 11:32:12 AM

You can rule out w2k being the problem (in general). UT runs on win2k on my machine perfectly.

You can also rule out any reinstalling. I've been using the same UT directory for years and simply zip it up and move it around when i'm doing reinstalls, then just unzip it again (its about 1.2Gb now!). So don't bother reinstalling it again.

<b>I never <i>was</i> that good with hardware theory</b> :eek: 
Anonymous
a b U Graphics card
November 14, 2001 12:55:55 PM

ahhhhhh! nothing seems to help. It's strange because i know people who are using win2k with a geforce256 without any trouble at all
Anonymous
a b U Graphics card
November 14, 2001 1:28:09 PM

I have just got a geforce2 mx400, im running a T-Bird 1gig on a Abit kt7. im using windows me and UT will not run under direct 3d. its fine in open GL, i tried the detonatorxp 21.80 drivers for the card and i reinstalled directx 8.0, but still get problems. my old voodoo4 4500 pci card was alot faster. the detonator 21.40 drivers are supposed to be the most stable drivers for geforce based cards.
November 14, 2001 2:05:20 PM

Try the AMD/Win2K AGP patch and also try loading the separate Via AGP 4.05C driver (as opposed to the 4-in-1 drivers). Also, the official version of DirectX 8.1 is now available. Links below.

<A HREF="http://www.amd.com/us-en/Processors/ProductInformation/..." target="_new">http://www.amd.com/us-en/Processors/ProductInformation/...;/A>

<A HREF="http://www.viaarena.com/?PageID=2" target="_new">http://www.viaarena.com/?PageID=2&lt;/A> (bottom of page)

<A HREF="http://www.microsoft.com/downloads/release.asp?ReleaseI..." target="_new">http://www.microsoft.com/downloads/release.asp?ReleaseI...;/A> (for Win2K only)

<b>We are all beta testers!</b>
Anonymous
a b U Graphics card
November 14, 2001 11:28:15 PM

nope :(  none of those things helped.

i had high hopes for the AMD patch too :( 
November 15, 2001 1:59:13 PM

Yesterday was a bad day, twice I misread messages and I forgot to ask a key question on your issue.

What motherboard are you using?

I assumed you have a motherboard with a Via Northbridge (probably because someone else mentioned Via drivers). No harm would have been done as only drivers for which you have hardware would have loaded. However, if you have an AMD northbridge you need different drivers. Get the AMD Driver Pack <A HREF="http://www.amd.com/us-en/Processors/ComputingSolutions/..." target="_new">here</A>. <b>(Warning, under no circumstances, load the AMD drivers unless you have an AMD Northbridge!!!!)</b>

<b>We are all beta testers!</b><P ID="edit"><FONT SIZE=-1><EM>Edited by phsstpok on 11/15/01 11:02 AM.</EM></FONT></P>
November 15, 2001 3:56:46 PM

Interesting problem.
Did you try to play other games with your system?
Try one or two directX games, and open gl games.
Try to alter graphic/3d setting in the UT game too.
November 15, 2001 5:16:38 PM

I don't suppose you have got active desktop enabled have you? (has win2K got it?)
I reinstalled win98 recently and forgot to disable it. My graphics were terrible, especially in D3D though. It took me ages to figure it out. I was doing my nut. As soon as i turned off the active desktop, my 3dmark scores went back over 7000, from about 3000.
Bit of a long shot, but I hope this solves your problem too.
Anonymous
a b U Graphics card
November 15, 2001 9:04:36 PM

Ed_Phoon: the only other game i've tried is Rogue Spear which was absolutly fine.
November 16, 2001 4:32:31 AM

Ok, this is a stretch but while I was troubleshooting a performance issue on my own system I discovered something that causes horrible "jerkiness". Maybe it's causing your problem. I enabled Video RAM caching in my BIOS and boom, where I had smooth game play I now get pauses every couple of seconds. Disable Video RAM caching and the problem is fixed. It's worth taking a look.

I found a BIOS tuning guide which contains an explanation of why Video RAM caching and Video BIOS caching actually degrades system performance.

<A HREF="http://www.adriansrojakpot.com/Speed_Demonz/BIOS_Guide/..." target="_new">http://www.adriansrojakpot.com/Speed_Demonz/BIOS_Guide/...;/A>

<b>We are all beta testers!</b>
November 16, 2001 4:34:26 PM

Someone in this forum said he solve his graphic/games problem by changing AGP aperture to 16mb, he's using win2k too, try it out!
Anonymous
a b U Graphics card
November 16, 2001 9:07:28 PM

still no luck, anyone have anymore idea's :( 
Anonymous
a b U Graphics card
November 16, 2001 9:39:11 PM

i did a test with 3dmark2000 and i got a score of 1538... ahh, what's wrong :( 

i cant seem to get above 7.5fps on direct3d aps
November 17, 2001 1:32:25 AM

1538? It sounds like AGP is not working except this can't be true if one or more of your games is performing well. From your original post it sounded like Direct3D were operating in some kind of software mode, non-accelerated, but that isn't likely either. Both of these are strange.

When you installed the 4-in-1 drivers or the AGP driver did you select "Turbo mode". Without this your AGP would operate at AGP 1X only. Turbo mode allows the choice of 2X and 4X. (Maybe the Win2K drivers don't work the same way. I don't use Win2K).

According to <A HREF="http://www.geforcefaq.com" target="_new">www.geforcefaq.com&lt;/A>, setting AGP aperture below 32MB will disable AGP, force your video card to work in PCI mode. What is your AGP Aperture size?

<b>We are all beta testers!</b>
Anonymous
a b U Graphics card
November 17, 2001 6:12:01 AM

everything was set up correctly for my card....

i finally fixed the problem with games. the card was set to use like 30meg ram... I upped it to like 55 and it seems to work fine. its still scoring low in benchmarks, but i dont care.
November 17, 2001 1:07:44 PM

30 meg? 55 meg? These are strange numbers. I was talking about checking AGP aperture in your BIOS. The options are usually 4, 8, 16, ... 256. They are powers of 2.

Are you by chance talking about "memory for textures" in the Display Manager. If you are, and making changes actually helps, then you do have a problem. That memory adjustment is for video when your video card is operating in PCI mode. If its helping your card then your card is not working in AGP mode.

<b>We are all beta testers!</b>
Anonymous
a b U Graphics card
November 18, 2001 5:21:05 AM

hmm yeah, that does seem to be whats going on.. i changed the "Maximum System Memory for Textures in PCI mode"

how did it get to be PCI? since the card is AGP? how do i change it back?
November 18, 2001 2:34:31 PM

Usually the VIA 4-in-1 drivers or the VIA AGP driver should activate AGP.

Try installing the 4-in-1 drivers but this time at the prompts select the uninstall option for each of the modules. When done reboot and reinstall the 4-in-1 drivers (with turbo mode). This should give you a cleaner installation of the drivers and hopefully they will work this time.

<b>We are all beta testers!</b>
Anonymous
a b U Graphics card
November 18, 2001 7:10:55 PM

Hi All,

I have been running an AMD 500Mz CPU with a VOODOO II card for a couple of years now (very successfully) and thought it high time to upgrade to a Creative GeForce2 GTS – better renditions, L & T, better frame rates etc. WRONG! True the frame rates are better – but only marginally.

A further problem that has manifested itself is the mouse pointer is very unstable. If the mouse is stationary, the pointer disappears. This problem only happens in 3D games, NOT on desktop or W/P etc. Could this be significant to the main problem?

How do I check if the AGP is working? There is no reference to AGP in BIOS (except AGP set to TURBO) or in any of the Control Panel set-ups.

In ‘Display Manager’ in ‘Memory for Textures’ setting, under ‘PCI Texture Memory Size’, it is indicating ‘Use up to 23Mb of system memory for textures in PCI mode’. Is this significant?

I use Win 98SE. I have the latest drivers from Creative, Direct X 8.1 installed and the latest AGP drivers for my motherboard (ASUS P5A-B).

I would very much welcome the combined knowledge of all you guru’s out there. I know you have helped many newbie’s in the past – please help me!

Cheers everyone,

Alan C
Anonymous
a b U Graphics card
November 18, 2001 9:54:14 PM

w00t! i think it's entirely fixed.... Im scoring a 6871 in 3dmark now, AND getting high FTS in all diagnostic programs.


The VIA 4-1 Drivers helped! thanks a bunch!
November 19, 2001 12:16:14 AM

You're welcome and congrats. You buy the next beer.

<b>We are all beta testers!</b>
November 19, 2001 12:39:11 AM

Not too many ideas.

You've already updated the AGP driver. How about the BIOS?

Check the mouse control panel and under pointers set schemes to <b>none</b>.

<b>We are all beta testers!</b>
November 19, 2001 12:50:11 AM

yep
i had extreemly poor direct3d results for my athlon/win2k box too

new chipset drivers helped a bit
new detonator 21.85 video drivers helped ALOT

Why do i feel like the lone sane voice in the mental assylum?
!