Sign in with
Sign up | Sign in
Your question

WinServ 2003 Enterprise: Fails Service Pack2 + RDP fails to init

Last response: in Business Computing
Share
October 18, 2012 6:58:03 PM

This one can be filed under "Family Tech Support"...

My parents have a Win2003 Enterprise, and a Win2008 R2 server for their business. The 2008 system is internal only, to support their accounting software, where the older 2003 is multi-homed and provides internet connectivity and web-stuffs. (I've referenced 2008 for the 'big-picture' so-to-speak, but it's irrelevant at the moment).
Once upon a time, the 2003 system was run headless to accept Remote Desktop connections, and supported all of the servicing (web, internet, software) just fine.

While Remote Desktop continues to function just fine, attempting to install Service Pack1 will fail, and then cause Remote Desktop to fail.

Before attempting to install Windows Server 2003 Service Pack 2, I cloned the drive so that I can mess with the duplicate vs "production" on the same hardware (different drive) so it only takes minutes to revert one way or another.

*SP1 fails with error: "Access denied" - and will attempt to reverse the installation.
*It would seem that the offending element is PCI.SYS.
*I've searched the internets several times, but any of the "fixes" I've found in the past ~2 years have not worked.
** Note - I've only just found this: http://social.technet.microsoft.com/Forums/it/windowsse... - and haven't had the opportunity to check (but it looks similar to things I've tried already).

Several things I have tried:
*When prompted to reverse the Service-Pack install by clicking "OK", by choosing to LOG OFF and log back on, those files already replaced remain replaced with SP2 files. However, upon doing so, Remote Desktop fails - so it must be logged on directly.

*Taking Ownership of pci.sys does not correct the SP upgrade-failure.

*Replacing pci.sys prior-to the upgrade attempt with a 'future version' (from 2008) does not correct the SP upgrade-failure.

*PCI.SYS can still be deleted, but I believe file-protection replaces it before the SP upgrade processes the file.

*Reinstall 2003 Ent. from disc; however, I receive 3 file-failures: One is Dx7-something, another has to do with OutlookExpress (I believe), and the other wasn't really important - but I can't remember what the three file-names were (off the top of my mind). The installation would complete by 'skipping' those files. ---- so in this test, I have continuing, perplexing conditions: The Remote tab isn't listed from the System Properties menu right on the fresh install, AND SP1 fails (identical to my previous mentioning). I have worked around to getting the Remote Tab to be displayed - and can force Remote Desktop services ON, but attempts to connect to the system via MSTSC/terminal continue to fail (as if the system wasn't even running RDC-services at all / port isn't opening). With the firewall off, the same condition for Remote Desktop exists...


So, I'm currently at a point where Windows Server 2003 Ent. needs to be upgraded, and/or re-installed - of which too, displays the same failure-condition.
With the PCI.SYS failing the SP upgrade, it's remotely possible that there's a hardware problem - but I doubt it since the system continues to operate just fine with the original installation.
IF the win2003 installation disc has a problem, is that something MS can verify our COA and replace the disc? (Yes, for their nominal fee, I'd expect)...

Anyway - if anyone has any thoughts or would like more information, please respond.
Thanks in advance!

** Edit - replaced SP1 in context with SP2 - I knew it should have been 2 ;) 
!