Sign in with
Sign up | Sign in
Your question

Sudden "Jerks" in D3D

Last response: in Graphics & Displays
Share
February 14, 2002 4:33:37 AM

OK I built a new computer
Heres the specs

AMD XP 1600+
ECS K7S5A mboard
GF2 GTS 32mb
Win98 se

When I run 3dmark 2000, the frame rate is very good and I score high. But every couple of seconds, there is a sudden pause or "jerk" and then the benchmark continues. This is very annoying to look at and wrecks gameplay. Please help me stop the jerks!


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!

More about : sudden jerks d3d

February 14, 2002 10:37:07 AM

You play 3DMark2000? If you're referring to real games then I recommend that you make sure V-Sync is on.

AMD technology + Intel technology = Intel/AMD Pentathlon IV; the <b>ULTIMATE</b> PC processor
February 14, 2002 2:08:32 PM

No it did it in GTA2 also (the only game on there right now). Its not tearing, the whole screen pauses for a split second, then constinues. This happens about every two seconds.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!
Related resources
Can't find your answer ? Ask !
February 14, 2002 2:56:18 PM

Maybe its the hard disk struggling to keep up? My system does this occasionally when pushed graphically...What type of HD do you have?
February 14, 2002 3:19:17 PM

Texture thrashing on that 32mb card? Try running with 16 bit texures for a bit to test this.
February 14, 2002 5:03:50 PM

How many RAM do you have? be sure that you set the AGP Aperture Size inside your BIOS to 1/2 of your system RAM (not video RAM).
Also be sure that you have the latest drivers from NVidia's site and that you installed all chipset drivers.

My case has so many fans that it hovers above the ground :eek:  .
February 14, 2002 6:04:47 PM

Be sure to stop any background programs that could be causing a conflict. They could be causing your video issues.

This is a non-smoking forum.
If your computer is smoking, please extinguish it immediately.
February 14, 2002 6:07:12 PM

Half your ram is a bit much. I usually try to set mine to double my Video card ram. However, I've found that I get worse performance with my 8500 with a 128 MB size than a 64MB size. Ultimately, it depends on what apps you are using, and if they even need the AGP Aperture.

This is a non-smoking forum.
If your computer is smoking, please extinguish it immediately.
February 15, 2002 1:10:52 AM

OK still have the problem. Gonna try reformatting tonight.
No offense, but all of the suggestion have helped little. The only one possible is that the hard drive isn't catching up but i doubt it. It a very consistent occurence, pauses quickly about once every 2-3 seconds.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!
February 15, 2002 1:14:26 AM

Oh, and I tried half-life and it still had the same problem in all video modes (D3D, openGL, sofware) So i guess its a problem with all 3d games.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!
February 15, 2002 2:30:15 AM

Turn off Video RAM Caching in your BIOS.

<b>We are all beta testers!</b>
February 15, 2002 3:43:13 AM

working now!

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!
February 15, 2002 4:06:18 PM

What fixed it?

<b>We are all beta testers!</b>
February 15, 2002 8:56:32 PM

I dont really know what was wrong, once i reformatted it was fixed.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Darbish Fish, Mmmmm Floppy!
a b U Graphics card
February 16, 2002 5:40:10 PM

Did someone call for a sudden jerk? OK, HERE GOES!!!
HEY IDIOT, TRY GETTING A FASTER CARD!
There, that's me being a sudden jerk!

What's the frequency, Kenneth?
February 17, 2002 3:54:41 AM

I have a gf3 and an athlon. 3dmark jerks for me too (and I get good scores too) but my games are fine. even the power guzzling Medal of Honour.

If your games jerk too try turning OFF agp2x or agp4x mode in your bios (whichever you see) you will get better performance with those off (but they may not stop 3dmark from being a jerk)
February 17, 2002 3:57:55 AM

"Half your ram is a bit much. I usually try to set mine to double my Video card ram"

Uh? those two are the same number on my comp. half my ram is 128. double my video ram is 128. I suspect the same is the case on most comps.
February 17, 2002 4:00:34 AM

"No offense, but all of the suggestion have helped little"

I know how you feel.
I had the same problem with my card. turning *off* agp2x or agp4x (whichever you have) helped me. It SHOULD be off.
February 17, 2002 4:06:04 AM

No offence to anyone but I see a lot of techsupport type answers here - "you know the wire at the back? follow it to the wall. is it plugged in?" type answers. rather than answers from experience. Just the ones I looked at.
Anonymous
a b U Graphics card
February 17, 2002 4:56:24 AM

A lot of persons have the same problem with Win XP. After a while, 3d games starts to stutter every 2-3 seconds and i never found a solution for this anywhere. The only solution that i have is to format and wish for the problem not to come back. This happens with any driver and because of that, i format every 2 weeks. If you look at forums on madonion.com and search for "stutter", you will find a lot of posts talking about this.
P3-700 at 933
Win XP Pro
P3B-F (440BX)
512MB RAM
V8200T2 Deluxe
a b U Graphics card
February 17, 2002 11:50:24 AM

Have you tried setting a 500mb min, 500mb max windows swap file. This can cause the problem you are describing. Windows is constantly changeing the swap file size,which will cause your system to stutter, as windows hogs resourses when constantly changeing swap file size.

I aint signing nothing!!!
February 17, 2002 2:42:31 PM

the problem of stuttering in win xp is caused by a driver conflict with the nvidia driver. the stack dump goes out of control (to a certain degree, not infinately)and the same bit of rendering gets re-done by the card, and then disgarded.this problem usually developes after a few games in d3d.

scansfield
February 17, 2002 3:36:36 PM

That could AGP thrashing. This is when the CPU is being over utiliesd and the graphics card under utilised. A couple of ways to prevent this is to reduce CPU utilisation (decrease sound quality requirements is one way), or increase graphics card usage (increase resolution).

This will drop your fps, but should reduce the amount of 'stutter'.

:cool: <b><font color=blue>The Cisco Kid</font color=blue></b> :cool:
Anonymous
a b U Graphics card
February 17, 2002 8:32:34 PM

Here are some things that work for me:

Set swap file to 2X the amount of ram you have, if you have 128 megs ram st swap file to no less than 256 and also no more than 256, this way the swap file is constant. 256 meg ram 512 swap file, get the picture.

If you are using Win 98 make sure to enable DMA mode on your Hard Drive. Win2k, XP it's done for you(no choice).

Make sure When you play games, certain TSR's are diabled, i.e, Hardware monitoring, realtime virus scanning, you can always re-enable these things later.

Also AMD has a registry patch on thier site specifically addressing an issue AMD processors handle large files, this one seems to be important, I was having some video issues and this fixed my problem.
Anonymous
a b U Graphics card
February 17, 2002 9:08:10 PM

"and the same bit of rendering gets re-done by the card, and then disgarded.this problem usually developes after a few games in d3d."
There's driver problem on a clean install of XP? and is there a solution to your explanation?
!