How to set owner and permission for a folder/file on Windo..

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

First, I still have problem to set a folder to be
private. It should be a VERY EAY task.
But when I right click the Property of a folder on D: drive
its "Make this private" check box is gray out.
So I can NOT make a folder be private in D: drive.

It seem to me the private folders are private
under "My Documents" in C: drive.

I read from Help, it says a drive MUST be NTFS

But I type

convert D: /fs:ntfs

It says my D drive already is NTFS format.
Since it already in NTFS, then why I can't
make it private?

Since I am system administrator at home for my
Windows XP. If I created new folders on D: drive
for my daughter and son.
I need to set the ownership, group and permission
for each user, make the folders be private.

How do I do these in step-by-step.
I am UNIX/LINUX system administrator.
It is a very easy task for me do
these in UNIX/LINUX, just type

mkdir folder_name # create a directory/folder
chown owner_name folder_name # set owner for a foler
chgrp group_name folder_name # set group for a folder
chmod u=rwx,g=rx,o=r folder_name # set permission
# owner read/write/execute;
# group read/execute;
# others read only

or

chmod u+rwx,g+rx-w,o+r-wx folder_name


How do I do all these in Windows XP Home edition?
Thank Q very much in advance!
1 answer Last reply
More about owner permission folder file windo
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    In news:dfk3br$tdk$1@news.nems.noaa.gov,
    RC <raymond.chui@nospam.noaa.gov> had this to say:

    My reply is at the bottom of your sent message:

    > First, I still have problem to set a folder to be
    > private. It should be a VERY EAY task.
    > But when I right click the Property of a folder on D: drive
    > its "Make this private" check box is gray out.
    > So I can NOT make a folder be private in D: drive.
    >
    > It seem to me the private folders are private
    > under "My Documents" in C: drive.
    >
    > I read from Help, it says a drive MUST be NTFS
    >
    > But I type
    >
    > convert D: /fs:ntfs
    >
    > It says my D drive already is NTFS format.
    > Since it already in NTFS, then why I can't
    > make it private?
    >
    > Since I am system administrator at home for my
    > Windows XP. If I created new folders on D: drive
    > for my daughter and son.
    > I need to set the ownership, group and permission
    > for each user, make the folders be private.
    >
    > How do I do these in step-by-step.
    > I am UNIX/LINUX system administrator.
    > It is a very easy task for me do
    > these in UNIX/LINUX, just type
    >
    > mkdir folder_name # create a directory/folder
    > chown owner_name folder_name # set owner for a foler
    > chgrp group_name folder_name # set group for a folder
    > chmod u=rwx,g=rx,o=r folder_name # set permission
    > # owner read/write/execute;
    > # group read/execute;
    > # others read only
    >
    > or
    >
    > chmod u+rwx,g+rx-w,o+r-wx folder_name
    >
    >
    > How do I do all these in Windows XP Home edition?
    > Thank Q very much in advance!

    Log on to safe mode, start > run > type "control folders" > click view tab >
    untick simple file sharing > make your changes.

    Safe Mode :
    http://kgiii.info/windows/all/general/safemode.html

    Galen
    --

    "You know that a conjurer gets no credit when once he has explained his
    trick; and if I show you too much of my method of working, you will
    come to the conclusion that I am a very ordinary individual after all."

    Sherlock Holmes
Ask a new question

Read More

Linux Administration Windows XP