Sign in with
Sign up | Sign in
Your question

Hard Drive Activity Slows Computer Considerably.

Last response: in Windows XP
Share
December 25, 2003 7:48:22 AM

System:
AMD XP 2500+ Barton (Runs at 95-100oF)
Kingston HyperX 512mb RAM 333mhz
Gigabyte GA-7VAXP Ultra (KT400)
MSI Geforce 4 Ti4600-8x (Runs at 95-100oF)
Antec 550W PSU
SB Live Platinum 5.1

Internal Case Temperature runs about 80-86oF

It seems that any time there is ANY hard drive activity, my computer starts being very choppy, if i do anything while an MP3 is playing, the MP3 gets really jittery. Any time the hard drive light so much as flickers while i'm playing a game, the computer freezes while the lgiht is on, if the light flickers constantly, the game gets really choppy and almost unplayable.

My virtual memory page file is on a seprate partition, and after setting it to "System Managed Size" i see some improvements, the light dosesent flicker constantly, but every time it does flicker, everything on the computer slows down considerably.

Hard Drive Setup:
Maxtor 40gb 7200rpm (Windows Drive & Swap Partition)
Samsung 40gb 5400rpm (Old crappy drive for old crappy files)
Maxtor 120gb 7200rpm (MP3's and other files)

All drives are defragged as of today.

Not sure what to do. can anyone give any suggestions?
December 25, 2003 3:31:59 PM

Have you installed the <A HREF="http://www.giga-byte.com/Motherboard/Support/Driver/Dri... Ultra.htm" target="_new">chipset drivers</A>, and then checked the DMA settings for the IDE channels in the Device Manager?

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
December 25, 2003 4:10:40 PM

XP hates partitions. No kidding...try dualing it with Linux...you have to do it a certain order and then XP will be ok with it. That being said, I recommend that you put your pagefile on the same partition as your windows installation. I think your performance will improve quite a bit. Thank Bill Gates for being gay...XP absolutely hates cross accessing partitions.

PS: Another thing to check is 'Control Panel' 'Sysem' 'Performance' 'Settings button' 'Advanced tab' and to make sure that you have programs selected for both memory and processor.

----------
<b>It is always brave to say what everyone thinks. </b> <i>Georges Duhamel</i>

TKS
Related resources
December 25, 2003 6:53:34 PM

well i was having this problem before i made that partition, i thought it might help a bit. so far its only gotten better because of it.

Both settings are set to "programs" and i have my chipset drivers installed, but i've never messed with DMA settings before... what should they be set to?

<P ID="edit"><FONT SIZE=-1><EM>Edited by draxsath on 12/25/03 03:54 PM.</EM></FONT></P>
December 25, 2003 8:24:03 PM

1. Under Device Manager, open IDE ATA/ATAPI Controllers.
2. On each of the Primary and Secondary IDE Channels, open up the Properties display by right-clicking.
3. In Properties, click on the Advanced Settings tab.
4. Make sure that the Current Transfer Mode is set to DMA if available, and not PIO.

Windows should automatically detect the correct DMA mode after a reboot, and with those HDDs, it should be at least Ultra DMA Mode 5, and perhaps 6, if the drive is ATA133.

If Windows does NOT set the correct DMA mode after the reboot, then the chipset drivers may need to be reinstalled, and/or the BIOS settings accessed to be sure that DMA is enabled at the hardware level.

Nearly all chipsets released since 1997 have supported Independent Device Timing, which allows for different devices on the same cable to run at different speeds, without slowing down the faster device to the speed of the slowest device. However, WinXP often sets all devices to PIO mode when first installed, without manual intervention from the user. CRC errors, which can come from damaged cables or incompatible devices will also cause Windows to force a device to operate in PIO mode.

Be certain that you have no PIO mode only devices sharing a cable with DMA-only devices, as this negates the IDT feature.

Having a dedicated partition for the page file should make little or no difference to the HDD performance in WinXP with the amount of physical memory installed in the system. It should also make no difference whether or not the page file is located in the partition that contains the system files.

Heck, I've got mine in a logical partition on a slaved disk, simply because it has never been accessed ... not with 512MB of RAM.

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
December 26, 2003 2:14:43 AM

When it boots up here is what it lists:
Primary Master - Maxtor 40gb (Windwos) - "ATA 133"
Primary Slave - Samsung 40gb (Crap Drive) - "ATA 100"
Secondary Master - DVD-ROM - "ATA 33"
Secondary Slave - CD-RW - "Pio 4"

Promise Card:
Pirmary Master - 120gb Maxtor - "DMA Mode 6"
Primary Slave - Toshiba DVD-RAM - "PIO 4"
Secondary Master - None
Secondary Slave - None

Windows Lists:
Primary IDE Channel Properties:
Device 0 - "DMA if available" - PIO Mode
Device 1 - "DMA if available" - Ultra DMA Mode 5

Secondary IDE Channel Properties:
Device 0 - "DMA if available" - Ultra DMA Mode 2
Device 1 - "DMA if available" - Multi-Word DMA Mode 2

As you can see, the CD-ROMs and Hard Drives are on different channels, so i dont think that IDT is the problem.

I've guessing "Device 0" means master and 1 means slave... in that case it looks like windows wants to run my main windows hard drive on PIO mode. Everything else in the windows settings concurs with whats on the bios settings except that, all other drives are running at thier optimal speeds. of course except the main drive, the most important one!

I'm going to reinstall my chipset drivers and see what happens.

BTW i've already run the maxtor diagnostic tool on my main hard drive and it came out clean.

ok reinstalling chipset drivers didnt work.

I have another IDE Cable sitting here i'll try replacing the one i have (although the one in there is only a few months old)

Ok that didnt work.

There has to be a way to force windows into DMA mode for a hard drive, i just don't know how.

any ideas?

<P ID="edit"><FONT SIZE=-1><EM>Edited by draxsath on 12/26/03 00:17 AM.</EM></FONT></P>
December 26, 2003 3:51:09 AM

Fixed it!

everything works perfect now!!!!

Running at Ultra DMA 6 (ATA133) like i should be.

Replacing the cable did nothing, reinstalling the drivers did nothing, but when i right clicked the primary ATA controller driver in the device manager, i selected "uninstall". After a few reboots it came up in the device manager as "Ultra DMA Mode 6".

Strange that reinstalling the drivers didnt do anything.

anyway... WOO! YAY!
!